<!DOCTYPE html>
<html lang="en-US">
<head>
<meta charset="UTF-8" >
<meta name="viewport" id="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=1.0, minimum-scale=1.0, user-scalable=no" />
<script data-cfasync="false" id="ao_optimized_gfonts_config" type="text/javascript">WebFontConfig={google:{families:["Advent Pro:700&subset=latin,latin-ext,cyrillic,cyrillic-ext,greek-ext,greek,vietnamese","Open Sans:700&subset=latin,latin-ext,cyrillic,cyrillic-ext,greek-ext,greek,vietnamese","Anton:400&subset=latin,latin-ext,cyrillic,cyrillic-ext,greek-ext,greek,vietnamese","Oswald:100,200,300,400,500,600,700,800,900&subset=latin,latin-ext,cyrillic,cyrillic-ext,greek-ext,greek,vietnamese","Oswald:100,200,300,400,500,600,700,800,900&subset=latin,latin-ext,cyrillic,cyrillic-ext,greek-ext,greek,vietnamese","Roboto:100,200,300,400,500,600,700,800,900&subset=latin,latin-ext,cyrillic,cyrillic-ext,greek-ext,greek,vietnamese","Roboto:100,200,300,400,500,600,700,800,900&subset=latin,latin-ext,cyrillic,cyrillic-ext,greek-ext,greek,vietnamese","PT Serif:100,200,300,400,500,600,700,800,900&subset=latin,latin-ext,cyrillic,cyrillic-ext,greek-ext,greek,vietnamese","Oswald:100,200,300,400,500,600,700,800,900&subset=latin,latin-ext,cyrillic,cyrillic-ext,greek-ext,greek,vietnamese"] },classes:false, events:false, timeout:1500};</script><link rel="shortcut icon" href="https://www.lockedondolphins.com/wp-content/uploads/2018/05/lockedondolphinsicon.jpg" /><link rel="pingback" href="https://www.lockedondolphins.com/xmlrpc.php" />
<meta property="og:type" content="article" />
					<meta property="og:image" content="https://www.lockedondolphins.com/wp-content/uploads/2019/09/USATSI_13329046-1000x600.jpg" />
		<meta name="twitter:image" content="https://www.lockedondolphins.com/wp-content/uploads/2019/09/USATSI_13329046-1000x600.jpg" />
	<meta property="og:url" content="https://www.lockedondolphins.com/dolphins/blown-out-by-baltimore-again-miami-dolphins-week-1-recap/" />
<meta property="og:title" content="Blown Out by Baltimore Again &#8211; Miami Dolphins Week 1 Recap" />
<meta property="og:description" content="Tanking might not be a strong enough word after the Dolphins endured its worst home defeat in franchise history Odds makers had Miami as a touchdown underdog in the 2019 season opener. Playing at home is worth three points alone, and the Ravens &#8212; winners of eight of the last nine head-to-head matchups with Miami [&hellip;]" />
<meta name="twitter:card" content="summary">
<meta name="twitter:url" content="https://www.lockedondolphins.com/dolphins/blown-out-by-baltimore-again-miami-dolphins-week-1-recap/">
<meta name="twitter:title" content="Blown Out by Baltimore Again &#8211; Miami Dolphins Week 1 Recap">
<meta name="twitter:description" content="Tanking might not be a strong enough word after the Dolphins endured its worst home defeat in franchise history Odds makers had Miami as a touchdown underdog in the 2019 season opener. Playing at home is worth three points alone, and the Ravens &#8212; winners of eight of the last nine head-to-head matchups with Miami [&hellip;]">
<link type="text/css" media="all" href="https://www.lockedondolphins.com/wp-content/cache/autoptimize/css/autoptimize_e49c9a58bfc4be99dcf491f2fb7639e8.css" rel="stylesheet" /><title>Blown Out by Baltimore Again - Miami Dolphins Week 1 Recap</title>
<link rel="amphtml" href="https://www.lockedondolphins.com/dolphins/blown-out-by-baltimore-again-miami-dolphins-week-1-recap/amp/" /><meta name="generator" content="AMP for WP 0.9.97.65"/><link href='https://fonts.gstatic.com' crossorigin='anonymous' rel='preconnect' />
<link href='https://ajax.googleapis.com' rel='preconnect' />
<link href='https://fonts.googleapis.com' rel='preconnect' />
<link rel="alternate" type="application/rss+xml" title="Locked On Dolphins &raquo; Feed" href="https://www.lockedondolphins.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Locked On Dolphins &raquo; Comments Feed" href="https://www.lockedondolphins.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Locked On Dolphins &raquo; Blown Out by Baltimore Again &#8211; Miami Dolphins Week 1 Recap Comments Feed" href="https://www.lockedondolphins.com/dolphins/blown-out-by-baltimore-again-miami-dolphins-week-1-recap/feed/" />












<link rel='https://api.w.org/' href='https://www.lockedondolphins.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.lockedondolphins.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.lockedondolphins.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='Scouting College Football&#8217;s Top 2020 Quarterbacks &#8211; Week 2' href='https://www.lockedondolphins.com/dolphins/draft/scouting-college-footballs-top-2020-quarterbacks-week-2/' />
<link rel='shortlink' href='https://www.lockedondolphins.com/?p=8069' />
<link rel="alternate" type="application/json+oembed" href="https://www.lockedondolphins.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.lockedondolphins.com%2Fdolphins%2Fblown-out-by-baltimore-again-miami-dolphins-week-1-recap%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.lockedondolphins.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.lockedondolphins.com%2Fdolphins%2Fblown-out-by-baltimore-again-miami-dolphins-week-1-recap%2F&#038;format=xml" />
<!-- start Simple Custom CSS and JS -->
<script type="text/javascript">
/* When the user clicks on the button, 
toggle between hiding and showing the dropdown content */
function myFunction() {
    document.getElementById("myDropdown").classList.toggle("show");
}

// Close the dropdown menu if the user clicks outside of it
window.onclick = function(event) {
  if (!event.target.matches('.dropbtn')) {

    var dropdowns = document.getElementsByClassName("dropdown-content");
    var i;
    for (i = 0; i < dropdowns.length; i++) {
      var openDropdown = dropdowns[i];
      if (openDropdown.classList.contains('show')) {
        openDropdown.classList.remove('show');
      }
    }
  }
}

</script>
<!-- end Simple Custom CSS and JS -->
<!-- start Simple Custom CSS and JS -->

<!-- end Simple Custom CSS and JS -->

            <script>
                (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
                (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
                m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
                })(window,document,'script','//www.google-analytics.com/analytics.js','gaplusu');

                function gaplus_track() {
                                                gaplusu('create', 'UA-106810897-1 ', 'auto');
                                                    gaplusu('set', 'anonymizeIp', true);
                                                                            gaplusu('require', 'displayfeatures');
                                                                            gaplusu('send', 'pageview');
                    
                                    }

                                    gaplus_track();
                
            </script>

		<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script>
  (adsbygoogle = window.adsbygoogle || []).push({
    google_ad_client: "ca-pub-3311849153835630",
    enable_page_level_ads: true
  });
</script><!-- SEO meta tags powered by SmartCrawl https://premium.wpmudev.org/project/smartcrawl-wordpress-seo/ -->
<meta name="description" content="Tanking might not be a strong enough word after the Dolphins endured its worst home defeat in franchise history Odds makers had Miami as a touchdown underdog in the 2019 season opener. Playing at home is worth three points alone, and the Ravens -- winners of eight of the last nine head-to-head m ..." />
<meta name="google-site-verification" content="VcvW7atgyXYq3Tb5JeSRSUr2vLMMZ9Rtro-Ik52-GSU" />
<meta name="msvalidate.01" content="0B5AABFBD8EC8B2555A2D0CC5B983691" />
<meta property="og:type" content="article" />
<meta property="og:url" content="https://www.lockedondolphins.com/dolphins/blown-out-by-baltimore-again-miami-dolphins-week-1-recap/" />
<meta property="og:title" content="Blown Out by Baltimore Again - Miami Dolphins Week 1 Recap" />
<meta property="og:description" content="Tanking might not be a strong enough word after the Dolphins endured its worst home defeat in franchise history Odds makers had Miami as a touchdown underdog in the 2019 season opener. Playing at home is worth three points alone, and the Ravens -- winners of eight of the last nine head-to-head m ..." />
<meta property="og:image" content="https://www.lockedondolphins.com/wp-content/uploads/2019/09/USATSI_13329046-1000x600.jpg" />
<meta property="article:published_time" content="2019-09-08T22:03:23" />
<meta property="article:author" content="Travis Wingfield" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:site" content="LockedonPhins" />
<meta name="twitter:title" content="Blown Out by Baltimore Again - Miami Dolphins Week 1 Recap" />
<meta name="twitter:description" content="Tanking might not be a strong enough word after the Dolphins endured its worst home defeat in franchise history Odds makers had Miami as a touchdown underdog in the 2019 season opener. Playing at home is worth three points alone, and the Ravens -- winners of eight of the last nine head-to-head m ..." />
<meta name="twitter:image" content="https://www.lockedondolphins.com/wp-content/uploads/2019/09/USATSI_13329046-1000x600.jpg" />
<!-- /SEO -->
<script>if (document.location.protocol != "https:") {document.location = document.URL.replace(/^http:/i, "https:");}</script><script type='text/javascript' src='https://www.lockedondolphins.com/wp-includes/js/jquery/jquery.js'></script>
<script type='text/javascript' src='https://www.lockedondolphins.com/wp-includes/js/jquery/jquery-migrate.min.js'></script>

	<script data-cfasync="false" id="ao_optimized_gfonts_webfontloader" type="text/javascript">(function() {var wf = document.createElement('script');wf.src='https://ajax.googleapis.com/ajax/libs/webfont/1/webfont.js';wf.type='text/javascript';wf.async='true';var s=document.getElementsByTagName('script')[0];s.parentNode.insertBefore(wf, s);})();</script></head>
<body data-rsssl=1 class="post-template-default single single-post postid-8069 single-format-standard custom-background cookies-not-set desktop">
	<div id="mvp-fly-wrap">
	<div id="mvp-fly-menu-top" class="left relative">
		<div class="mvp-fly-top-out left relative">
			<div class="mvp-fly-top-in">
				<div id="mvp-fly-logo" class="left relative">
											<a href="https://www.lockedondolphins.com/"><img src="https://www.lockedondolphins.com/wp-content/uploads/2019/02/Locked-On-Dolphins-Podcast-Website-Logo-1.png" alt="Locked On Dolphins" data-rjs="2" /></a>
									</div><!--mvp-fly-logo-->
			</div><!--mvp-fly-top-in-->
			<div class="mvp-fly-but-wrap mvp-fly-but-menu mvp-fly-but-click">
				<span></span>
				<span></span>
				<span></span>
				<span></span>
			</div><!--mvp-fly-but-wrap-->
		</div><!--mvp-fly-top-out-->
	</div><!--mvp-fly-menu-top-->
	<div id="mvp-fly-menu-wrap">
		<nav class="mvp-fly-nav-menu left relative">
			<div class="menu-dolphins-main-nav-new-container"><ul id="menu-dolphins-main-nav-new" class="menu"><li id="menu-item-5318" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5318"><a href="https://www.lockedondolphins.com/category/dolphins/news/">News</a></li>
<li id="menu-item-5319" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5319"><a href="https://www.lockedondolphins.com/category/dolphins/draft/">NFL Draft</a></li>
<li id="menu-item-5409" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5409"><a href="https://cms.megaphone.fm/channel/lockedondolphins">Podcast</a></li>
<li id="menu-item-5321" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5321"><a href="https://www.lockedondolphins.com/category/dolphins/scouting/">Scouting</a></li>
<li id="menu-item-5322" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-5322"><a href="#">Subscribe to Podcast</a>
<ul class="sub-menu">
	<li id="menu-item-5323" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5323"><a href="https://itunes.apple.com/us/podcast/locked-on-dolphins/id1137170219?mt=2">Apple Podcast</a></li>
	<li id="menu-item-5324" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5324"><a href="https://play.google.com/music/listen?u=0#/ps/Ins66r5pdzmd3byrgo6kkibuw5a">Google Play</a></li>
	<li id="menu-item-5325" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5325"><a href="https://open.spotify.com/show/1h5AvikBOVYhqtI7zuuUU7">Spotify</a></li>
	<li id="menu-item-5326" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5326"><a href="https://tunein.com/podcasts/Sports--Recreation-Podcasts/Locked-on-Dolphins-p1025314/">TuneIn</a></li>
</ul>
</li>
</ul></div>		</nav>
	</div><!--mvp-fly-menu-wrap-->
	<div id="mvp-fly-soc-wrap">
		<span class="mvp-fly-soc-head">Connect with us</span>
		<ul class="mvp-fly-soc-list left relative">
										<li><a href="https://twitter.com/lockedonphins" target="_blank" class="fa fa-twitter fa-2"></a></li>
																							</ul>
	</div><!--mvp-fly-soc-wrap-->
</div><!--mvp-fly-wrap-->	<div id="mvp-site" class="left relative">
		<div id="mvp-search-wrap">
			<div id="mvp-search-box">
				<form method="get" id="searchform" action="https://www.lockedondolphins.com/">
	<input type="text" name="s" id="s" value="Search" onfocus='if (this.value == "Search") { this.value = ""; }' onblur='if (this.value == "") { this.value = "Search"; }' />
	<input type="hidden" id="searchsubmit" value="Search" />
</form>			</div><!--mvp-search-box-->
			<div class="mvp-search-but-wrap mvp-search-click">
				<span></span>
				<span></span>
			</div><!--mvp-search-but-wrap-->
		</div><!--mvp-search-wrap-->
				<div id="mvp-site-wall" class="left relative">
											<div id="mvp-leader-wrap">
					<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Locked On Dolphins 728x90 Leaderboard -->
<ins class="adsbygoogle"
     style="display:inline-block;width:728px;height:90px"
     data-ad-client="ca-pub-3311849153835630"
     data-ad-slot="8371817379"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>				</div><!--mvp-leader-wrap-->
										<div id="mvp-site-main" class="left relative">
			<header id="mvp-main-head-wrap" class="left relative">
									<nav id="mvp-main-nav-wrap" class="left relative">
						<div id="mvp-main-nav-top" class="left relative">
							<div class="mvp-main-box">
								<div id="mvp-nav-top-wrap" class="left relative">
									<div class="mvp-nav-top-right-out left relative">
										<div class="mvp-nav-top-right-in">
											<div class="mvp-nav-top-cont left relative">
												<div class="mvp-nav-top-left-out relative">
													<div class="mvp-nav-top-left">
														<div class="mvp-nav-soc-wrap">
																																														<a href="https://twitter.com/lockedonphins" target="_blank"><span class="mvp-nav-soc-but fa fa-twitter fa-2"></span></a>
																																																											</div><!--mvp-nav-soc-wrap-->
														<div class="mvp-fly-but-wrap mvp-fly-but-click left relative">
															<span></span>
															<span></span>
															<span></span>
															<span></span>
														</div><!--mvp-fly-but-wrap-->
													</div><!--mvp-nav-top-left-->
													<div class="mvp-nav-top-left-in">
														<div class="mvp-nav-top-mid left relative" itemscope itemtype="http://schema.org/Organization">
																															<a class="mvp-nav-logo-reg" itemprop="url" href="https://www.lockedondolphins.com/"><img itemprop="logo" src="https://www.lockedondolphins.com/wp-content/uploads/2019/02/Locked-On-Dolphins-Podcast-Website-Logo.png" alt="Locked On Dolphins" data-rjs="2" /></a>
																																														<a class="mvp-nav-logo-small" href="https://www.lockedondolphins.com/"><img src="https://www.lockedondolphins.com/wp-content/uploads/2019/02/Locked-On-Dolphins-Podcast-Website-Logo-1.png" alt="Locked On Dolphins" data-rjs="2" /></a>
																																														<h2 class="mvp-logo-title">Locked On Dolphins</h2>
																																														<div class="mvp-drop-nav-title left">
																	<h4>Blown Out by Baltimore Again &#8211; Miami Dolphins Week 1 Recap</h4>
																</div><!--mvp-drop-nav-title-->
																													</div><!--mvp-nav-top-mid-->
													</div><!--mvp-nav-top-left-in-->
												</div><!--mvp-nav-top-left-out-->
											</div><!--mvp-nav-top-cont-->
										</div><!--mvp-nav-top-right-in-->
										<div class="mvp-nav-top-right">
																						<span class="mvp-nav-search-but fa fa-search fa-2 mvp-search-click"></span>
										</div><!--mvp-nav-top-right-->
									</div><!--mvp-nav-top-right-out-->
								</div><!--mvp-nav-top-wrap-->
							</div><!--mvp-main-box-->
						</div><!--mvp-main-nav-top-->
						<div id="mvp-main-nav-bot" class="left relative">
							<div id="mvp-main-nav-bot-cont" class="left">
								<div class="mvp-main-box">
									<div id="mvp-nav-bot-wrap" class="left">
										<div class="mvp-nav-bot-right-out left">
											<div class="mvp-nav-bot-right-in">
												<div class="mvp-nav-bot-cont left">
													<div class="mvp-nav-bot-left-out">
														<div class="mvp-nav-bot-left left relative">
															<div class="mvp-fly-but-wrap mvp-fly-but-click left relative">
																<span></span>
																<span></span>
																<span></span>
																<span></span>
															</div><!--mvp-fly-but-wrap-->
														</div><!--mvp-nav-bot-left-->
														<div class="mvp-nav-bot-left-in">
															<div class="mvp-nav-menu left">
																<div class="menu-dolphins-main-nav-new-container"><ul id="menu-dolphins-main-nav-new-1" class="menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5318"><a href="https://www.lockedondolphins.com/category/dolphins/news/">News</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5319"><a href="https://www.lockedondolphins.com/category/dolphins/draft/">NFL Draft</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5409"><a href="https://cms.megaphone.fm/channel/lockedondolphins">Podcast</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5321"><a href="https://www.lockedondolphins.com/category/dolphins/scouting/">Scouting</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-5322"><a href="#">Subscribe to Podcast</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5323"><a href="https://itunes.apple.com/us/podcast/locked-on-dolphins/id1137170219?mt=2">Apple Podcast</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5324"><a href="https://play.google.com/music/listen?u=0#/ps/Ins66r5pdzmd3byrgo6kkibuw5a">Google Play</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5325"><a href="https://open.spotify.com/show/1h5AvikBOVYhqtI7zuuUU7">Spotify</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5326"><a href="https://tunein.com/podcasts/Sports--Recreation-Podcasts/Locked-on-Dolphins-p1025314/">TuneIn</a></li>
</ul>
</li>
</ul></div>															</div><!--mvp-nav-menu-->
														</div><!--mvp-nav-bot-left-in-->
													</div><!--mvp-nav-bot-left-out-->
												</div><!--mvp-nav-bot-cont-->
											</div><!--mvp-nav-bot-right-in-->
											<div class="mvp-nav-bot-right left relative">
												<span class="mvp-nav-search-but fa fa-search fa-2 mvp-search-click"></span>
											</div><!--mvp-nav-bot-right-->
										</div><!--mvp-nav-bot-right-out-->
									</div><!--mvp-nav-bot-wrap-->
								</div><!--mvp-main-nav-bot-cont-->
							</div><!--mvp-main-box-->
						</div><!--mvp-main-nav-bot-->
					</nav><!--mvp-main-nav-wrap-->
							</header><!--mvp-main-head-wrap-->
			<div id="mvp-main-body-wrap" class="left relative"><article id="mvp-article-wrap" itemscope itemtype="http://schema.org/NewsArticle">
			<meta itemscope itemprop="mainEntityOfPage"  itemType="https://schema.org/WebPage" itemid="https://www.lockedondolphins.com/dolphins/blown-out-by-baltimore-again-miami-dolphins-week-1-recap/"/>
						<div id="mvp-article-cont" class="left relative">
			<div class="mvp-main-box">
				<div id="mvp-post-main" class="left relative">
										<div class="mvp-post-main-out left relative">
						<div class="mvp-post-main-in">
							<div id="mvp-post-content" class="left relative">
																	<header id="mvp-post-head" class="left relative">
										<h3 class="mvp-post-cat left relative"><a class="mvp-post-cat-link" href="https://www.lockedondolphins.com/category/dolphins/"><span class="mvp-post-cat left">Miami Dolphins</span></a></h3>
										<h1 class="mvp-post-title left entry-title" itemprop="headline">Blown Out by Baltimore Again &#8211; Miami Dolphins Week 1 Recap</h1>
																															<div class="mvp-author-info-wrap left relative">
												<div class="mvp-author-info-thumb left relative">
													<img src="https://www.lockedondolphins.com/wp-content/uploads/2019/06/Profile-80x80.jpg" width="46" height="46" alt="Travis Wingfield" class="avatar avatar-46 wp-user-avatar wp-user-avatar-46 alignnone photo" />												</div><!--mvp-author-info-thumb-->
												<div class="mvp-author-info-text left relative">
													<div class="mvp-author-info-date left relative">
														<p>Published</p> <span class="mvp-post-date">1 hour ago</span> <p>on</p> <span class="mvp-post-date updated"><time class="post-date updated" itemprop="datePublished" datetime="2019-09-08">September 8, 2019</time></span>
														<meta itemprop="dateModified" content="2019-09-08"/>
													</div><!--mvp-author-info-date-->
													<div class="mvp-author-info-name left relative" itemprop="author" itemscope itemtype="https://schema.org/Person">
														<p>By</p> <span class="author-name vcard fn author" itemprop="name"><a href="https://www.lockedondolphins.com/author/twingfield/" title="Posts by Travis Wingfield" rel="author">Travis Wingfield</a></span> <a href="" class="mvp-twit-but" target="_blank"><span class="mvp-author-info-twit-but"><i class="fa fa-twitter fa-2"></i></span></a>
													</div><!--mvp-author-info-name-->
												</div><!--mvp-author-info-text-->
											</div><!--mvp-author-info-wrap-->
																			</header>
																																																														<div id="mvp-post-feat-img" class="left relative mvp-post-feat-img-wide2" itemprop="image" itemscope itemtype="https://schema.org/ImageObject">
												<img width="892" height="600" src="https://www.lockedondolphins.com/wp-content/uploads/2019/09/USATSI_13329046.jpg" class="attachment- size- wp-post-image" alt="" srcset="https://www.lockedondolphins.com/wp-content/uploads/2019/09/USATSI_13329046.jpg 892w, https://www.lockedondolphins.com/wp-content/uploads/2019/09/USATSI_13329046-300x202.jpg 300w, https://www.lockedondolphins.com/wp-content/uploads/2019/09/USATSI_13329046-768x517.jpg 768w" sizes="(max-width: 892px) 100vw, 892px" />																								<meta itemprop="url" content="https://www.lockedondolphins.com/wp-content/uploads/2019/09/USATSI_13329046-1000x600.jpg">
												<meta itemprop="width" content="1000">
												<meta itemprop="height" content="600">
											</div><!--mvp-post-feat-img-->
																																																														<div id="mvp-content-wrap" class="left relative">
									<div class="mvp-post-soc-out right relative">
																																		<div class="mvp-post-soc-wrap left relative">
		<ul class="mvp-post-soc-list left relative">
			<a href="#" onclick="window.open('http://www.facebook.com/sharer.php?u=https://www.lockedondolphins.com/dolphins/blown-out-by-baltimore-again-miami-dolphins-week-1-recap/&amp;t=Blown Out by Baltimore Again &#8211; Miami Dolphins Week 1 Recap', 'facebookShare', 'width=626,height=436'); return false;" title="Share on Facebook">
			<li class="mvp-post-soc-fb">
				<i class="fa fa-2 fa-facebook" aria-hidden="true"></i>
			</li>
			</a>
			<a href="#" onclick="window.open('http://twitter.com/share?text=Blown Out by Baltimore Again &#8211; Miami Dolphins Week 1 Recap -&amp;url=https://www.lockedondolphins.com/dolphins/blown-out-by-baltimore-again-miami-dolphins-week-1-recap/', 'twitterShare', 'width=626,height=436'); return false;" title="Tweet This Post">
			<li class="mvp-post-soc-twit">
				<i class="fa fa-2 fa-twitter" aria-hidden="true"></i>
			</li>
			</a>
			<a href="#" onclick="window.open('http://pinterest.com/pin/create/button/?url=https://www.lockedondolphins.com/dolphins/blown-out-by-baltimore-again-miami-dolphins-week-1-recap/&amp;media=https://www.lockedondolphins.com/wp-content/uploads/2019/09/USATSI_13329046-1000x600.jpg&amp;description=Blown Out by Baltimore Again &#8211; Miami Dolphins Week 1 Recap', 'pinterestShare', 'width=750,height=350'); return false;" title="Pin This Post">
			<li class="mvp-post-soc-pin">
				<i class="fa fa-2 fa-pinterest-p" aria-hidden="true"></i>
			</li>
			</a>
			<a href="/cdn-cgi/l/email-protection#c1feb2b4a3aba4a2b5fc83adaeb6afe18eb4b5e1a3b8e183a0adb5a8acaeb3a4e180a6a0a8afe1e7e2f9f3f0f0fae18ca8a0aca8e185aeadb1a9a8afb2e196a4a4aae1f0e193a4a2a0b1e7a0acb1fa838e8598fc88e1a7aeb4afa5e1b5a9a8b2e1a0b3b5a8a2ada4e1a8afb5a4b3a4b2b5a8afa6e1a0afa5e1b5a9aeb4a6a9b5e1aea7e1b2a9a0b3a8afa6e1a8b5e1b6a8b5a9e1b8aeb4efe182a9a4a2aae1a8b5e1aeb4b5fbe1a9b5b5b1b2fbeeeeb6b6b6efadaea2aaa4a5aeafa5aeadb1a9a8afb2efa2aeaceea5aeadb1a9a8afb2eea3adaeb6afecaeb4b5eca3b8eca3a0adb5a8acaeb3a4eca0a6a0a8afecaca8a0aca8eca5aeadb1a9a8afb2ecb6a4a4aaecf0ecb3a4a2a0b1ee">
			<li class="mvp-post-soc-email">
				<i class="fa fa-2 fa-envelope" aria-hidden="true"></i>
			</li>
			</a>
												<a href="https://www.lockedondolphins.com/dolphins/blown-out-by-baltimore-again-miami-dolphins-week-1-recap/#comments">
					<li class="mvp-post-soc-com mvp-com-click">
						<i class="fa fa-2 fa-commenting" aria-hidden="true"></i>
					</li>
					</a>
									</ul>
	</div><!--mvp-post-soc-wrap-->
	<div id="mvp-soc-mob-wrap">
		<div class="mvp-soc-mob-out left relative">
			<div class="mvp-soc-mob-in">
				<div class="mvp-soc-mob-left left relative">
					<ul class="mvp-soc-mob-list left relative">
						<a href="#" onclick="window.open('http://www.facebook.com/sharer.php?u=https://www.lockedondolphins.com/dolphins/blown-out-by-baltimore-again-miami-dolphins-week-1-recap/&amp;t=Blown Out by Baltimore Again &#8211; Miami Dolphins Week 1 Recap', 'facebookShare', 'width=626,height=436'); return false;" title="Share on Facebook">
						<li class="mvp-soc-mob-fb">
							<i class="fa fa-facebook" aria-hidden="true"></i><span class="mvp-soc-mob-fb">Share</span>
						</li>
						</a>
						<a href="#" onclick="window.open('http://twitter.com/share?text=Blown Out by Baltimore Again &#8211; Miami Dolphins Week 1 Recap -&amp;url=https://www.lockedondolphins.com/dolphins/blown-out-by-baltimore-again-miami-dolphins-week-1-recap/', 'twitterShare', 'width=626,height=436'); return false;" title="Tweet This Post">
						<li class="mvp-soc-mob-twit">
							<i class="fa fa-twitter" aria-hidden="true"></i><span class="mvp-soc-mob-fb">Tweet</span>
						</li>
						</a>
						<a href="#" onclick="window.open('http://pinterest.com/pin/create/button/?url=https://www.lockedondolphins.com/dolphins/blown-out-by-baltimore-again-miami-dolphins-week-1-recap/&amp;media=https://www.lockedondolphins.com/wp-content/uploads/2019/09/USATSI_13329046-1000x600.jpg&amp;description=Blown Out by Baltimore Again &#8211; Miami Dolphins Week 1 Recap', 'pinterestShare', 'width=750,height=350'); return false;" title="Pin This Post">
						<li class="mvp-soc-mob-pin">
							<i class="fa fa-pinterest-p" aria-hidden="true"></i>
						</li>
						</a>
						<a href="whatsapp://send?text=Blown Out by Baltimore Again &#8211; Miami Dolphins Week 1 Recap https://www.lockedondolphins.com/dolphins/blown-out-by-baltimore-again-miami-dolphins-week-1-recap/"><div class="whatsapp-share"><span class="whatsapp-but1">
						<li class="mvp-soc-mob-what">
							<i class="fa fa-whatsapp" aria-hidden="true"></i>
						</li>
						</a>
						<a href="/cdn-cgi/l/email-protection#efd09c9a8d858a8c9bd2ad83809881cfa09a9bcf8d96cfad8e839b8682809d8acfae888e8681cfc9ccd7dddeded4cfa2868e8286cfab80839f8786819ccfb88a8a84cfdecfbd8a8c8e9fc98e829fd4ada0abb6d2a6cf89809a818bcf9b87869ccf8e9d9b868c838acf86819b8a9d8a9c9b868188cf8e818bcf9b87809a88879bcf8089cf9c878e9d868188cf869bcf98869b87cf96809ac1cfac878a8c84cf869bcf809a9bd5cf879b9b9f9cd5c0c0989898c183808c848a8b80818b80839f8786819cc18c8082c08b80839f8786819cc08d83809881c2809a9bc28d96c28d8e839b8682809d8ac28e888e8681c282868e8286c28b80839f8786819cc2988a8a84c2dec29d8a8c8e9fc0">
						<li class="mvp-soc-mob-email">
							<i class="fa fa-envelope-o" aria-hidden="true"></i>
						</li>
						</a>
																					<a href="https://www.lockedondolphins.com/dolphins/blown-out-by-baltimore-again-miami-dolphins-week-1-recap/#comments">
								<li class="mvp-soc-mob-com mvp-com-click">
									<i class="fa fa-comment-o" aria-hidden="true"></i>
								</li>
								</a>
																		</ul>
				</div><!--mvp-soc-mob-left-->
			</div><!--mvp-soc-mob-in-->
			<div class="mvp-soc-mob-right left relative">
				<i class="fa fa-ellipsis-h" aria-hidden="true"></i>
			</div><!--mvp-soc-mob-right-->
		</div><!--mvp-soc-mob-out-->
	</div><!--mvp-soc-mob-wrap-->
																															<div class="mvp-post-soc-in">
											<div id="mvp-content-body" class="left relative">
												<div id="mvp-content-body-top" class=left relative">
																																							<div id="mvp-content-main" class="left relative">
														<h2>Tanking might not be a strong enough word after the Dolphins endured its worst home defeat in franchise history</h2>
<p>Odds makers had Miami as a touchdown underdog in the 2019 season opener. Playing at home is worth three points alone, and the Ravens &#8212; winners of eight of the last nine head-to-head matchups with Miami &#8212; have always given this Dolphins team fits.</p>
<p>None of those losses, even with most of them coming in embarrassing fashion, were as convincing as the beating <strong>Brian Flores</strong> and his team took in the Rookie Head Coach’s debut.</p>
<p>&nbsp;</p>
<table>
<tbody>
<tr>
<td width="156"><strong>Stat</strong></td>
<td width="156"><span style="color: #008080;"><strong>Dolphins</strong></span></td>
<td width="156"><span style="color: #800080;"><strong>Ravens</strong></span></td>
</tr>
<tr>
<td width="156">Total Yards</td>
<td width="156">200</td>
<td width="156">643</td>
</tr>
<tr>
<td width="156">Rushing</td>
<td width="156">21</td>
<td width="156">265</td>
</tr>
<tr>
<td width="156">Passing</td>
<td width="156">179</td>
<td width="156">378</td>
</tr>
<tr>
<td width="156">Penalties</td>
<td width="156">9 for 64 yards</td>
<td width="156">4 for 40 yards</td>
</tr>
<tr>
<td width="156">3<sup>rd</sup>/4<sup>th</sup>Down</td>
<td width="156">3/10 (30%)</td>
<td width="156">9/13 (69.2%)</td>
</tr>
<tr>
<td width="156">Sacks For</td>
<td width="156">1</td>
<td width="156">3</td>
</tr>
<tr>
<td width="156">TOP</td>
<td width="156">19:53</td>
<td width="156">40:07</td>
</tr>
</tbody>
</table>
<p>&nbsp;</p>
<p>We knew the offensive line play was going to be bad &#8212; to the tune of three sacks, 12 additional quarterback pressure, and six tackles for loss.</p>
<p>We knew the quarterback play would be spotty &#8212; surprisingly decent after a truly terrible interception on Miami first drive.</p>
<p>It was the issues on defense, particularly in the back-seven, that were alarming. The alarms were allegedly going off in the Dolphins post-game locker room as well, as <a href="https://profootballtalk.nbcsports.com/2019/09/08/early-mutiny-in-miami/?fbclid=IwAR1Sw8aNH1HCGCBabHPu2z7DU4s6XiOCPnrcNPyzPEcyAejwwNodSojZE_o"><em>Pro Football Talk</em> reported</a> that multiple Miami veterans phoned their agents in hopes of getting out of town via a trade.</p>
<p>Many questions arise from this upsetting report, none bigger than those directed at the individuals attached to the rumor. And if these players were part of the 49-point loss, the biggest home defeat in franchise history, do we actually want those guys as part of the future? Especially if they can bring back draft compensation?</p>
<p>Speculation would point to veterans like R<strong>eshad Jones</strong>,<strong> Daniel Kilgore</strong>, <strong>Albert Wilson</strong> or <strong>Bobby McCain</strong>, but might <strong>Minkah Fitzpatrick</strong> be involved in that conversation? We’ll get to his performance in the position-by-position portion of this column, but complaints of misusage can be <a href="http://www.nfl.com/news/story/0ap3000001041365/article/minkahs-mom-objects-to-son-playing-out-of-position">traced back to training camp</a>.</p>
<p><strong>Fitzpatrick</strong> made no qualms about his frustration on the field. Going from playing for college football’s national title every year, to the perpetually mediocre (and now basement dwellers) Dolphins is a difficult pill to swallow. Multiple occasions saw Fitzpatrick throwing his head back is disbelief of the defensive effort.</p>
<p>Communication, tackling, defeating blocks; all the core principles of <strong>Brian Flores</strong> program came up patently empty in the first rendition of the post-<strong>Adam Gase</strong> era.</p>
<p>The plan on either side of the ball was uninspiring. Working with a roster that was turned over by 20% just in the last week alone, and 60% from last season, Flores and company had to feel as if they were playing against a stacked deck &#8212; and it showed.</p>
<blockquote class="twitter-tweet" data-width="550" data-dnt="true">
<p lang="en" dir="ltr">From the CBS broadcast on Miami’s overhaul. <a href="https://t.co/vO6yPs4rtw">pic.twitter.com/vO6yPs4rtw</a></p>
<p>&mdash; Travis Wingfield (@WingfieldNFL) <a href="https://twitter.com/WingfieldNFL/status/1170742322255953920?ref_src=twsrc%5Etfw">September 8, 2019</a></p></blockquote>
<p><script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></p>
<p>With busted coverages down the middle of the field, minimal safety-help any time the Ravens attacked vertically, zero pass rush to speak of, and run-fits that were reminiscent of old coaching staffs, this tape belongs securely in the fireplace.</p>
<p>Let’s go unit-by-unit</p>
<p><span style="font-size: 18pt; color: #008080;"><strong>Quarterback</strong></span></p>
<p><strong>Ryan Fitzpatrick</strong> made about as much hay as one could’ve expected from the 36-year-old veteran. Completing less than 50% of his balls, winding up on his back nearly every play, Fitzpatrick managed to evade some of the consistently compromised pockets, and stretched the field a few times.</p>
<p>His interception was vintage <strong>Fitz</strong>, as he mis-identified a two-deep, post-snap rotation, and somehow failed to account for <strong>Earl Thomas</strong>, who made Fitzpatrick pay. He did, however, throw a touchdown pass, making him the first quarterback to ever do so for eight different teams.</p>
<p><strong>Josh Rosen</strong> threw three passes. One hit the turf and two were caught, one by either team. His interception was a bad ball that turned into a turnover because the receiver (<strong>Jakeem Grant</strong>) didn’t come back to the football).</p>
<p><span style="font-size: 18pt; color: #008080;"><strong>Running Back</strong></span></p>
<p>So much for using <strong>Kenyan Drake</strong> early and often. Miami only rushed for 21 yards and never had a chance to get the run-game going because of the lopsided scoreboard, but it’s night and day which back offers more explosion.</p>
<blockquote class="twitter-tweet" data-width="550" data-dnt="true">
<p lang="en" dir="ltr">Absolutely fantastic from Kenyan Drake. Can’t even carry out the fake before he has to locate and hit the free rusher. <a href="https://t.co/tlVggkZ9Hp">pic.twitter.com/tlVggkZ9Hp</a></p>
<p>&mdash; Travis Wingfield (@WingfieldNFL) <a href="https://twitter.com/WingfieldNFL/status/1170753928067080192?ref_src=twsrc%5Etfw">September 8, 2019</a></p></blockquote>
<p><script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></p>
<p><strong>Drake</strong> rushed for just 12 yards on four carries &#8212; not much, but substantially better than <strong>Kalen Ballage’s</strong> five carries for -1 yard &#8212; and caught two of his three targets for 15 yards. His most impressive work came in pass protection, however.</p>
<p><span style="font-size: 18pt; color: #008080;"><strong>Wide Receiver</strong></span></p>
<p><strong>Devante Parker</strong> leaping to make full extension catches is a treat to watch. When Parker adds the vertical element to his game, he can be a more than viable option in 11-personnel sets. He caught less than 50% of his targets (3 of 7) but he posted 75 yards to double up the team’s second leading receiver.</p>
<blockquote class="twitter-tweet" data-width="550" data-dnt="true">
<p lang="it" dir="ltr">OK, Devante. <a href="https://t.co/pu8giI0oN4">pic.twitter.com/pu8giI0oN4</a></p>
<p>&mdash; Travis Wingfield (@WingfieldNFL) <a href="https://twitter.com/WingfieldNFL/status/1170757724423933952?ref_src=twsrc%5Etfw">September 8, 2019</a></p></blockquote>
<p><script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></p>
<p><strong>Preston Williams</strong> owns the lone Dolphins touchdown on the year. It came in familiar fashion as Williams &#8212; as he did all camp long &#8212; worked the end-line in a goal-to-go situation for a gorgeous touchdown stab. The impressive part was the release, and consequent stacking of the defender.</p>
<blockquote class="twitter-tweet" data-width="550" data-dnt="true">
<p lang="en" dir="ltr">They ran Preston Williams along the end line in every goal-to-go package I saw at camp. Here, he stacks his man and scores the first TD of the 2019 season. <a href="https://t.co/akmmkeb22A">pic.twitter.com/akmmkeb22A</a></p>
<p>&mdash; Travis Wingfield (@WingfieldNFL) <a href="https://twitter.com/WingfieldNFL/status/1170767814350659584?ref_src=twsrc%5Etfw">September 8, 2019</a></p></blockquote>
<p><script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></p>
<p>It’s unfair to speculate which veterans might be interested in a departure, but <strong>Albert Wilson’s</strong> body language certainly didn’t send an endorsing message &#8212; but who can blame him?</p>
<blockquote class="twitter-tweet" data-width="550" data-dnt="true">
<p lang="en" dir="ltr">Albert Wilson’s body language says it all. It’s the first quarter of the first game. Can’t imagine rehabbing for 10 months for this. <a href="https://t.co/EXaceXdJr3">pic.twitter.com/EXaceXdJr3</a></p>
<p>&mdash; Travis Wingfield (@WingfieldNFL) <a href="https://twitter.com/WingfieldNFL/status/1170754513382199296?ref_src=twsrc%5Etfw">September 8, 2019</a></p></blockquote>
<p><script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></p>
<p><span style="font-size: 18pt; color: #008080;"><strong>Tight Ends</strong></span></p>
<p><strong>Durham Smythe</strong> opened the game as the starter, but he and <strong>Nick O’Leary</strong> were not targeted. Miami only rushed the ball 12 times, so the 12-personnel pairing was naturally uninvolved most of the game.</p>
<p><strong>Mike Gesicki</strong> was the team’s second leading receiver. He caught only two of his six targets, but picked 31 yards (26 on one play). He continues to show his skill set as a flex, supped-up receiver type.</p>
<p><span style="font-size: 18pt; color: #008080;"><strong>Offensive Line</strong></span></p>
<p>It’s going to be an unbalanced evaluation for the skill players all year long, and we have the line to thank for it. We’ll get to the horrendous defense, but this unit was responsible for the measly 10 points and 12 first downs on 10 offensive possessions.</p>
<p><strong>Jesse Davis</strong> signed an extension on Saturday, and moved to left tackle full-time starting with today’s game. We’ll have more on this in the podcast that coincides with this article, but Davis’ performance triggers some early buyer’s remorse. He doesn’t get off the football (kick-slide) smooth enough to deal with the speed rushers off that edge, letting up his fair share of pressures.</p>
<blockquote class="twitter-tweet" data-width="550" data-dnt="true">
<p lang="en" dir="ltr">Jesse Davis’ kick slide is not one you typically see on a LT <a href="https://t.co/cXJHXtkmpF">pic.twitter.com/cXJHXtkmpF</a></p>
<p>&mdash; Travis Wingfield (@WingfieldNFL) <a href="https://twitter.com/WingfieldNFL/status/1170766985946255360?ref_src=twsrc%5Etfw">September 8, 2019</a></p></blockquote>
<p><script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></p>
<p><strong>Daniel Kilgore</strong> has to be one of the trade requests &#8212; he has to be. We heard about a veteran of the line becoming very upset over the Tunsil trade, and the extra duty he has to pull to pick up the slack on this line is…. well it’s a lot.</p>
<blockquote class="twitter-tweet" data-width="550" data-dnt="true">
<p lang="en" dir="ltr">This is one of the best plays I’ve seen a Dolphins offensive lineman make in some time (Dan Kilgore). <a href="https://t.co/d9Xhxsiaoq">pic.twitter.com/d9Xhxsiaoq</a></p>
<p>&mdash; Travis Wingfield (@WingfieldNFL) <a href="https://twitter.com/WingfieldNFL/status/1170772447374635008?ref_src=twsrc%5Etfw">September 8, 2019</a></p></blockquote>
<p><script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></p>
<p><strong>Julie’n Davenport</strong> was a tire fire in Houston, and he brought the show to Miami today. Miami’s new right tackle frequently put his teammates in danger because of his shortcomings, but also a fuzzy understanding of his assignments (can you blame him? He’s been here for a week).</p>
<blockquote class="twitter-tweet" data-width="550" data-dnt="true">
<p lang="en" dir="ltr">This is the part of all these new players — of the tank — I don’t like. Julie’n Davenport either didn’t know his landmark or he’s just not good enough to get to it, but you can’t stand there and watch the edge tee off on your RB like this. <a href="https://t.co/XU7Ez1rXcb">pic.twitter.com/XU7Ez1rXcb</a></p>
<p>&mdash; Travis Wingfield (@WingfieldNFL) <a href="https://twitter.com/WingfieldNFL/status/1170751288843239424?ref_src=twsrc%5Etfw">September 8, 2019</a></p></blockquote>
<p><script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></p>
<p><strong>Danny Isidora</strong> wiped a booger on <strong>Pernell McPhee</strong> on one inside rush, but it only slowed McPhee’s move down by a fraction of a second.</p>
<blockquote class="twitter-tweet" data-width="550" data-dnt="true">
<p lang="en" dir="ltr">Pernell McPhee gets in on Fitz by simply saying “excuse me, sir” to new Dolphins RG Danny Isidora. <a href="https://t.co/RWdrbxP7lN">pic.twitter.com/RWdrbxP7lN</a></p>
<p>&mdash; Travis Wingfield (@WingfieldNFL) <a href="https://twitter.com/WingfieldNFL/status/1170762891596722176?ref_src=twsrc%5Etfw">September 8, 2019</a></p></blockquote>
<p><script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></p>
<p><strong>Michael Deiter</strong> pitched in with his own pass protection issues.</p>
<blockquote class="twitter-tweet" data-width="550" data-dnt="true">
<p lang="en" dir="ltr">Lets check in on Michael Deiter. Legitimately feel bad for Fitz. <a href="https://t.co/CURceBxEFD">pic.twitter.com/CURceBxEFD</a></p>
<p>&mdash; Travis Wingfield (@WingfieldNFL) <a href="https://twitter.com/WingfieldNFL/status/1170776284361674754?ref_src=twsrc%5Etfw">September 8, 2019</a></p></blockquote>
<p><script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></p>
<p><span style="color: #008080; font-size: 18pt;"><strong>Defensive Line</strong></span></p>
<p>Two players in this group were issued playbooks last week, and deployed for significant workloads Sunday. <strong>John Jenkins</strong> and<strong> Avery Moss</strong> are unrecognizable to the fans (first time wearing their new jerseys today) but they both became quickly acquainted, and did so for all the wrong reasons.</p>
<p><strong>Christian Wilkins</strong> was knocked back badly on one of Baltimore’s touchdown runs, but he responded and played one of the better games up front.</p>
<p>The same was true of <strong>Davon Godchaux</strong>, who made his feelings about a potential locker room mutiny known after the game</p>
<blockquote class="twitter-tweet" data-width="550" data-dnt="true">
<p lang="en" dir="ltr">We will be back💪🏾 <a href="https://t.co/fTaxK3bO5Y">pic.twitter.com/fTaxK3bO5Y</a></p>
<p>&mdash; Davon Godchaux (@ChauxDown) <a href="https://twitter.com/ChauxDown/status/1170847906687004672?ref_src=twsrc%5Etfw">September 8, 2019</a></p></blockquote>
<p><script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></p>
<p><strong>Charles Harris</strong>’ preseason looked like fool’s gold in this game, he was back on the milk carton.</p>
<p><strong>Jonathan Ledbetter</strong> is a fit and a find from this scouting staff. In addition to falling in-line with the expectation for playing the edge (as well as condensing inside), Ledbetter made a number of hustle plays in the game.</p>
<p><span style="font-size: 18pt; color: #008080;"><strong>Linebackers</strong></span></p>
<p>What a swift departure this was from the preseason and camp this unit had. Sam Eguavoen was exposed big time in this game. He was regularly tossed aside in his attempts to set the edge or fill inside, and was a beat late in coverage on a few occasions.</p>
<p>The same was true for <strong>Raekwon McMillan</strong>. He made one nifty run-stuff early in the game, but got caught in coverage, had a terrible run fit on a Ravens touchdown run, and eventually left with an injury.</p>
<blockquote class="twitter-tweet" data-width="550" data-dnt="true">
<p lang="en" dir="ltr">Minkah attacks the pull, Baker has the B-gap fill, but McMillan doesn’t scrape and it’s a massive lane for a walk-in. <a href="https://t.co/WvL3O8QVvc">pic.twitter.com/WvL3O8QVvc</a></p>
<p>&mdash; Travis Wingfield (@WingfieldNFL) <a href="https://twitter.com/WingfieldNFL/status/1170765986556870656?ref_src=twsrc%5Etfw">September 8, 2019</a></p></blockquote>
<p><script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></p>
<p><strong>Jerome Baker’s</strong> hot camp and preseason didn’t translate. A few folks are concerned about his fit in this defense because of his size, and those limitations showed up in this game &#8212; he still needs to get stronger.</p>
<p><span style="font-size: 18pt; color: #008080;"><strong>Defensive Backs</strong></span></p>
<p><strong>Xavien Howard</strong> was targeted one time that I remember, and he damn near picked it off. He’s still elite.</p>
<blockquote class="twitter-tweet" data-width="550" data-dnt="true">
<p lang="en" dir="ltr">Putting your 80 million dollar man on the rookie with 2 TDs and 4,000 yards in the first quarter seems like a good idea. <a href="https://t.co/yPOERyCuws">pic.twitter.com/yPOERyCuws</a></p>
<p>&mdash; Travis Wingfield (@WingfieldNFL) <a href="https://twitter.com/WingfieldNFL/status/1170756027119046656?ref_src=twsrc%5Etfw">September 8, 2019</a></p></blockquote>
<p><script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></p>
<p>The rest of Miami’s corners had a dreadful game. <strong>Eric Rowe</strong> got lost in coverage multiple times and, on more than one occasion, didn’t appear all that interested in helping his team.</p>
<p><strong>Minkah Fitzpatrick</strong> was slow roasted. He was put in some precarious positions, including in man-coverage against <strong>Hollywood Brown</strong> with a 12-yard cushion and no safety help. This sounds normal, but Minkah had to close down in a quasi-robber role on the over route, and once Brown caught Fitzpatrick leaning, it was game over.</p>
<p><strong>Jomal Wiltz</strong> was burnt for at least two touchdown that will go against him. He was overmatched, especially on a vertical route from <strong>Willie Snead</strong>, who is not known for his blazing speed.</p>
<blockquote class="twitter-tweet" data-width="550" data-dnt="true">
<p lang="en" dir="ltr">This time it’s Willie Snead on Jomal Wiltz. Widen the slot take-off with a step to the flag, turns Wiltz’s hips&#8230; see ya. <a href="https://t.co/zzKHYwKlQg">pic.twitter.com/zzKHYwKlQg</a></p>
<p>&mdash; Travis Wingfield (@WingfieldNFL) <a href="https://twitter.com/WingfieldNFL/status/1170756889031790592?ref_src=twsrc%5Etfw">September 8, 2019</a></p></blockquote>
<p><script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></p>
<p><strong>Reshad Jones</strong> had a pretty typical Reshad Jones game. He made a weak-side C-gap run-stuff down around the goal line, and made three additional tackles.</p>
<p>The <strong>Bobby McCain</strong> free safety experiment might already be over. The insult came via multiple coverage busts and vacated zones in the middle of the field; the injury came when McCain aggravated the shoulder that listed him on the injury report this week.</p>
<p><span style="font-size: 18pt; color: #008080;"><strong>Recap</strong></span></p>
<p>This is probably going to be the painstaking norm this season. The Dolphins lopped off most of the talent it had back in the winter, and continued that purge over the last couple of weeks, with no real regard for winning football games this season.</p>
<p>Repairing years of poor management &#8212; which put the balance sheets out of whack, without much talent to account for the expenses &#8212; is an arduous process. A process that we are smack-dab in the middle of.</p>
<p>The light at the end of the tunnel comes by-way of the 2020 draft class &#8212; which is 227 days away, for those scoring at home.</p>
<p>This year’s class is impressive, and it’s spearheaded by a generational talent. Miami’s moves &#8212; namely the left tackle extension for <strong>Davis</strong> (more in the podcast) &#8212; suggest that Tua is the target. In fact, I can confirm that <strong>Tua Tagovailoa</strong> is the target.</p>
<p>In case you aren’t convinced about what an electrifying, upstart quarterback can do for a bad football team, take a look at <strong>Kyler Murray</strong> in Arizona. After a dreadful first half of his own, Kyler went 17 of 21 in the fourth quarter, and engineered an 18-point comeback in the process (the game would end in a tie after the Cardinals defense gave the overtime field back to the Lions).</p>
<p>We will track the college quarterbacks each week here on Locked On Dolphins.</p>
<p>For now, we are Andy Dufresne in the middle of that sewage-filled pipe. On the other side, freedom.</p>
<p>We hope.</p>
<p><strong><a href="https://twitter.com/WingfieldNFL">@WingfieldNFL</a></strong></p>
																											</div><!--mvp-content-main-->
													<div id="mvp-content-bot" class="left">
																												<div class="mvp-post-tags">
															<span class="mvp-post-tags-header">Related Topics:</span><span itemprop="keywords"><a href="https://www.lockedondolphins.com/tag/brian-flores/" rel="tag">Brian Flores</a><a href="https://www.lockedondolphins.com/tag/featured/" rel="tag">Featured</a><a href="https://www.lockedondolphins.com/tag/josh-rosen/" rel="tag">Josh Rosen</a><a href="https://www.lockedondolphins.com/tag/miami-dolphins-tanking/" rel="tag">Miami Dolphins Tanking</a><a href="https://www.lockedondolphins.com/tag/minkah-fitzpatrick/" rel="tag">Minkah Fitzpatrick</a><a href="https://www.lockedondolphins.com/tag/tanking/" rel="tag">Tanking</a><a href="https://www.lockedondolphins.com/tag/tua-tagovailoa/" rel="tag">Tua Tagovailoa</a></span>
														</div><!--mvp-post-tags-->
														<div class="posts-nav-link">
																													</div><!--posts-nav-link-->
																													<div id="mvp-prev-next-wrap" class="left relative">
																																																	<div class="mvp-prev-post-wrap left relative">
																		<a href="https://www.lockedondolphins.com/dolphins/dolphins-sign-ol-jesse-davis-to-3-year-extension/" rel="bookmark">
																		<div class="mvp-prev-next-cont left relative">
																			<div class="mvp-prev-cont-out right relative">
																				<span class="mvp-prev-arr fa fa-chevron-left left"></span>
																				<div class="mvp-prev-cont-in">
																					<div class="mvp-prev-next-text left relative">
																						<span class="mvp-prev-next-label left relative">Don&#039;t Miss</span>
																						<p>Dolphins Sign OL Jesse Davis to 3-Year Extension</p>
																					</div><!--mvp-prev-next-text-->
																				</div><!--mvp-prev-cont-in-->
																			</div><!--mvp-prev-cont-out-->
																		</div><!--mvp-prev-next-cont-->
																		</a>
																	</div><!--mvp-prev-post-wrap-->
																															</div><!--mvp-prev-next-wrap-->
																																											<div id="mvp-author-box-wrap" class="left relative">
																<div class="mvp-author-box-out right relative">
																	<div id="mvp-author-box-img" class="left relative">
																		<img src="https://www.lockedondolphins.com/wp-content/uploads/2019/06/Profile-80x80.jpg" width="60" height="60" alt="Travis Wingfield" class="avatar avatar-60 wp-user-avatar wp-user-avatar-60 alignnone photo" />																	</div><!--mvp-author-box-img-->
																	<div class="mvp-author-box-in">
																		<div id="mvp-author-box-head" class="left relative">
																			<span class="mvp-author-box-name left relative"><a href="https://www.lockedondolphins.com/author/twingfield/" title="Posts by Travis Wingfield" rel="author">Travis Wingfield</a></span>
																			<div id="mvp-author-box-soc-wrap" class="left relative">
																																																																																																																																																															</div><!--mvp-author-box-soc-wrap-->
																		</div><!--mvp-author-box-head-->
																	</div><!--mvp-author-box-in-->
																</div><!--mvp-author-box-out-->
																<div id="mvp-author-box-text" class="left relative">
																	<p></p>
																</div><!--mvp-author-box-text-->
															</div><!--mvp-author-box-wrap-->
																												<div class="mvp-org-wrap" itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
															<div class="mvp-org-logo" itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
																																	<img src="https://www.lockedondolphins.com/wp-content/uploads/2019/02/Locked-On-Dolphins-Podcast-Website-Logo.png"/>
																	<meta itemprop="url" content="https://www.lockedondolphins.com/wp-content/uploads/2019/02/Locked-On-Dolphins-Podcast-Website-Logo.png">
																															</div><!--mvp-org-logo-->
															<meta itemprop="name" content="Locked On Dolphins">
														</div><!--mvp-org-wrap-->
													</div><!--mvp-content-bot-->
												</div><!--mvp-content-body-top-->
												<div class="mvp-cont-read-wrap">
																																								<div id="mvp-post-bot-ad" class="left relative">
															<span class="mvp-ad-label">Advertisement</span>
															<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<ins class="adsbygoogle"
     style="display:block"
     data-ad-format="fluid"
     data-ad-layout-key="-6r+di+5g-2m-8y"
     data-ad-client="ca-pub-3311849153835630"
     data-ad-slot="8448677726"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script>
<div style="height:20px;"></div>
<!-- Begin MailChimp Signup Form -->
<link href="//cdn-images.mailchimp.com/embedcode/horizontal-slim-10_7.css" rel="stylesheet" type="text/css">

<div id="mc_embed_signup">
<form action="https://fanragsports.us8.list-manage.com/subscribe/post?u=0929c3c0f4c900717acdf09e4&id=aa26475111" method="post" id="mc-embedded-subscribe-form" name="mc-embedded-subscribe-form" class="validate" target="_blank" novalidate>
    <div id="mc_embed_signup_scroll">
	<label for="mce-EMAIL">Subscribe to the Locked on Dolphins Newsletter Today - It's FREE</label>
	<input type="email" value="" name="EMAIL" class="email" id="mce-EMAIL" placeholder="email address" required>
    <!-- real people should not fill this in and expect good things - do not remove this or risk form bot signups-->
    <div style="position: absolute; left: -5000px;" aria-hidden="true"><input type="text" name="b_0929c3c0f4c900717acdf09e4_aa26475111" tabindex="-1" value=""></div>
    <div class="clear"><input type="submit" value="Subscribe" name="subscribe" id="mc-embedded-subscribe" class="button"></div>
    </div>
</form>
</div>

<!--End mc_embed_signup-->														</div><!--mvp-post-bot-ad-->
																																																																																			<div id="mvp-comments-button" class="left relative mvp-com-click">
																<span class="mvp-comment-but-text">1 Comment</span>
															</div><!--mvp-comments-button-->
															<div id="comments">
				<h4 class="mvp-widget-home-title"><span class="mvp-widget-home-title">
			1 Comment		</span></h4>
		<ol class="commentlist">
			<li class="comment even thread-even depth-1" id="li-comment-4205">
		<div class="comment-wrapper" id="comment-4205">
			<div class="comment-inner">
				<div class="comment-avatar">
					<img src="https://secure.gravatar.com/avatar/a32d7e05efbacd8a420347fac8aba543?s=46&#038;d=monsterid&#038;r=g" width="46" height="46" alt="Avatar" class="avatar avatar-46wp-user-avatar wp-user-avatar-46 alignnone photo avatar-default" />				</div>
				<div class="commentmeta">
					<p class="comment-meta-1">
						<cite class="fn">PapaPickett</cite> 					</p>
					<p class="comment-meta-2">
						September 8, 2019 at 10:32 pm											</p>
				</div>
				<div class="text">
										<div class="c">
						<p>The front seven was so bad the Secondary was using their Safeties man to man in off coverages with no help over the top. It was an all around team failure but no one deserves a game ball quite like Chris Grier. I hope someone else is choosing for the draft picks he traded for.</p>
					</div>
				</div><!-- .text  -->
				<div class="clear"></div>
				<div class="comment-reply"><span class="reply"><a rel='nofollow' class='comment-reply-link' href='/dolphins/blown-out-by-baltimore-again-miami-dolphins-week-1-recap/?replytocom=4205#respond' data-commentid="4205" data-postid="8069" data-belowelement="comment-4205" data-respondelement="respond" aria-label='Reply to PapaPickett'>Reply</a></span></div>
			</div><!-- comment-inner  -->
		</div><!-- comment-wrapper  -->
	</li><!-- #comment-## -->
	</ol>
			
	
	<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title"><h4 class="mvp-widget-home-title"><span class="mvp-widget-home-title">Leave a Reply</span></h4> <small><a rel="nofollow" id="cancel-comment-reply-link" href="/dolphins/blown-out-by-baltimore-again-miami-dolphins-week-1-recap/#respond" style="display:none;">Cancel reply</a></small></h3>			<form action="https://www.lockedondolphins.com/wp-comments-post.php" method="post" id="commentform" class="comment-form">
				<p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p><p class="comment-form-comment"><label for="comment">Comment</label> <textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" required="required"></textarea></p><p class="comment-form-author"><label for="author">Name <span class="required">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" required='required' /></p>
<p class="comment-form-email"><label for="email">Email <span class="required">*</span></label> <input id="email" name="email" type="text" value="" size="30" maxlength="100" aria-describedby="email-notes" required='required' /></p>
<p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="text" value="" size="30" maxlength="200" /></p>
<p class="comment-form-cookies-consent"><input id="wp-comment-cookies-consent" name="wp-comment-cookies-consent" type="checkbox" value="yes" /><label for="wp-comment-cookies-consent">Save my name, email, and website in this browser for the next time I comment.</label></p>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='8069' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="6268f6e0ca" /></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="193"/></p>			</form>
			</div><!-- #respond -->
	<p class="akismet_comment_form_privacy_notice">This site uses Akismet to reduce spam. <a href="https://akismet.com/privacy/" target="_blank" rel="nofollow noopener">Learn how your comment data is processed</a>.</p>
</div><!--comments-->																																							</div><!--mvp-cont-read-wrap-->
											</div><!--mvp-content-body-->
										</div><!--mvp-post-soc-in-->
									</div><!--mvp-post-soc-out-->
								</div><!--mvp-content-wrap-->
													<div id="mvp-post-add-box">
								<div id="mvp-post-add-wrap" class="left relative">
																			<div class="mvp-post-add-story left relative">
											<div class="mvp-post-add-head left relative">
												<h3 class="mvp-post-cat left relative"><a class="mvp-post-cat-link" href="https://www.lockedondolphins.com/category/dolphins/draft/"><span class="mvp-post-cat left">NFL Draft</span></a></h3>
												<h1 class="mvp-post-title left">Scouting College Football&#8217;s Top 2020 Quarterbacks &#8211; Week 2</h1>
																																					<div class="mvp-author-info-wrap left relative">
														<div class="mvp-author-info-thumb left relative">
															<img src="https://www.lockedondolphins.com/wp-content/uploads/2019/06/Profile-80x80.jpg" width="46" height="46" alt="Travis Wingfield" class="avatar avatar-46 wp-user-avatar wp-user-avatar-46 alignnone photo" />														</div><!--mvp-author-info-thumb-->
														<div class="mvp-author-info-text left relative">
															<div class="mvp-author-info-date left relative">
																<p>Published</p> <span class="mvp-post-date">1 day ago</span> <p>on</p> <span class="mvp-post-date">September 7, 2019</span>
															</div><!--mvp-author-info-date-->
															<div class="mvp-author-info-name left relative">
																<p>By</p> <span class="author-name"><a href="https://www.lockedondolphins.com/author/twingfield/" title="Posts by Travis Wingfield" rel="author">Travis Wingfield</a></span> <a href="" class="mvp-twit-but" target="_blank"><span class="mvp-author-info-twit-but"><i class="fa fa-twitter fa-2"></i></span></a>
															</div><!--mvp-author-info-name-->
														</div><!--mvp-author-info-text-->
													</div><!--mvp-author-info-wrap-->
																							</div><!--mvp-post-add-head-->
											<div class="mvp-post-add-body left relative">
																																							<div class="mvp-post-add-img left relative">
															<img width="900" height="600" src="https://www.lockedondolphins.com/wp-content/uploads/2019/09/USATSI_13324832.jpg" class="attachment- size- wp-post-image" alt="" srcset="https://www.lockedondolphins.com/wp-content/uploads/2019/09/USATSI_13324832.jpg 900w, https://www.lockedondolphins.com/wp-content/uploads/2019/09/USATSI_13324832-300x200.jpg 300w, https://www.lockedondolphins.com/wp-content/uploads/2019/09/USATSI_13324832-768x512.jpg 768w" sizes="(max-width: 900px) 100vw, 900px" />														</div><!--mvp-post-feat-img-->
																																																			<div class="mvp-post-add-cont left relative">
													<div class="mvp-post-add-main right relative">
														<h2>Recapping Week 2 for College Football&#8217;s Top QB Prospects</h2>
<p>The news that <strong>Ryan Fitzpatrick</strong> beat out<strong> Josh Rosen</strong> for the opening day start in Miami is a tough pill to swallow. Easing the blow to Rosen’s long-term franchise answer probability, is the fact that Miami is staring down the barrel of a loaded quarterback class set to hit the draft next April.</p>
<p>During the college season, here on <em>Locked On Dolphins</em>, we’re going to keep an eye on quarterbacks all throughout the country. Our primary focus will be on the big four, the options that Miami will likely choose from with an early pick in the 2020 draft.</p>
<p><strong>Those quarterbacks are:</strong></p>
<p><strong><a style="color: #800000;" href="https://www.lockedondolphins.com/dolphins/scouting/face-of-the-franchise-series-tua-tagovailoa/">Tua Tagovailoa Scouting Report</a><br />
<span style="color: #ff0000;"><a style="color: #ff0000;" href="https://www.lockedondolphins.com/dolphins/scouting/face-of-the-franchise-series-jake-fromm/">Jake Fromm <span style="caret-color: #800000;">Scouting</span> Report</a></span><br />
<span style="color: #008000;"><a style="color: #008000;" href="https://www.lockedondolphins.com/dolphins/scouting/face-of-the-franchise-series-justin-herbert/">Justin Herbert Scouting Report</a></span><br />
<a href="https://www.lockedondolphins.com/dolphins/scouting/face-of-the-franchise-series-jordan-love/"><span style="color: #000080;">Jordan Love Scouting Report</span></a></strong><br />
<span style="color: #000000;"><strong><a style="color: #000000;" href="https://www.lockedondolphins.com/dolphins/draft/scouting-college-footballs-2020-top-quarterbacks-week-1/">2019 Week 1 Recap</a></strong></span></p>
<p>We’ll go in chronological order from when the games were played. Up first, QB1.</p>
<p><span style="color: #800000; font-size: 18pt;"><strong>Tua Tagovailoa vs. New Mexico State, Win 62-10</strong></span><br />
<strong>Stats: 16/25 (64%) 227 yards (9.1 YPA), 3 TDs (1 rushing, 4 total)</strong></p>
<p>More misses than usual for the career 70% passer, Tagovailoa wasn’t as sharp as he typically is, yet he still posted gaudy stats towards his Heisman pursuit. Aside from the explosive passing game &#8212; and one long touchdown rush &#8212; Tagovailoa missed a pair of short throws and was a little too aggressive in the deep passing game.</p>
<p>Still, the traits that make him QB1 were on display. The light feet, the manipulation of the defense with eye and body positioning, elite accuracy and spatial awareness to create windows and thread tight lanes, this quarterback is a marvel to watch each week.</p>
<blockquote class="twitter-tweet" data-width="550" data-dnt="true">
<p lang="en" dir="ltr">Tua Tagovailoa vs. New Mexico State thread. </p>
<p>NMS gets pressure off both edges, Tua quickly gets off the spot and climbs through the pocket to give his guy a chance. Ruggs does the rest <a href="https://t.co/gORG9XuYlY">pic.twitter.com/gORG9XuYlY</a></p>
<p>&mdash; Travis Wingfield (@WingfieldNFL) <a href="https://twitter.com/WingfieldNFL/status/1170430831858352128?ref_src=twsrc%5Etfw">September 7, 2019</a></p></blockquote>
<p><script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></p>
<p>Tua rarely misses layups, but when he is responsible for putting the offense behind the chains, he typically bails the unit out with third-down mastery. The Alabama protection wasn’t great in the first half, but the quarterback’s ability to find clean platforms and deliver the ball from multiple arm angles never ceases to amaze.</p>
<p><span style="color: #ff0000; font-size: 18pt;"><strong>Jake Fromm vs. Murray State &#8211; Win 63-17</strong></span><br />
<strong>Stats: 10/11 (90.1%) 166 yards (15.1 YPA) 1 TD</strong></p>
<p>Tagovailoa stands to get dinged for the surrounding talent he plays with more than anybody, but its Georgia’s talent and style that limits the evaluation of Fromm even more. Fromm made one bad throw (decision) in this game, and it could’ve been picked off. He completed every other pass he threw, however, and continues to lean on the nation’s strongest ground game.</p>
<p>Fromm’s services were no longer needed by the end of the second quarter, and his intermediate and deep passing were a big reason why he earned the right to hold the clipboard in the second half.</p>
<blockquote class="twitter-tweet" data-width="550" data-dnt="true">
<p lang="en" dir="ltr">Jake Fromm thread vs Murray State. Doesn’t account for the corner who falls off after the field side short motion flanker runs a crosser, and almost gets picked. <a href="https://t.co/0DRo1skpSD">pic.twitter.com/0DRo1skpSD</a></p>
<p>&mdash; Travis Wingfield (@WingfieldNFL) <a href="https://twitter.com/WingfieldNFL/status/1170433521187340288?ref_src=twsrc%5Etfw">September 7, 2019</a></p></blockquote>
<p><script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></p>
<p>During the broadcast, the announcers referred to a pre-game conversation they had with the noble quarterback. Fromm discussed the action-reaction relationship between the defense’s plan, and the offense’s reaction to that plan. “Every time the defense moves, there’s a solution to that movement, and I’ve got to find that answer.”</p>
<p>That cerebral approach will entice the Miami brain trust, even though Fromm is the least physically impressive passer of this foursome. The advanced processing and ball placement are Fromm’s two greatest traits, and he showcased both in the romp over Murray State.</p>
<p><span style="color: #339966; font-size: 18pt;"><strong>Justin Herbert vs. Nevada, Win 77-6</strong></span><br />
<strong>Stats: 19/26 (73.1%) 310 yards (11.9 YPA) 5 TDs</strong></p>
<p>Through two games Herbert is exactly who has been throughout his career. Moments of jaw-dropping brilliance, followed up by inconsistencies in his mechanics, accuracy, and under duress, clouds the evaluation. Herbert saw some ghosts in that Auburn opener, and that’s understandable, but he exhibits that urgency in a panicky fashion with regularity.</p>
<p>The aforementioned sloppy mechanics leaves balls scattered all over the passing chart, but once he finally settles in, he paints some of the prettiest pictures in college football.</p>
<blockquote class="twitter-tweet" data-width="550" data-dnt="true">
<p lang="en" dir="ltr">Justin Herbert vs. Nevada thread</p>
<p>Missed a second down throw, then comes back with this high pass under duress on 3rd. <a href="https://t.co/HnYKnM60sm">pic.twitter.com/HnYKnM60sm</a></p>
<p>&mdash; Travis Wingfield (@WingfieldNFL) <a href="https://twitter.com/WingfieldNFL/status/1170484521503879169?ref_src=twsrc%5Etfw">September 7, 2019</a></p></blockquote>
<p><script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></p>
<p>Herbert got it cranking after Oregon’s first two series stalled. He responded with fastballs down the seam that are simply uncoverable. He took the Ducks down the field on the five next drives &#8212; each capped by a Herbert touchdown.</p>
<p>If Herbert develops consistency as the season goes along, he’ll solidify his top-five draft status. Even if he doesn’t, the lofty upside is going to entice the coach of one quarterback-needy franchise next April.</p>
<p><span style="font-size: 18pt; color: #000080;"><strong>Jordan Love vs. Stony Brook, Win 62-7</strong></span><br />
<strong>Stats: 25/34 (73.5%) 294 yards (8/65 YPA) 1 TD</strong></p>
<p>His performance will carry the burden of a Stony Brook caveat, but the eye-popping, highlight plays were on display Saturday night for Love. First, the arm-talent. The natural elasticity to whip the football with velocity and spin &#8212; regardless of the angle &#8212; is the reason scouts are so high on Jordan Love. Height, weight, arm strength, it’s all there, but when you factor in the mobility (both as a running threat and within the pocket) and recognition of the “why” behind the offense, you’re working with endless potential.</p>
<blockquote class="twitter-tweet" data-width="550" data-dnt="true">
<p lang="en" dir="ltr">Jordan Love vs. Stony Brook thread</p>
<p>Oh, OK, then. <a href="https://t.co/jFDQPGIHp1">pic.twitter.com/jFDQPGIHp1</a></p>
<p>&mdash; Travis Wingfield (@WingfieldNFL) <a href="https://twitter.com/WingfieldNFL/status/1170492281264078849?ref_src=twsrc%5Etfw">September 8, 2019</a></p></blockquote>
<p><script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></p>
<p>Nobody is confusing Stony Brook’s defense for a Vic Fangio squad, but Love’s ability to read the entire field, and trust his eyes based on his preparation was apparent Saturday. He scans the first read in the progression, and because of the information that particular side of the defense affords him, he’s able to come back and rip it with trust that he’s got his man.</p>
<p>The needle was never going to move this week given the competition of the four QB’s in week-two. Fromm managed another dominant rushing performance from Georgia, Tua missed more throws that usual, but was still spectacular, Love was all over the highlight reel and Herbert dominated after a slow start.</p>
<p>Next week, it’s a bye week, two more cupcakes, and our first conference game for QB1.</p>
<p><strong>Week 3 Schedule</strong></p>
<p>Tagovailoa &#8211; @ South Carolina, 3:30 CBS<br />
Fromm &#8211; Arkansas State, 12:00 (N/A)<br />
Herbert &#8211; vs. Montana, 10:45 PAC12 Network<br />
Love &#8211; BYE</p>
<p><a href="https://twitter.com/WingfieldNFL"><strong>@WingfieldNFL</strong></a></p>
													</div><!--mvp-post-add-main-->
													<div class="mvp-post-add-link">
														<a href="https://www.lockedondolphins.com/dolphins/draft/scouting-college-footballs-top-2020-quarterbacks-week-2/" rel="bookmark"><span class="mvp-post-add-link-but">Continue Reading</span></a>
													</div><!--mvp-post-add-link-->
												</div><!--mvp-post-add-cont-->
											</div><!--mvp-post-add-body-->
										</div><!--mvp-post-add-story-->
																			<div class="mvp-post-add-story left relative">
											<div class="mvp-post-add-head left relative">
												<h3 class="mvp-post-cat left relative"><a class="mvp-post-cat-link" href="https://www.lockedondolphins.com/category/dolphins/"><span class="mvp-post-cat left">Miami Dolphins</span></a></h3>
												<h1 class="mvp-post-title left">Dolphins Sign OL Jesse Davis to 3-Year Extension</h1>
																																					<div class="mvp-author-info-wrap left relative">
														<div class="mvp-author-info-thumb left relative">
															<img src="https://www.lockedondolphins.com/wp-content/uploads/2019/05/image1-1-80x80.jpeg" width="46" height="46" alt="Chris Kowalewski" class="avatar avatar-46 wp-user-avatar wp-user-avatar-46 alignnone photo" />														</div><!--mvp-author-info-thumb-->
														<div class="mvp-author-info-text left relative">
															<div class="mvp-author-info-date left relative">
																<p>Published</p> <span class="mvp-post-date">1 day ago</span> <p>on</p> <span class="mvp-post-date">September 7, 2019</span>
															</div><!--mvp-author-info-date-->
															<div class="mvp-author-info-name left relative">
																<p>By</p> <span class="author-name"><a href="https://www.lockedondolphins.com/author/ckowalewski/" title="Posts by Chris Kowalewski" rel="author">Chris Kowalewski</a></span> <a href="" class="mvp-twit-but" target="_blank"><span class="mvp-author-info-twit-but"><i class="fa fa-twitter fa-2"></i></span></a>
															</div><!--mvp-author-info-name-->
														</div><!--mvp-author-info-text-->
													</div><!--mvp-author-info-wrap-->
																							</div><!--mvp-post-add-head-->
											<div class="mvp-post-add-body left relative">
																																							<div class="mvp-post-add-img left relative">
															<img width="770" height="600" src="https://www.lockedondolphins.com/wp-content/uploads/2019/02/USATSI_10503548.jpg" class="attachment- size- wp-post-image" alt="" srcset="https://www.lockedondolphins.com/wp-content/uploads/2019/02/USATSI_10503548.jpg 770w, https://www.lockedondolphins.com/wp-content/uploads/2019/02/USATSI_10503548-300x234.jpg 300w, https://www.lockedondolphins.com/wp-content/uploads/2019/02/USATSI_10503548-768x599.jpg 768w" sizes="(max-width: 770px) 100vw, 770px" />														</div><!--mvp-post-feat-img-->
																																																			<div class="mvp-post-add-cont left relative">
													<div class="mvp-post-add-main right relative">
														<p>On the eve of the Dolphins’ 2019 season, the team makes another announcement &#8211; this time not a cut, but an extension for offensive lineman <b>Jesse</b> <b>Davis</b>.</p>
<p>The new contract for Miami’s versatile guard/tackle is reported to be a 3 year deal worth a total of $15 million, comprised of $8.5m fully guaranteed and a $4m signing bonus.</p>
<blockquote class="twitter-tweet" data-width="550" data-dnt="true">
<p lang="en" dir="ltr">At $5M APY, Jesse Davis would be the 13th highest-paid RT this year, 15th next, and 16th in 2021. Its 17th in total value among all RTs.</p>
<p>His guarantees come in at 14th most among RTs.</p>
<p>As a right guard, he’s the 20th-highest paid on an annual basis.</p>
<p>&mdash; Travis Wingfield (@WingfieldNFL) <a href="https://twitter.com/WingfieldNFL/status/1170390729304051712?ref_src=twsrc%5Etfw">September 7, 2019</a></p></blockquote>
<p><script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></p>
<p>Davis played every offensive snap for the Miami Dolphins in 2018 and stands as one of the few staple players on the frontline &#8211; a group which has seen significant turnover recently with the trade of <b>Laremy</b> <b>Tunsil</b>.</p>
<p>The deal should see Davis as a key member of the offensive line through the 2022 season.</p>
<p>During his career with the Dolphins, Jesse Davis has seen starting roles at both guard and tackle positions along the line. His versatility figures to be one of his primary strengths in <b>Brian</b> <b>Flores</b>’ scheme and Davis will reportedly fill the starting LT spot following Tunsil’s departure for the opening game at least.</p>
<blockquote class="twitter-tweet" data-width="550" data-dnt="true">
<p lang="en" dir="ltr">Per source, Dolphins gave Jesse Davis a 4 M signing bonus. 3 yr, 15 M deal with 8.5 M guaranteed. Has been working at LT this week after playing RT in preseason. Now signed through 2022</p>
<p>&mdash; Barry Jackson (@flasportsbuzz) <a href="https://twitter.com/flasportsbuzz/status/1170385580527632384?ref_src=twsrc%5Etfw">September 7, 2019</a></p></blockquote>
<p><script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></p>
<p>&nbsp;</p>
<p>&nbsp;</p>
													</div><!--mvp-post-add-main-->
													<div class="mvp-post-add-link">
														<a href="https://www.lockedondolphins.com/dolphins/dolphins-sign-ol-jesse-davis-to-3-year-extension/" rel="bookmark"><span class="mvp-post-add-link-but">Continue Reading</span></a>
													</div><!--mvp-post-add-link-->
												</div><!--mvp-post-add-cont-->
											</div><!--mvp-post-add-body-->
										</div><!--mvp-post-add-story-->
																			<div class="mvp-post-add-story left relative">
											<div class="mvp-post-add-head left relative">
												<h3 class="mvp-post-cat left relative"><a class="mvp-post-cat-link" href="https://www.lockedondolphins.com/category/dolphins/"><span class="mvp-post-cat left">Miami Dolphins</span></a></h3>
												<h1 class="mvp-post-title left">The Miami Dolphins announce their 2019 team captains</h1>
																																					<div class="mvp-author-info-wrap left relative">
														<div class="mvp-author-info-thumb left relative">
															<img src="https://www.lockedondolphins.com/wp-content/uploads/2019/02/image1-80x80.jpeg" width="46" height="46" alt="Shawn Digity" class="avatar avatar-46 wp-user-avatar wp-user-avatar-46 alignnone photo" />														</div><!--mvp-author-info-thumb-->
														<div class="mvp-author-info-text left relative">
															<div class="mvp-author-info-date left relative">
																<p>Published</p> <span class="mvp-post-date">2 days ago</span> <p>on</p> <span class="mvp-post-date">September 6, 2019</span>
															</div><!--mvp-author-info-date-->
															<div class="mvp-author-info-name left relative">
																<p>By</p> <span class="author-name"><a href="https://www.lockedondolphins.com/author/sdigity/" title="Posts by Shawn Digity" rel="author">Shawn Digity</a></span> <a href="@DIGITYnodoubt" class="mvp-twit-but" target="_blank"><span class="mvp-author-info-twit-but"><i class="fa fa-twitter fa-2"></i></span></a>
															</div><!--mvp-author-info-name-->
														</div><!--mvp-author-info-text-->
													</div><!--mvp-author-info-wrap-->
																							</div><!--mvp-post-add-head-->
											<div class="mvp-post-add-body left relative">
																																							<div class="mvp-post-add-img left relative">
															<img width="429" height="600" src="https://www.lockedondolphins.com/wp-content/uploads/2019/09/USATSI_11917709.jpg" class="attachment- size- wp-post-image" alt="Miami Dolphins team captains Jerome Baker" srcset="https://www.lockedondolphins.com/wp-content/uploads/2019/09/USATSI_11917709.jpg 429w, https://www.lockedondolphins.com/wp-content/uploads/2019/09/USATSI_11917709-214x300.jpg 214w, https://www.lockedondolphins.com/wp-content/uploads/2019/09/USATSI_11917709-768x1075.jpg 768w" sizes="(max-width: 429px) 100vw, 429px" />														</div><!--mvp-post-feat-img-->
																													<span class="mvp-feat-caption">Image courtesy of USA Today Sports</span>
																																																			<div class="mvp-post-add-cont left relative">
													<div class="mvp-post-add-main right relative">
														<h1>Miami Dolphins announce the 2019 team captains</h1>
<p>In preparation for their official kickoff against the Ravens on Sunday, the Miami Dolphins have announced the team captains for the season.</p>
<p>The players selected by their fellow teammates are <strong><a href="https://www.pro-football-reference.com/players/B/BakeJe00.htm?utm_campaign=Linker&amp;utm_source=direct&amp;utm_medium=linker-" target="_blank" rel="nofollow noopener noreferrer">Jerome Baker</a></strong> and <strong><a href="https://www.pro-football-reference.com/players/M/McCaBo01.htm?utm_campaign=Linker&amp;utm_source=direct&amp;utm_medium=linker-" target="_blank" rel="nofollow noopener noreferrer">Bobby McCain</a></strong> on defense, <strong><a href="https://www.pro-football-reference.com/players/K/KilgDa00.htm?utm_campaign=Linker&amp;utm_source=direct&amp;utm_medium=linker-" target="_blank" rel="nofollow noopener noreferrer">Daniel Kilgore</a></strong> on offense, and <strong><a href="https://www.pro-football-reference.com/players/A/AikeWa00.htm?utm_campaign=Linker&amp;utm_source=direct&amp;utm_medium=linker-" target="_blank" rel="nofollow noopener noreferrer">Walt Aikens</a> </strong>on special teams, Brian Flores announced on Friday during his press conference.</p>
<p>The honor speaks highly of <strong>Walt Aikens</strong>, <strong>Daniel Kilgore</strong>, and <strong>Bobby McCain</strong> for their leadership and veteran presence on the team and what it means to their teammates, but it also speaks volumes of what the team thinks of the second-year <strong>Jerome Baker</strong>, especially. Baker is going into his sophomore season, so it&#8217;s a great indication of his stepping up that his peers felt that it should be recognized.</p>
<p>You can watch the press conference below where Brian Flores unveils the team captains directly from the Miami Dolphins Twitter account. He also talks about the offensive line and the <a href="https://www.lockedondolphins.com/dolphins/miami-dolphins-sign-ot-jmarcus-webb-add-andrew-van-ginkel-to-ir/">newly signed <strong>J&#8217;Marcus Webb</strong></a>.</p>
<blockquote class="twitter-tweet" data-width="550" data-dnt="true">
<p lang="en" dir="ltr">Dolphins Live: Coach Flores meets with the media. <a href="https://t.co/qCK7k5jvmu">https://t.co/qCK7k5jvmu</a></p>
<p>&mdash; Miami Dolphins (@MiamiDolphins) <a href="https://twitter.com/MiamiDolphins/status/1170009291488518144?ref_src=twsrc%5Etfw">September 6, 2019</a></p></blockquote>
<p><script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></p>
<p>It stands to reason that each of the four selected captains will make meaningful impacts throughout the season. They&#8217;ll lead the charge, and they will kick that off against the Baltimore Ravens on Sunday at 1 p.m. EST.</p>
<p>&nbsp;</p>
													</div><!--mvp-post-add-main-->
													<div class="mvp-post-add-link">
														<a href="https://www.lockedondolphins.com/dolphins/the-miami-dolphins-announce-their-2019-team-captains/" rel="bookmark"><span class="mvp-post-add-link-but">Continue Reading</span></a>
													</div><!--mvp-post-add-link-->
												</div><!--mvp-post-add-cont-->
											</div><!--mvp-post-add-body-->
										</div><!--mvp-post-add-story-->
																	</div><!--mvp-post-add-wrap-->
							</div><!--mvp-post-add-box-->
													</div><!--mvp-post-content-->
						</div><!--mvp-post-main-in-->
													<div id="mvp-side-wrap" class="left relative">
						<section id="mvp_ad_widget-2" class="mvp-side-widget mvp_ad_widget">			<div class="mvp-widget-ad left relative">
				<span class="mvp-ad-label">Advertisement</span>
				<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Locked On Dolphins 300x250 Sidebar -->
<ins class="adsbygoogle"
     style="display:inline-block;width:300px;height:250px"
     data-ad-client="ca-pub-3311849153835630"
     data-ad-slot="1814147880"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>			</div><!--mvp-widget-ad-->
		</section>		<section id="recent-posts-2" class="mvp-side-widget widget_recent_entries">		<div class="mvp-widget-home-head"><h4 class="mvp-widget-home-title"><span class="mvp-widget-home-title">LATEST</span></h4></div>		<ul>
											<li>
					<a href="https://www.lockedondolphins.com/dolphins/blown-out-by-baltimore-again-miami-dolphins-week-1-recap/">Blown Out by Baltimore Again &#8211; Miami Dolphins Week 1 Recap</a>
											<span class="post-date">September 8, 2019</span>
									</li>
											<li>
					<a href="https://www.lockedondolphins.com/dolphins/draft/scouting-college-footballs-top-2020-quarterbacks-week-2/">Scouting College Football&#8217;s Top 2020 Quarterbacks &#8211; Week 2</a>
											<span class="post-date">September 7, 2019</span>
									</li>
											<li>
					<a href="https://www.lockedondolphins.com/dolphins/dolphins-sign-ol-jesse-davis-to-3-year-extension/">Dolphins Sign OL Jesse Davis to 3-Year Extension</a>
											<span class="post-date">September 7, 2019</span>
									</li>
											<li>
					<a href="https://www.lockedondolphins.com/dolphins/the-miami-dolphins-announce-their-2019-team-captains/">The Miami Dolphins announce their 2019 team captains</a>
											<span class="post-date">September 6, 2019</span>
									</li>
											<li>
					<a href="https://www.lockedondolphins.com/dolphins/staff-predictions-miami-dolphins-2019-season-record/">Staff Predictions: Miami Dolphins 2019 season record</a>
											<span class="post-date">September 6, 2019</span>
									</li>
					</ul>
		</section><section id="mvp_ad_widget-4" class="mvp-side-widget mvp_ad_widget">			<div class="mvp-widget-ad left relative">
				<span class="mvp-ad-label">Advertisement</span>
				<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Locked On Dolphins Skyscraper Sidebar -->
<ins class="adsbygoogle"
     style="display:inline-block;width:300px;height:600px"
     data-ad-client="ca-pub-3311849153835630"
     data-ad-slot="4572173168"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>			</div><!--mvp-widget-ad-->
		</section><section id="custom_html-4" class="widget_text mvp-side-widget widget_custom_html"><div class="textwidget custom-html-widget"><iframe frameborder="no" height="455" scrolling="no" src="https://player.megaphone.fm/podcast/PPY7775606149?tile=true" width="275"></iframe></div></section><section id="mvp_ad_widget-5" class="mvp-side-widget mvp_ad_widget">			<div class="mvp-widget-ad left relative">
				<span class="mvp-ad-label">Advertisement</span>
				<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Locked On Dolphins 300x250 Sidebar -->
<ins class="adsbygoogle"
     style="display:inline-block;width:300px;height:250px"
     data-ad-client="ca-pub-3311849153835630"
     data-ad-slot="1814147880"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>			</div><!--mvp-widget-ad-->
		</section>			</div><!--mvp-side-wrap-->											</div><!--mvp-post-main-out-->
				</div><!--mvp-post-main-->
							<div id="mvp-post-more-wrap" class="left relative">
					<h4 class="mvp-widget-home-title">
						<span class="mvp-widget-home-title">Trending</span>
					</h4>
					<ul class="mvp-post-more-list left relative">
													<a href="https://www.lockedondolphins.com/dolphins/miami-dolphins-2019-cut-tracker-live-document/" rel="bookmark">
							<li>
																	<div class="mvp-post-more-img left relative">
										<img width="400" height="240" src="https://www.lockedondolphins.com/wp-content/uploads/2019/07/USATSI_12751297-400x240.jpg" class="mvp-reg-img wp-post-image" alt="" srcset="https://www.lockedondolphins.com/wp-content/uploads/2019/07/USATSI_12751297-400x240.jpg 400w, https://www.lockedondolphins.com/wp-content/uploads/2019/07/USATSI_12751297-1000x600.jpg 1000w, https://www.lockedondolphins.com/wp-content/uploads/2019/07/USATSI_12751297-590x354.jpg 590w" sizes="(max-width: 400px) 100vw, 400px" />										<img width="80" height="80" src="https://www.lockedondolphins.com/wp-content/uploads/2019/07/USATSI_12751297-80x80.jpg" class="mvp-mob-img wp-post-image" alt="" srcset="https://www.lockedondolphins.com/wp-content/uploads/2019/07/USATSI_12751297-80x80.jpg 80w, https://www.lockedondolphins.com/wp-content/uploads/2019/07/USATSI_12751297-150x150.jpg 150w" sizes="(max-width: 80px) 100vw, 80px" />																			</div><!--mvp-post-more-img-->
																<div class="mvp-post-more-text left relative">
									<div class="mvp-cat-date-wrap left relative">
										<span class="mvp-cd-cat left relative">Miami Dolphins</span><span class="mvp-cd-date left relative">1 week ago</span>
									</div><!--mvp-cat-date-wrap-->
									<p>Miami Dolphins 2019 Cut Tracker (LIVE DOCUMENT)</p>
								</div><!--mvp-post-more-text-->
							</li>
							</a>
													<a href="https://www.lockedondolphins.com/dolphins/state-of-the-miami-dolphins-franchise-september-1-2019/" rel="bookmark">
							<li>
																	<div class="mvp-post-more-img left relative">
										<img width="400" height="240" src="https://www.lockedondolphins.com/wp-content/uploads/2019/09/USATSI_13277249-400x240.jpg" class="mvp-reg-img wp-post-image" alt="" srcset="https://www.lockedondolphins.com/wp-content/uploads/2019/09/USATSI_13277249-400x240.jpg 400w, https://www.lockedondolphins.com/wp-content/uploads/2019/09/USATSI_13277249-1000x600.jpg 1000w, https://www.lockedondolphins.com/wp-content/uploads/2019/09/USATSI_13277249-590x354.jpg 590w" sizes="(max-width: 400px) 100vw, 400px" />										<img width="80" height="80" src="https://www.lockedondolphins.com/wp-content/uploads/2019/09/USATSI_13277249-80x80.jpg" class="mvp-mob-img wp-post-image" alt="" srcset="https://www.lockedondolphins.com/wp-content/uploads/2019/09/USATSI_13277249-80x80.jpg 80w, https://www.lockedondolphins.com/wp-content/uploads/2019/09/USATSI_13277249-150x150.jpg 150w" sizes="(max-width: 80px) 100vw, 80px" />																			</div><!--mvp-post-more-img-->
																<div class="mvp-post-more-text left relative">
									<div class="mvp-cat-date-wrap left relative">
										<span class="mvp-cd-cat left relative">Miami Dolphins</span><span class="mvp-cd-date left relative">1 week ago</span>
									</div><!--mvp-cat-date-wrap-->
									<p>State of the Miami Dolphins Franchise &#8211; September 1, 2019</p>
								</div><!--mvp-post-more-text-->
							</li>
							</a>
													<a href="https://www.lockedondolphins.com/dolphins/meet-the-13-newest-miami-dolphins/" rel="bookmark">
							<li>
																	<div class="mvp-post-more-img left relative">
										<img width="400" height="240" src="https://www.lockedondolphins.com/wp-content/uploads/2019/09/USATSI_9837337-400x240.jpg" class="mvp-reg-img wp-post-image" alt="" srcset="https://www.lockedondolphins.com/wp-content/uploads/2019/09/USATSI_9837337-400x240.jpg 400w, https://www.lockedondolphins.com/wp-content/uploads/2019/09/USATSI_9837337-1000x600.jpg 1000w, https://www.lockedondolphins.com/wp-content/uploads/2019/09/USATSI_9837337-590x354.jpg 590w" sizes="(max-width: 400px) 100vw, 400px" />										<img width="80" height="80" src="https://www.lockedondolphins.com/wp-content/uploads/2019/09/USATSI_9837337-80x80.jpg" class="mvp-mob-img wp-post-image" alt="" srcset="https://www.lockedondolphins.com/wp-content/uploads/2019/09/USATSI_9837337-80x80.jpg 80w, https://www.lockedondolphins.com/wp-content/uploads/2019/09/USATSI_9837337-150x150.jpg 150w" sizes="(max-width: 80px) 100vw, 80px" />																			</div><!--mvp-post-more-img-->
																<div class="mvp-post-more-text left relative">
									<div class="mvp-cat-date-wrap left relative">
										<span class="mvp-cd-cat left relative">Miami Dolphins</span><span class="mvp-cd-date left relative">4 days ago</span>
									</div><!--mvp-cat-date-wrap-->
									<p>Meet the 13 Newest Miami Dolphins</p>
								</div><!--mvp-post-more-text-->
							</li>
							</a>
													<a href="https://www.lockedondolphins.com/dolphins/miami-dolphins-official-53-man-roster-likely-not-done-yet/" rel="bookmark">
							<li>
																	<div class="mvp-post-more-img left relative">
										<img width="400" height="240" src="https://www.lockedondolphins.com/wp-content/uploads/2019/08/E6F88566-DFD5-4087-8823-11DA9F7C4E4F-400x240.jpeg" class="mvp-reg-img wp-post-image" alt="" srcset="https://www.lockedondolphins.com/wp-content/uploads/2019/08/E6F88566-DFD5-4087-8823-11DA9F7C4E4F-400x240.jpeg 400w, https://www.lockedondolphins.com/wp-content/uploads/2019/08/E6F88566-DFD5-4087-8823-11DA9F7C4E4F-1000x600.jpeg 1000w, https://www.lockedondolphins.com/wp-content/uploads/2019/08/E6F88566-DFD5-4087-8823-11DA9F7C4E4F-590x354.jpeg 590w" sizes="(max-width: 400px) 100vw, 400px" />										<img width="80" height="80" src="https://www.lockedondolphins.com/wp-content/uploads/2019/08/E6F88566-DFD5-4087-8823-11DA9F7C4E4F-80x80.jpeg" class="mvp-mob-img wp-post-image" alt="" srcset="https://www.lockedondolphins.com/wp-content/uploads/2019/08/E6F88566-DFD5-4087-8823-11DA9F7C4E4F-80x80.jpeg 80w, https://www.lockedondolphins.com/wp-content/uploads/2019/08/E6F88566-DFD5-4087-8823-11DA9F7C4E4F-150x150.jpeg 150w" sizes="(max-width: 80px) 100vw, 80px" />																			</div><!--mvp-post-more-img-->
																<div class="mvp-post-more-text left relative">
									<div class="mvp-cat-date-wrap left relative">
										<span class="mvp-cd-cat left relative">Miami Dolphins</span><span class="mvp-cd-date left relative">1 week ago</span>
									</div><!--mvp-cat-date-wrap-->
									<p>Miami Dolphins Official 53-Man Roster, Likely Not Done Yet</p>
								</div><!--mvp-post-more-text-->
							</li>
							</a>
											</ul>
				</div><!--mvp-post-more-wrap-->
						</div><!--mvp-main-box-->
		</div><!--mvp-article-cont-->
		</article><!--mvp-article-wrap-->
			</div><!--mvp-main-body-wrap-->
			<footer id="mvp-foot-wrap" class="left relative">
				<div id="mvp-foot-top" class="left relative">
					<div class="mvp-main-box">
						<div id="mvp-foot-logo" class="left relative">
															<a href="https://www.lockedondolphins.com/"><img src="https://www.lockedondolphins.com/wp-content/uploads/2019/02/Locked-On-Dolphins-Podcast-Website-Logo-2.png" alt="Locked On Dolphins" data-rjs="2" /></a>
													</div><!--mvp-foot-logo-->
						<div id="mvp-foot-soc" class="left relative">
							<ul class="mvp-foot-soc-list left relative">
																									<li><a href="https://twitter.com/lockedonphins" target="_blank" class="fa fa-twitter fa-2"></a></li>
																																																															</ul>
						</div><!--mvp-foot-soc-->
						<div id="mvp-foot-menu-wrap" class="left relative">
							<div id="mvp-foot-menu" class="left relative">
								<div class="menu-dolphins-footer-menu-container"><ul id="menu-dolphins-footer-menu" class="menu"><li id="menu-item-5247" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5247"><a target="_blank" href="https://lockedonpodcasts.com/about/#contact">Contact</a></li>
<li id="menu-item-5248" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5248"><a target="_blank" href="https://lockedonpodcasts.com/advertising/">Advertise</a></li>
<li id="menu-item-5255" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5255"><a href="https://www.lockedondolphins.com/terms-and-conditions/">Terms and Conditions</a></li>
<li id="menu-item-5254" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5254"><a href="https://www.lockedondolphins.com/privacy-policy/">privacy policy</a></li>
<li id="menu-item-2572" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2572"><a href="https://www.lockedondolphins.com/cookie-policy-2/">Cookie Policy</a></li>
</ul></div>							</div><!--mvp-foot-menu-->
						</div><!--mvp-foot-menu-wrap-->
					</div><!--mvp-main-box-->
				</div><!--mvp-foot-top-->
				<div id="mvp-foot-bot" class="left relative">
					<div class="mvp-main-box">
						<div id="mvp-foot-copy" class="left relative">
							<p>Copyright © 2019 <a href="https://lockedonpodcasts.com/" target="_blank">Locked On Podcast Network</a>, All Rights Reserved.</p>
						</div><!--mvp-foot-copy-->
					</div><!--mvp-main-box-->
				</div><!--mvp-foot-bot-->
			</footer>
		</div><!--mvp-site-main-->
	</div><!--mvp-site-wall-->
</div><!--mvp-site-->
<div class="mvp-fly-top back-to-top">
	<i class="fa fa-angle-up fa-3"></i>
</div><!--mvp-fly-top-->
<div class="mvp-fly-fade mvp-fly-but-click">
</div><!--mvp-fly-fade-->
<script>
  var ai_insert_1 = function(){
    ai_insert ('after', 'div.mvp-main-blog-cont.left.relative', b64d ('PGRpdiBjbGFzcz0nY29kZS1ibG9jayBjb2RlLWJsb2NrLTEnIHN0eWxlPSdtYXJnaW46IDhweCBhdXRvOyB0ZXh0LWFsaWduOiBjZW50ZXI7IGRpc3BsYXk6IGJsb2NrOyBjbGVhcjogYm90aDsnPgo8c2NyaXB0IGFzeW5jIHNyYz0iLy9wYWdlYWQyLmdvb2dsZXN5bmRpY2F0aW9uLmNvbS9wYWdlYWQvanMvYWRzYnlnb29nbGUuanMiPjwvc2NyaXB0Pg0KPCEtLSBMb2NrZWQgT24gRG9scGhpbnMgNzI4eDkwIExlYWRlcmJvYXJkIC0tPg0KPGlucyBjbGFzcz0iYWRzYnlnb29nbGUiDQogICAgIHN0eWxlPSJkaXNwbGF5OmlubGluZS1ibG9jazt3aWR0aDo3MjhweDtoZWlnaHQ6OTBweCINCiAgICAgZGF0YS1hZC1jbGllbnQ9ImNhLXB1Yi0zMzExODQ5MTUzODM1NjMwIg0KICAgICBkYXRhLWFkLXNsb3Q9IjgzNzE4MTczNzkiPjwvaW5zPg0KPHNjcmlwdD4NCihhZHNieWdvb2dsZSA9IHdpbmRvdy5hZHNieWdvb2dsZSB8fCBbXSkucHVzaCh7fSk7DQo8L3NjcmlwdD48L2Rpdj4K'));
  };
  if (document.readyState === 'complete' || (document.readyState !== 'loading' && !document.documentElement.doScroll)) ai_insert_1 (); else document.addEventListener ('DOMContentLoaded', ai_insert_1);
</script>
<script>
setTimeout (function() {Array.prototype.forEach.call (document.querySelectorAll (".ai-viewports"), function (element, index) {ai_insert_code (element);});}, 10);

</script>
		<div data-theiaStickySidebar-sidebarSelector='".mvp-post-soc-wrap, #mvp-side-wrap"'
		     data-theiaStickySidebar-options='{"containerSelector":"","additionalMarginTop":140,"additionalMarginBottom":20,"updateSidebarHeight":false,"minWidth":1025,"sidebarBehavior":"stick-to-bottom","disableOnResponsiveLayouts":true}'></div>
		<script type='text/javascript'>
/* <![CDATA[ */
var ai_front = {"wp_ai":"5.1.2+2.4.22","insertion_before":"BEFORE","insertion_after":"AFTER","insertion_prepend":"PREPEND CONTENT","insertion_append":"APPEND CONTENT","insertion_replace_content":"REPLACE CONTENT","insertion_replace_element":"REPLACE ELEMENT","cancel":"Cancel","use":"Use","add":"Add","parent":"Parent","cancel_element_selection":"Cancel element selection","select_parent_element":"Select parent element","css_selector":"CSS selector","use_current_selector":"Use current selector","element":"ELEMENT","path":"PATH","selector":"SELECTOR","visible":"VISIBLE","hidden":"HIDDEN"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.lockedondolphins.com/wp-content/plugins/ad-inserter/includes/js/ai-jquery.js'></script>
<script type='text/javascript'>
function ai_insert(a,f,h){var e=-1!=f.indexOf(":eq")?jQuery(f):document.querySelectorAll(f);Array.prototype.forEach.call(e,function(b,e){selector_string=b.hasAttribute("id")?"#"+b.getAttribute("id"):b.hasAttribute("class")?"."+b.getAttribute("class").replace(RegExp(" ","g"),"."):"";var d=document.createElement("div");d.innerHTML=h;var c=d.getElementsByClassName("ai-selector-counter")[0];null!=c&&(c.innerText=e+1);c=d.getElementsByClassName("ai-debug-name ai-main")[0];if(null!=c){var g="";"before"==
a?g=ai_front.insertion_before:"after"==a?g=ai_front.insertion_after:"prepend"==a?g=ai_front.insertion_prepend:"append"==a?g=ai_front.insertion_append:"replace-content"==a?g=ai_front.insertion_replace_content:"replace-element"==a&&(g=ai_front.insertion_replace_element);c.innerText=g+" "+f+" ("+b.tagName.toLowerCase()+selector_string+")"}c=document.createRange().createContextualFragment(d.innerHTML);"before"==a?b.parentNode.insertBefore(c,b):"after"==a?b.parentNode.insertBefore(c,b.nextSibling):"prepend"==
a?b.insertBefore(c,b.firstChild):"append"==a?b.insertBefore(c,null):"replace-content"==a?b.innerHTML=d.innerHTML:"replace-element"==a&&(b.parentNode.insertBefore(c,b),b.parentNode.removeChild(b))})}
function ai_insert_code(a){function f(a,b){return null==a?!1:a.classList?a.classList.contains(b):-1<(" "+a.className+" ").indexOf(" "+b+" ")}function h(a,b){null!=a&&(a.classList?a.classList.add(b):a.className+=" "+b)}function e(a,b){null!=a&&(a.classList?a.classList.remove(b):a.className=a.className.replace(new RegExp("(^|\\b)"+b.split(" ").join("|")+"(\\b|$)","gi")," "))}var b=!!(a.offsetWidth||a.offsetHeight||a.getClientRects().length);a.getAttribute("data-block");if(b){b=a.getAttribute("data-code");
var k=a.getAttribute("data-insertion"),d=a.getAttribute("data-selector");null!=b&&(null!=k&&null!=d?document.querySelectorAll(d).length&&(ai_insert(k,d,b64d(b)),e(a,"ai-viewports")):(b=document.createRange().createContextualFragment(b64d(b)),a.parentNode.insertBefore(b,a.nextSibling),e(a,"ai-viewports")))}else b=a.previousElementSibling,f(b,"ai-debug-bar")&&f(b,"ai-debug-script")&&(e(b,"ai-debug-script"),h(b,"ai-debug-viewport-invisible")),e(a,"ai-viewports")}
function b64e(a){return btoa(encodeURIComponent(a).replace(/%([0-9A-F]{2})/g,function(a,h){return String.fromCharCode("0x"+h)}))}function b64d(a){return decodeURIComponent(atob(a).split("").map(function(a){return"%"+("00"+a.charCodeAt(0).toString(16)).slice(-2)}).join(""))};
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var wpcf7 = {"apiSettings":{"root":"https:\/\/www.lockedondolphins.com\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"}};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.lockedondolphins.com/wp-content/plugins/contact-form-7/includes/js/scripts.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var cnArgs = {"ajaxurl":"https:\/\/www.lockedondolphins.com\/wp-admin\/admin-ajax.php","hideEffect":"slide","onScroll":"yes","onScrollOffset":"200","cookieName":"cookie_notice_accepted","cookieValue":"true","cookieTime":"2147483647","cookiePath":"\/","cookieDomain":"","redirection":"","cache":"","refuse":"no","revoke_cookies":"0","revoke_cookies_opt":"automatic","secure":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.lockedondolphins.com/wp-content/plugins/cookie-notice/js/front.min.js'></script>
<script type='text/javascript' src='https://www.lockedondolphins.com/wp-content/plugins/theia-sticky-sidebar/js/ResizeSensor.js'></script>
<script type='text/javascript' src='https://www.lockedondolphins.com/wp-content/plugins/theia-sticky-sidebar/js/theia-sticky-sidebar.js'></script>
<script type='text/javascript' src='https://www.lockedondolphins.com/wp-content/plugins/theia-sticky-sidebar/js/main.js'></script>
<script type='text/javascript' src='https://www.lockedondolphins.com/wp-content/themes/zox-news/js/mvpcustom.js'></script>
<script type='text/javascript'>
	jQuery(document).ready(function($) {
	$(window).load(function(){
	var leaderHeight = $("#mvp-leader-wrap").outerHeight();
	var logoHeight = $("#mvp-main-nav-top").outerHeight();
	var botHeight = $("#mvp-main-nav-bot").outerHeight();
	var navHeight = $("#mvp-main-head-wrap").outerHeight();
	var headerHeight = navHeight + leaderHeight;
	var aboveNav = leaderHeight + logoHeight;
	var totalHeight = logoHeight + botHeight;
	var previousScroll = 0;
	$(window).scroll(function(event){
			var scroll = $(this).scrollTop();
			if ($(window).scrollTop() > aboveNav){
				$("#mvp-main-nav-top").addClass("mvp-nav-small");
				$("#mvp-main-nav-bot").css("margin-top", logoHeight );
			} else {
				$("#mvp-main-nav-top").removeClass("mvp-nav-small");
				$("#mvp-main-nav-bot").css("margin-top","0");
			}
			if ($(window).scrollTop() > headerHeight){
				$("#mvp-main-nav-top").addClass("mvp-fixed");
				$("#mvp-main-nav-bot").addClass("mvp-fixed1");
				$("#mvp-main-body-wrap").css("margin-top", totalHeight );
				$("#mvp-main-nav-top").addClass("mvp-fixed-shadow");
				$(".mvp-nav-top-mid").addClass("mvp-fixed-post");
				$(".mvp-drop-nav-title").show();
				$(".mvp-fly-top").addClass("mvp-to-top");
	    		if(scroll < previousScroll) {
					$("#mvp-main-nav-bot").addClass("mvp-fixed2");
					$("#mvp-main-nav-top").removeClass("mvp-fixed-shadow");
					$("#mvp-main-nav-top").removeClass("mvp-soc-mob-up");
					$("#mvp-soc-mob-wrap").removeClass("mvp-soc-mob-up");
				} else {
					$("#mvp-main-nav-bot").removeClass("mvp-fixed2");
					$("#mvp-main-nav-top").addClass("mvp-fixed-shadow");
					$("#mvp-main-nav-top").addClass("mvp-soc-mob-up");
					$("#mvp-soc-mob-wrap").addClass("mvp-soc-mob-up");
				}
			} else {
				$("#mvp-main-nav-top").removeClass("mvp-fixed");
				$("#mvp-main-nav-bot").removeClass("mvp-fixed1");
				$("#mvp-main-nav-bot").removeClass("mvp-fixed2");
				$("#mvp-main-body-wrap").css("margin-top","0");
				$("#mvp-main-nav-top").removeClass("mvp-fixed-shadow");
				$(".mvp-nav-top-mid").removeClass("mvp-fixed-post");
				$(".mvp-drop-nav-title").hide();
	    		$(".mvp-fly-top").removeClass("mvp-to-top");
			}
			previousScroll = scroll;
	});
	});
	});
	

	jQuery(document).ready(function($) {
	// Mobile Social Buttons More
	$(window).load(function(){
 		$(".mvp-soc-mob-right").on("click", function(){
			$("#mvp-soc-mob-wrap").toggleClass("mvp-soc-mob-more");
  		});
  	});
	});
  	

	jQuery(document).ready(function($) {
	$(".menu-item-has-children a").click(function(event){
	  event.stopPropagation();
	  location.href = this.href;
  	});

	$(".menu-item-has-children").click(function(){
    	  $(this).addClass("toggled");
    	  if($(".menu-item-has-children").hasClass("toggled"))
    	  {
    	  $(this).children("ul").toggle();
	  $(".mvp-fly-nav-menu").getNiceScroll().resize();
	  }
	  $(this).toggleClass("tog-minus");
    	  return false;
  	});

	// Main Menu Scroll
	$(window).load(function(){
	  $(".mvp-fly-nav-menu").niceScroll({cursorcolor:"#888",cursorwidth: 7,cursorborder: 0,zindex:999999});
	});
	});
	

	jQuery(document).ready(function($) {
	$(".infinite-content").infinitescroll({
	  navSelector: ".mvp-nav-links",
	  nextSelector: ".mvp-nav-links a:first",
	  itemSelector: ".infinite-post",
	  errorCallback: function(){ $(".mvp-inf-more-but").css("display", "none") }
	});
	$(window).unbind(".infscr");
	$(".mvp-inf-more-but").click(function(){
   		$(".infinite-content").infinitescroll("retrieve");
        	return false;
	});
	$(window).load(function(){
		if ($(".mvp-nav-links a").length) {
			$(".mvp-inf-more-but").css("display","inline-block");
		} else {
			$(".mvp-inf-more-but").css("display","none");
		}
	});
	});
	
</script>
<script type='text/javascript' src='https://www.lockedondolphins.com/wp-content/themes/zox-news/js/scripts.js'></script>
<script type='text/javascript' src='https://www.lockedondolphins.com/wp-content/themes/zox-news/js/retina.js'></script>
<script type='text/javascript' src='https://www.lockedondolphins.com/wp-content/themes/zox-news/js/flexslider.js'></script>
<script type='text/javascript' src='https://www.lockedondolphins.com/wp-content/themes/zox-news/js/jquery.infinitescroll.min.js'></script>
<script type='text/javascript' src='https://www.lockedondolphins.com/wp-includes/js/comment-reply.min.js'></script>
<script type='text/javascript' src='https://www.lockedondolphins.com/wp-includes/js/wp-embed.min.js'></script>
<script async="async" type='text/javascript' src='https://www.lockedondolphins.com/wp-content/plugins/akismet/_inc/form.js'></script>

			<div id="cookie-notice" role="banner" class="cn-bottom bootstrap" style="color: #fff; background-color: #000;"><div class="cookie-notice-container"><span id="cn-notice-text">We use cookies to provide you with the best experience on our website. If you stick around, we'll assume that you're happy with it.</span><a href="#" id="cn-accept-cookie" data-cookie-set="accept" class="cn-set-cookie cn-button bootstrap button">Ok</a>
				</div>
				
			</div></body>
</html>