<!DOCTYPE html>
<html lang="en-US">
<head>
<meta charset="UTF-8" >
<meta name="viewport" id="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=1.0, minimum-scale=1.0, user-scalable=no" />
<script data-cfasync="false" id="ao_optimized_gfonts_config" type="text/javascript">WebFontConfig={google:{families:["Advent Pro:700&subset=latin,latin-ext,cyrillic,cyrillic-ext,greek-ext,greek,vietnamese","Open Sans:700&subset=latin,latin-ext,cyrillic,cyrillic-ext,greek-ext,greek,vietnamese","Anton:400&subset=latin,latin-ext,cyrillic,cyrillic-ext,greek-ext,greek,vietnamese","Oswald:100,200,300,400,500,600,700,800,900&subset=latin,latin-ext,cyrillic,cyrillic-ext,greek-ext,greek,vietnamese","Oswald:100,200,300,400,500,600,700,800,900&subset=latin,latin-ext,cyrillic,cyrillic-ext,greek-ext,greek,vietnamese","Roboto:100,200,300,400,500,600,700,800,900&subset=latin,latin-ext,cyrillic,cyrillic-ext,greek-ext,greek,vietnamese","Roboto:100,200,300,400,500,600,700,800,900&subset=latin,latin-ext,cyrillic,cyrillic-ext,greek-ext,greek,vietnamese","PT Serif:100,200,300,400,500,600,700,800,900&subset=latin,latin-ext,cyrillic,cyrillic-ext,greek-ext,greek,vietnamese","Oswald:100,200,300,400,500,600,700,800,900&subset=latin,latin-ext,cyrillic,cyrillic-ext,greek-ext,greek,vietnamese"] },classes:false, events:false, timeout:1500};</script><link rel="shortcut icon" href="https://www.lockedondolphins.com/wp-content/uploads/2018/05/lockedondolphinsicon.jpg" /><link rel="pingback" href="https://www.lockedondolphins.com/xmlrpc.php" />
<meta property="og:type" content="article" />
					<meta property="og:image" content="https://www.lockedondolphins.com/wp-content/uploads/2019/11/USATSI_10245602-1000x600.jpg" />
		<meta name="twitter:image" content="https://www.lockedondolphins.com/wp-content/uploads/2019/11/USATSI_10245602-1000x600.jpg" />
	<meta property="og:url" content="https://www.lockedondolphins.com/dolphins/dolphins-eagles-week-13-preview/" />
<meta property="og:title" content="Dolphins Eagles Week 13 Preview" />
<meta property="og:description" content="Eagles offense looks to take flight against Miami’s banged up secondary Who: Dolphins (2-9) vs. Eagles (5-6) When: Sunday December 1, 1:00 East Where: Hard Rock Stadium &#8212; Miami Gardens, FL Weather: 80 degrees, partly cloudy Vegas Slant: Dolphins +10 A cornucopia of bad animal puns are available to us this week as the lifeless [&hellip;]" />
<meta name="twitter:card" content="summary">
<meta name="twitter:url" content="https://www.lockedondolphins.com/dolphins/dolphins-eagles-week-13-preview/">
<meta name="twitter:title" content="Dolphins Eagles Week 13 Preview">
<meta name="twitter:description" content="Eagles offense looks to take flight against Miami’s banged up secondary Who: Dolphins (2-9) vs. Eagles (5-6) When: Sunday December 1, 1:00 East Where: Hard Rock Stadium &#8212; Miami Gardens, FL Weather: 80 degrees, partly cloudy Vegas Slant: Dolphins +10 A cornucopia of bad animal puns are available to us this week as the lifeless [&hellip;]">
<link type="text/css" media="all" href="https://www.lockedondolphins.com/wp-content/cache/autoptimize/css/autoptimize_e49c9a58bfc4be99dcf491f2fb7639e8.css" rel="stylesheet" /><title>Dolphins Eagles Week 13 Preview</title>
<link rel="amphtml" href="https://www.lockedondolphins.com/dolphins/dolphins-eagles-week-13-preview/amp/" /><meta name="generator" content="AMP for WP 0.9.97.65"/><link href='https://fonts.gstatic.com' crossorigin='anonymous' rel='preconnect' />
<link href='https://ajax.googleapis.com' rel='preconnect' />
<link href='https://fonts.googleapis.com' rel='preconnect' />
<link rel="alternate" type="application/rss+xml" title="Locked On Dolphins &raquo; Feed" href="https://www.lockedondolphins.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Locked On Dolphins &raquo; Comments Feed" href="https://www.lockedondolphins.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Locked On Dolphins &raquo; Dolphins Eagles Week 13 Preview Comments Feed" href="https://www.lockedondolphins.com/dolphins/dolphins-eagles-week-13-preview/feed/" />












<link rel='https://api.w.org/' href='https://www.lockedondolphins.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.lockedondolphins.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.lockedondolphins.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='Jakeem Grant placed on Injured Reserve' href='https://www.lockedondolphins.com/dolphins/news/jakeem-grant-placed-on-injured-reserve/' />
<link rel='shortlink' href='https://www.lockedondolphins.com/?p=8815' />
<link rel="alternate" type="application/json+oembed" href="https://www.lockedondolphins.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.lockedondolphins.com%2Fdolphins%2Fdolphins-eagles-week-13-preview%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.lockedondolphins.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.lockedondolphins.com%2Fdolphins%2Fdolphins-eagles-week-13-preview%2F&#038;format=xml" />
<!-- start Simple Custom CSS and JS -->
<script type="text/javascript">
/* When the user clicks on the button, 
toggle between hiding and showing the dropdown content */
function myFunction() {
    document.getElementById("myDropdown").classList.toggle("show");
}

// Close the dropdown menu if the user clicks outside of it
window.onclick = function(event) {
  if (!event.target.matches('.dropbtn')) {

    var dropdowns = document.getElementsByClassName("dropdown-content");
    var i;
    for (i = 0; i < dropdowns.length; i++) {
      var openDropdown = dropdowns[i];
      if (openDropdown.classList.contains('show')) {
        openDropdown.classList.remove('show');
      }
    }
  }
}

</script>
<!-- end Simple Custom CSS and JS -->
<!-- start Simple Custom CSS and JS -->

<!-- end Simple Custom CSS and JS -->

            <script>
                (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
                (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
                m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
                })(window,document,'script','//www.google-analytics.com/analytics.js','gaplusu');

                function gaplus_track() {
                                                gaplusu('create', 'UA-106810897-1 ', 'auto');
                                                    gaplusu('set', 'anonymizeIp', true);
                                                                            gaplusu('require', 'displayfeatures');
                                                                            gaplusu('send', 'pageview');
                    
                                    }

                                    gaplus_track();
                
            </script>

		<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script>
  (adsbygoogle = window.adsbygoogle || []).push({
    google_ad_client: "ca-pub-3311849153835630",
    enable_page_level_ads: true
  });
</script><!-- SEO meta tags powered by SmartCrawl https://premium.wpmudev.org/project/smartcrawl-wordpress-seo/ -->
<meta name="description" content="Eagles offense looks to take flight against Miami’s banged up secondary Who: Dolphins (2-9) vs. Eagles (5-6) When: Sunday December 1, 1:00 East Where: Hard Rock Stadium -- Miami Gardens, FL Weather: 80 degrees, partly cloudy Vegas Slant: Dolphins +10 A cornucopia of bad animal puns are available ..." />
<meta name="google-site-verification" content="VcvW7atgyXYq3Tb5JeSRSUr2vLMMZ9Rtro-Ik52-GSU" />
<meta name="msvalidate.01" content="0B5AABFBD8EC8B2555A2D0CC5B983691" />
<meta property="og:type" content="article" />
<meta property="og:url" content="https://www.lockedondolphins.com/dolphins/dolphins-eagles-week-13-preview/" />
<meta property="og:title" content="Dolphins Eagles Week 13 Preview" />
<meta property="og:description" content="Eagles offense looks to take flight against Miami’s banged up secondary Who: Dolphins (2-9) vs. Eagles (5-6) When: Sunday December 1, 1:00 East Where: Hard Rock Stadium -- Miami Gardens, FL Weather: 80 degrees, partly cloudy Vegas Slant: Dolphins +10 A cornucopia of bad animal puns are available ..." />
<meta property="og:image" content="https://www.lockedondolphins.com/wp-content/uploads/2019/11/USATSI_10245602-1000x600.jpg" />
<meta property="article:published_time" content="2019-11-28T10:00:17" />
<meta property="article:author" content="Travis Wingfield" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:site" content="LockedonPhins" />
<meta name="twitter:title" content="Dolphins Eagles Week 13 Preview" />
<meta name="twitter:description" content="Eagles offense looks to take flight against Miami’s banged up secondary Who: Dolphins (2-9) vs. Eagles (5-6) When: Sunday December 1, 1:00 East Where: Hard Rock Stadium -- Miami Gardens, FL Weather: 80 degrees, partly cloudy Vegas Slant: Dolphins +10 A cornucopia of bad animal puns are available ..." />
<meta name="twitter:image" content="https://www.lockedondolphins.com/wp-content/uploads/2019/11/USATSI_10245602-1000x600.jpg" />
<!-- /SEO -->
<script>if (document.location.protocol != "https:") {document.location = document.URL.replace(/^http:/i, "https:");}</script><script type='text/javascript' src='https://www.lockedondolphins.com/wp-includes/js/jquery/jquery.js'></script>
<script type='text/javascript' src='https://www.lockedondolphins.com/wp-includes/js/jquery/jquery-migrate.min.js'></script>

	<script data-cfasync="false" id="ao_optimized_gfonts_webfontloader" type="text/javascript">(function() {var wf = document.createElement('script');wf.src='https://ajax.googleapis.com/ajax/libs/webfont/1/webfont.js';wf.type='text/javascript';wf.async='true';var s=document.getElementsByTagName('script')[0];s.parentNode.insertBefore(wf, s);})();</script></head>
<body data-rsssl=1 class="post-template-default single single-post postid-8815 single-format-standard custom-background cookies-not-set desktop">
	<div id="mvp-fly-wrap">
	<div id="mvp-fly-menu-top" class="left relative">
		<div class="mvp-fly-top-out left relative">
			<div class="mvp-fly-top-in">
				<div id="mvp-fly-logo" class="left relative">
											<a href="https://www.lockedondolphins.com/"><img src="https://www.lockedondolphins.com/wp-content/uploads/2019/02/Locked-On-Dolphins-Podcast-Website-Logo-1.png" alt="Locked On Dolphins" data-rjs="2" /></a>
									</div><!--mvp-fly-logo-->
			</div><!--mvp-fly-top-in-->
			<div class="mvp-fly-but-wrap mvp-fly-but-menu mvp-fly-but-click">
				<span></span>
				<span></span>
				<span></span>
				<span></span>
			</div><!--mvp-fly-but-wrap-->
		</div><!--mvp-fly-top-out-->
	</div><!--mvp-fly-menu-top-->
	<div id="mvp-fly-menu-wrap">
		<nav class="mvp-fly-nav-menu left relative">
			<div class="menu-dolphins-main-nav-new-container"><ul id="menu-dolphins-main-nav-new" class="menu"><li id="menu-item-5318" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5318"><a href="https://www.lockedondolphins.com/category/dolphins/news/">News</a></li>
<li id="menu-item-5319" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5319"><a href="https://www.lockedondolphins.com/category/dolphins/draft/">NFL Draft</a></li>
<li id="menu-item-5409" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5409"><a href="https://cms.megaphone.fm/channel/lockedondolphins">Podcast</a></li>
<li id="menu-item-5321" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5321"><a href="https://www.lockedondolphins.com/category/dolphins/scouting/">Scouting</a></li>
<li id="menu-item-5322" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-5322"><a href="#">Subscribe to Podcast</a>
<ul class="sub-menu">
	<li id="menu-item-5323" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5323"><a href="https://itunes.apple.com/us/podcast/locked-on-dolphins/id1137170219?mt=2">Apple Podcast</a></li>
	<li id="menu-item-5324" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5324"><a href="https://play.google.com/music/listen?u=0#/ps/Ins66r5pdzmd3byrgo6kkibuw5a">Google Play</a></li>
	<li id="menu-item-5325" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5325"><a href="https://open.spotify.com/show/1h5AvikBOVYhqtI7zuuUU7">Spotify</a></li>
	<li id="menu-item-5326" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5326"><a href="https://tunein.com/podcasts/Sports--Recreation-Podcasts/Locked-on-Dolphins-p1025314/">TuneIn</a></li>
</ul>
</li>
</ul></div>		</nav>
	</div><!--mvp-fly-menu-wrap-->
	<div id="mvp-fly-soc-wrap">
		<span class="mvp-fly-soc-head">Connect with us</span>
		<ul class="mvp-fly-soc-list left relative">
										<li><a href="https://twitter.com/lockedonphins" target="_blank" class="fa fa-twitter fa-2"></a></li>
																							</ul>
	</div><!--mvp-fly-soc-wrap-->
</div><!--mvp-fly-wrap-->	<div id="mvp-site" class="left relative">
		<div id="mvp-search-wrap">
			<div id="mvp-search-box">
				<form method="get" id="searchform" action="https://www.lockedondolphins.com/">
	<input type="text" name="s" id="s" value="Search" onfocus='if (this.value == "Search") { this.value = ""; }' onblur='if (this.value == "") { this.value = "Search"; }' />
	<input type="hidden" id="searchsubmit" value="Search" />
</form>			</div><!--mvp-search-box-->
			<div class="mvp-search-but-wrap mvp-search-click">
				<span></span>
				<span></span>
			</div><!--mvp-search-but-wrap-->
		</div><!--mvp-search-wrap-->
				<div id="mvp-site-wall" class="left relative">
											<div id="mvp-leader-wrap">
					<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Locked On Dolphins 728x90 Leaderboard -->
<ins class="adsbygoogle"
     style="display:inline-block;width:728px;height:90px"
     data-ad-client="ca-pub-3311849153835630"
     data-ad-slot="8371817379"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>				</div><!--mvp-leader-wrap-->
										<div id="mvp-site-main" class="left relative">
			<header id="mvp-main-head-wrap" class="left relative">
									<nav id="mvp-main-nav-wrap" class="left relative">
						<div id="mvp-main-nav-top" class="left relative">
							<div class="mvp-main-box">
								<div id="mvp-nav-top-wrap" class="left relative">
									<div class="mvp-nav-top-right-out left relative">
										<div class="mvp-nav-top-right-in">
											<div class="mvp-nav-top-cont left relative">
												<div class="mvp-nav-top-left-out relative">
													<div class="mvp-nav-top-left">
														<div class="mvp-nav-soc-wrap">
																																														<a href="https://twitter.com/lockedonphins" target="_blank"><span class="mvp-nav-soc-but fa fa-twitter fa-2"></span></a>
																																																											</div><!--mvp-nav-soc-wrap-->
														<div class="mvp-fly-but-wrap mvp-fly-but-click left relative">
															<span></span>
															<span></span>
															<span></span>
															<span></span>
														</div><!--mvp-fly-but-wrap-->
													</div><!--mvp-nav-top-left-->
													<div class="mvp-nav-top-left-in">
														<div class="mvp-nav-top-mid left relative" itemscope itemtype="http://schema.org/Organization">
																															<a class="mvp-nav-logo-reg" itemprop="url" href="https://www.lockedondolphins.com/"><img itemprop="logo" src="https://www.lockedondolphins.com/wp-content/uploads/2019/02/Locked-On-Dolphins-Podcast-Website-Logo.png" alt="Locked On Dolphins" data-rjs="2" /></a>
																																														<a class="mvp-nav-logo-small" href="https://www.lockedondolphins.com/"><img src="https://www.lockedondolphins.com/wp-content/uploads/2019/02/Locked-On-Dolphins-Podcast-Website-Logo-1.png" alt="Locked On Dolphins" data-rjs="2" /></a>
																																														<h2 class="mvp-logo-title">Locked On Dolphins</h2>
																																														<div class="mvp-drop-nav-title left">
																	<h4>Dolphins Eagles Week 13 Preview</h4>
																</div><!--mvp-drop-nav-title-->
																													</div><!--mvp-nav-top-mid-->
													</div><!--mvp-nav-top-left-in-->
												</div><!--mvp-nav-top-left-out-->
											</div><!--mvp-nav-top-cont-->
										</div><!--mvp-nav-top-right-in-->
										<div class="mvp-nav-top-right">
																						<span class="mvp-nav-search-but fa fa-search fa-2 mvp-search-click"></span>
										</div><!--mvp-nav-top-right-->
									</div><!--mvp-nav-top-right-out-->
								</div><!--mvp-nav-top-wrap-->
							</div><!--mvp-main-box-->
						</div><!--mvp-main-nav-top-->
						<div id="mvp-main-nav-bot" class="left relative">
							<div id="mvp-main-nav-bot-cont" class="left">
								<div class="mvp-main-box">
									<div id="mvp-nav-bot-wrap" class="left">
										<div class="mvp-nav-bot-right-out left">
											<div class="mvp-nav-bot-right-in">
												<div class="mvp-nav-bot-cont left">
													<div class="mvp-nav-bot-left-out">
														<div class="mvp-nav-bot-left left relative">
															<div class="mvp-fly-but-wrap mvp-fly-but-click left relative">
																<span></span>
																<span></span>
																<span></span>
																<span></span>
															</div><!--mvp-fly-but-wrap-->
														</div><!--mvp-nav-bot-left-->
														<div class="mvp-nav-bot-left-in">
															<div class="mvp-nav-menu left">
																<div class="menu-dolphins-main-nav-new-container"><ul id="menu-dolphins-main-nav-new-1" class="menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5318"><a href="https://www.lockedondolphins.com/category/dolphins/news/">News</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5319"><a href="https://www.lockedondolphins.com/category/dolphins/draft/">NFL Draft</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5409"><a href="https://cms.megaphone.fm/channel/lockedondolphins">Podcast</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5321"><a href="https://www.lockedondolphins.com/category/dolphins/scouting/">Scouting</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-5322"><a href="#">Subscribe to Podcast</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5323"><a href="https://itunes.apple.com/us/podcast/locked-on-dolphins/id1137170219?mt=2">Apple Podcast</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5324"><a href="https://play.google.com/music/listen?u=0#/ps/Ins66r5pdzmd3byrgo6kkibuw5a">Google Play</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5325"><a href="https://open.spotify.com/show/1h5AvikBOVYhqtI7zuuUU7">Spotify</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5326"><a href="https://tunein.com/podcasts/Sports--Recreation-Podcasts/Locked-on-Dolphins-p1025314/">TuneIn</a></li>
</ul>
</li>
</ul></div>															</div><!--mvp-nav-menu-->
														</div><!--mvp-nav-bot-left-in-->
													</div><!--mvp-nav-bot-left-out-->
												</div><!--mvp-nav-bot-cont-->
											</div><!--mvp-nav-bot-right-in-->
											<div class="mvp-nav-bot-right left relative">
												<span class="mvp-nav-search-but fa fa-search fa-2 mvp-search-click"></span>
											</div><!--mvp-nav-bot-right-->
										</div><!--mvp-nav-bot-right-out-->
									</div><!--mvp-nav-bot-wrap-->
								</div><!--mvp-main-nav-bot-cont-->
							</div><!--mvp-main-box-->
						</div><!--mvp-main-nav-bot-->
					</nav><!--mvp-main-nav-wrap-->
							</header><!--mvp-main-head-wrap-->
			<div id="mvp-main-body-wrap" class="left relative"><article id="mvp-article-wrap" itemscope itemtype="http://schema.org/NewsArticle">
			<meta itemscope itemprop="mainEntityOfPage"  itemType="https://schema.org/WebPage" itemid="https://www.lockedondolphins.com/dolphins/dolphins-eagles-week-13-preview/"/>
						<div id="mvp-article-cont" class="left relative">
			<div class="mvp-main-box">
				<div id="mvp-post-main" class="left relative">
										<div class="mvp-post-main-out left relative">
						<div class="mvp-post-main-in">
							<div id="mvp-post-content" class="left relative">
																	<header id="mvp-post-head" class="left relative">
										<h3 class="mvp-post-cat left relative"><a class="mvp-post-cat-link" href="https://www.lockedondolphins.com/category/dolphins/"><span class="mvp-post-cat left">Miami Dolphins</span></a></h3>
										<h1 class="mvp-post-title left entry-title" itemprop="headline">Dolphins Eagles Week 13 Preview</h1>
																															<div class="mvp-author-info-wrap left relative">
												<div class="mvp-author-info-thumb left relative">
													<img src="https://www.lockedondolphins.com/wp-content/uploads/2019/06/Profile-80x80.jpg" width="46" height="46" alt="Travis Wingfield" class="avatar avatar-46 wp-user-avatar wp-user-avatar-46 alignnone photo" />												</div><!--mvp-author-info-thumb-->
												<div class="mvp-author-info-text left relative">
													<div class="mvp-author-info-date left relative">
														<p>Published</p> <span class="mvp-post-date">1 hour ago</span> <p>on</p> <span class="mvp-post-date updated"><time class="post-date updated" itemprop="datePublished" datetime="2019-11-28">November 28, 2019</time></span>
														<meta itemprop="dateModified" content="2019-11-27"/>
													</div><!--mvp-author-info-date-->
													<div class="mvp-author-info-name left relative" itemprop="author" itemscope itemtype="https://schema.org/Person">
														<p>By</p> <span class="author-name vcard fn author" itemprop="name"><a href="https://www.lockedondolphins.com/author/twingfield/" title="Posts by Travis Wingfield" rel="author">Travis Wingfield</a></span> <a href="" class="mvp-twit-but" target="_blank"><span class="mvp-author-info-twit-but"><i class="fa fa-twitter fa-2"></i></span></a>
													</div><!--mvp-author-info-name-->
												</div><!--mvp-author-info-text-->
											</div><!--mvp-author-info-wrap-->
																			</header>
																																																														<div id="mvp-post-feat-img" class="left relative mvp-post-feat-img-wide2" itemprop="image" itemscope itemtype="https://schema.org/ImageObject">
												<img width="860" height="600" src="https://www.lockedondolphins.com/wp-content/uploads/2019/11/USATSI_10245602.jpg" class="attachment- size- wp-post-image" alt="" srcset="https://www.lockedondolphins.com/wp-content/uploads/2019/11/USATSI_10245602.jpg 860w, https://www.lockedondolphins.com/wp-content/uploads/2019/11/USATSI_10245602-300x209.jpg 300w, https://www.lockedondolphins.com/wp-content/uploads/2019/11/USATSI_10245602-768x536.jpg 768w" sizes="(max-width: 860px) 100vw, 860px" />																								<meta itemprop="url" content="https://www.lockedondolphins.com/wp-content/uploads/2019/11/USATSI_10245602-1000x600.jpg">
												<meta itemprop="width" content="1000">
												<meta itemprop="height" content="600">
											</div><!--mvp-post-feat-img-->
																																																														<div id="mvp-content-wrap" class="left relative">
									<div class="mvp-post-soc-out right relative">
																																		<div class="mvp-post-soc-wrap left relative">
		<ul class="mvp-post-soc-list left relative">
			<a href="#" onclick="window.open('http://www.facebook.com/sharer.php?u=https://www.lockedondolphins.com/dolphins/dolphins-eagles-week-13-preview/&amp;t=Dolphins Eagles Week 13 Preview', 'facebookShare', 'width=626,height=436'); return false;" title="Share on Facebook">
			<li class="mvp-post-soc-fb">
				<i class="fa fa-2 fa-facebook" aria-hidden="true"></i>
			</li>
			</a>
			<a href="#" onclick="window.open('http://twitter.com/share?text=Dolphins Eagles Week 13 Preview -&amp;url=https://www.lockedondolphins.com/dolphins/dolphins-eagles-week-13-preview/', 'twitterShare', 'width=626,height=436'); return false;" title="Tweet This Post">
			<li class="mvp-post-soc-twit">
				<i class="fa fa-2 fa-twitter" aria-hidden="true"></i>
			</li>
			</a>
			<a href="#" onclick="window.open('http://pinterest.com/pin/create/button/?url=https://www.lockedondolphins.com/dolphins/dolphins-eagles-week-13-preview/&amp;media=https://www.lockedondolphins.com/wp-content/uploads/2019/11/USATSI_10245602-1000x600.jpg&amp;description=Dolphins Eagles Week 13 Preview', 'pinterestShare', 'width=750,height=350'); return false;" title="Pin This Post">
			<li class="mvp-post-soc-pin">
				<i class="fa fa-2 fa-pinterest-p" aria-hidden="true"></i>
			</li>
			</a>
			<a href="/cdn-cgi/l/email-protection#eed19d9b8c848b8d9ad3aa81829e8687809dceab8f89828b9dceb98b8b85cedfddcebe9c8b98878b99c88f839ed5aca1aab7d3a7ce88819b808ace9a86879dce8f9c9a878d828bce87809a8b9c8b9d9a878089ce8f808ace9a86819b89869ace8188ce9d868f9c878089ce879ace99879a86ce97819bc0cead868b8d85ce879ace819b9ad4ce869a9a9e9dd4c1c1999999c082818d858b8a81808a81829e8687809dc08d8183c18a81829e8687809dc18a81829e8687809dc38b8f89828b9dc3998b8b85c3dfddc39e9c8b98878b99c1">
			<li class="mvp-post-soc-email">
				<i class="fa fa-2 fa-envelope" aria-hidden="true"></i>
			</li>
			</a>
												<a href="https://www.lockedondolphins.com/dolphins/dolphins-eagles-week-13-preview/#respond">
					<li class="mvp-post-soc-com mvp-com-click">
						<i class="fa fa-2 fa-commenting" aria-hidden="true"></i>
					</li>
					</a>
									</ul>
	</div><!--mvp-post-soc-wrap-->
	<div id="mvp-soc-mob-wrap">
		<div class="mvp-soc-mob-out left relative">
			<div class="mvp-soc-mob-in">
				<div class="mvp-soc-mob-left left relative">
					<ul class="mvp-soc-mob-list left relative">
						<a href="#" onclick="window.open('http://www.facebook.com/sharer.php?u=https://www.lockedondolphins.com/dolphins/dolphins-eagles-week-13-preview/&amp;t=Dolphins Eagles Week 13 Preview', 'facebookShare', 'width=626,height=436'); return false;" title="Share on Facebook">
						<li class="mvp-soc-mob-fb">
							<i class="fa fa-facebook" aria-hidden="true"></i><span class="mvp-soc-mob-fb">Share</span>
						</li>
						</a>
						<a href="#" onclick="window.open('http://twitter.com/share?text=Dolphins Eagles Week 13 Preview -&amp;url=https://www.lockedondolphins.com/dolphins/dolphins-eagles-week-13-preview/', 'twitterShare', 'width=626,height=436'); return false;" title="Tweet This Post">
						<li class="mvp-soc-mob-twit">
							<i class="fa fa-twitter" aria-hidden="true"></i><span class="mvp-soc-mob-fb">Tweet</span>
						</li>
						</a>
						<a href="#" onclick="window.open('http://pinterest.com/pin/create/button/?url=https://www.lockedondolphins.com/dolphins/dolphins-eagles-week-13-preview/&amp;media=https://www.lockedondolphins.com/wp-content/uploads/2019/11/USATSI_10245602-1000x600.jpg&amp;description=Dolphins Eagles Week 13 Preview', 'pinterestShare', 'width=750,height=350'); return false;" title="Pin This Post">
						<li class="mvp-soc-mob-pin">
							<i class="fa fa-pinterest-p" aria-hidden="true"></i>
						</li>
						</a>
						<a href="whatsapp://send?text=Dolphins Eagles Week 13 Preview https://www.lockedondolphins.com/dolphins/dolphins-eagles-week-13-preview/"><div class="whatsapp-share"><span class="whatsapp-but1">
						<li class="mvp-soc-mob-what">
							<i class="fa fa-whatsapp" aria-hidden="true"></i>
						</li>
						</a>
						<a href="/cdn-cgi/l/email-protection#9ca3efe9fef6f9ffe8a1d8f3f0ecf4f5f2efbcd9fdfbf0f9efbccbf9f9f7bcadafbccceef9eaf5f9ebbafdf1eca7ded3d8c5a1d5bcfaf3e9f2f8bce8f4f5efbcfdeee8f5fff0f9bcf5f2e8f9eef9efe8f5f2fbbcfdf2f8bce8f4f3e9fbf4e8bcf3fabceff4fdeef5f2fbbcf5e8bcebf5e8f4bce5f3e9b2bcdff4f9fff7bcf5e8bcf3e9e8a6bcf4e8e8ecefa6b3b3ebebebb2f0f3fff7f9f8f3f2f8f3f0ecf4f5f2efb2fff3f1b3f8f3f0ecf4f5f2efb3f8f3f0ecf4f5f2efb1f9fdfbf0f9efb1ebf9f9f7b1adafb1eceef9eaf5f9ebb3">
						<li class="mvp-soc-mob-email">
							<i class="fa fa-envelope-o" aria-hidden="true"></i>
						</li>
						</a>
																					<a href="https://www.lockedondolphins.com/dolphins/dolphins-eagles-week-13-preview/#respond">
								<li class="mvp-soc-mob-com mvp-com-click">
									<i class="fa fa-comment-o" aria-hidden="true"></i>
								</li>
								</a>
																		</ul>
				</div><!--mvp-soc-mob-left-->
			</div><!--mvp-soc-mob-in-->
			<div class="mvp-soc-mob-right left relative">
				<i class="fa fa-ellipsis-h" aria-hidden="true"></i>
			</div><!--mvp-soc-mob-right-->
		</div><!--mvp-soc-mob-out-->
	</div><!--mvp-soc-mob-wrap-->
																															<div class="mvp-post-soc-in">
											<div id="mvp-content-body" class="left relative">
												<div id="mvp-content-body-top" class=left relative">
																																							<div id="mvp-content-main" class="left relative">
														<h2>Eagles offense looks to take flight against Miami’s banged up secondary</h2>
<p><strong>Who:</strong> <span style="color: #008080;"><strong>Dolphins (2-9)</strong></span> vs. <span style="color: #003300;"><strong>Eagles (5-6)</strong></span><br />
<strong>When:</strong> Sunday December 1, 1:00 East<br />
<strong>Where:</strong> Hard Rock Stadium &#8212; Miami Gardens, FL<br />
<strong>Weather:</strong> 80 degrees, partly cloudy<br />
<strong>Vegas Slant: <span style="color: #008080;">Dolphins +10</span></strong></p>
<p>A cornucopia of bad animal puns are available to us this week as the lifeless Eagles offense limps into Miami to face a reeling Dolphins defense; and offense, for that matter.</p>
<p>It should be an interesting final month of the 2019 season for the ‘Phins. A schedule that presented the probability of a winning record in December, only a couple of weeks ago, suddenly looks like a fast track to a 2-14 finish. The interesting distinction comes via the depths from Miami has had to scrape in order to put together a 53-man roster.</p>
<p>Nine of Miami’s projected opening day starters are done for the year in Miami, for one reason or another, and that initial roster lacked depth to begin with. The magic may have run out for a pass defense that ranked in the league’s top-10 for a month despite playing more undrafted and street free agents than any team in football.</p>
<p>That ravenous war of attrition that is an NFL season has feasted on Miami’s feeble roster. It extends from the secondary into the offensive backfield, along the offensive line and out at receiver. If the Dolphins can muster just one win in the final five, it’ll be yet another feather in the cap of Brian Flores.</p>
<p><span style="font-size: 18pt; color: #008080;"><strong>The Scheme:</strong></span></p>
<p><span style="color: #ff6600;"><strong>Offense:</strong></span></p>
<p><strong>Doug Pederson</strong> helped usher in a more aggressive NFL than our parents knew. After pushing all the right buttons on a magical Super Bowl run in 2017, Philadelphia returned to doing what it does best, booing every imaginable sports figure the town has ever seen.</p>
<p>Perhaps the vitriol needs to be slung in another direction. After losing both <strong>Frank Reich</strong> and <strong>John DeFilippo</strong> after the championship season, the Eagles promoted Wide Receivers Coach <strong>Mike Groh</strong>, and the unit hasn’t returned to the form is enjoyed in 2017.</p>
<p>Communication issues and receivers failing to make proper sight adjustments are an indictment on a coach who ran the receiver’s room before his promotion to coordinator.</p>
<p>The Eagles offense ranks 23<sup>rd </sup>in passing and sacks allowed, 13<sup>th </sup>in rushing (19<sup>th </sup>in yards per rush), and 18<sup>th </sup>in scoring.</p>
<p><span style="color: #ff6600;"><strong>Defense:</strong></span></p>
<p><strong>Jim Schwartz</strong> is the pioneer of many-a-defensive nuances that several teams still deploy today. Dolphins fans are most familiar with the wide-9 defense, a scheme that put a strenuous workload on the defensive ends.</p>
<p>Now, with some of his old-school principles, Schwartz has been taken to task for the coverage busts from inverted cover-2, but mostly via an under-manned back-seven.</p>
<p>The result is a unit that ranks 12<sup>th </sup>in passing, 5<sup>th </sup>in run defense, but 16<sup>th </sup>in scoring. Philadelphia blitz percentage falls in the middle of the pack (13<sup>th</sup>). The Eagles are tied for 3<sup>rd </sup>in quarterback knockdowns, 12<sup>th </sup>in pressure rate and 11<sup>th </sup>in sacks. The 81 missed tackles ranks Philly 10<sup>th  </sup>worst in that department.</p>
<p><span style="color: #008080; font-size: 18pt;"><strong>The Players:</strong></span></p>
<p><span style="color: #ff6600;"><strong>Offense:</strong></span></p>
<p><strong>Carson Wentz</strong> is a lightning rod of fodder and debate in the City of Brotherly Love. After an MVP caliber 2017 season &#8212; which ended on the injured reserve &#8212; Wentz’s production hasn’t returned to that level despite the fact that he’s had stretches of play that were superior to that injury-shortened campaign.</p>
<p>The Eagles shortcomings on this side of the ball are multi-layered, but it starts with the receiving corps. In unit that has battled injuries all season, the only reliable target (<strong>Alshon Jeffery</strong>) has played through ailments of his own. The story has been the same for <strong>Zach Ertz</strong>, one of the game’s top tight ends. He missed Wednesday’s practice which could force a heavier workload into the lap of second-year tight end <strong>Dallas Goedert</strong> (most notable among Fins fans for his draft position alignment with <strong>Mike Gesicki</strong>).</p>
<p><strong>Miles Sanders</strong> is the multi-faceted back that was supposed to spark the Eagles backfield production, but it’s been a workshare with former Bears Tailback <strong>Jordan Howard</strong>. Together, the pair are on the verge of cracking 1,000 yards behind one of the game’s best offensive lines, when healthy.</p>
<p>But that unit, like the rest of the Birds offense, has also been restricted to the trainer’s room this season. <strong>Lane Johnson</strong> and <strong>Jason Peters</strong> are the best bookends in the business. Johnson was injured Sunday (expected to return in Miami) and Peters has missed three games this season. Fellow pro-bowler <strong>Brandon Brooks</strong> had to come out of the New England game, but he should be back for Sunday’s contest in South Florida.</p>
<p><span style="color: #ff6600;"><strong>Defense:</strong></span></p>
<p>It’s been a down-year for a front-seven that typically enjoys success from a barrage of supremely talented football players. It all starts on the inside with <strong>Fletcher Cox</strong>. Cox’s production is on track to be his worst since 2014, his second as a pro.</p>
<p>The ripple effect of <strong>Cox’s</strong> surprising lack of dominance has been tangible. <strong>Brandon Graham</strong> is the best of the bunch, but <strong>Vinny Curry</strong> and <strong>Derek Barnett</strong> have combined for just five sacks on the season.</p>
<p>Sunday is likely a get-right game for this Eagles front facing a decimated Dolphins offensive line.</p>
<p>The linebacker corps is where the biggest goat of them all grazes &#8212; and we’re not talking greatest of all time. <strong>Nathan Gerry</strong> is to Eagles fans what <strong>Dannell Ellerbe</strong> was to 2014 Dolphins fans. Missed assignments, false steps, minimal production and the frequent gaffe that leads to big plays incites mini riots on Eagles Twitter.</p>
<p>Philadelphia have reduced the exposure of the linebacker corps by using more sub-packages, but the secondary lacks depth for that to be an effective counter. <strong>Ronald Darby</strong>,<strong> Jalen Mills</strong> and <strong>Avonte Maddox</strong> each have lapses that lead to game-defining plays (see the <strong>Julio Jones</strong> touchdown to win the game in Atlanta).</p>
<p><strong>Devante Parker</strong> and <strong>Mike Gesicki</strong> have favorable matchups in this game, if Miami can get the Eagles front blocked &#8212; no small task.</p>
<p><span style="font-size: 18pt; color: #008080;"><strong>The Medical:</strong></span></p>
<p>Update coming Friday</p>
<p><span style="font-size: 18pt; color: #008080;"><strong>The Opportunities:</strong></span></p>
<p><strong>Devante Parker</strong> showed fans everywhere his premier potential in a 2017 preseason game in Philadelphia, then disappeared for the next two seasons. He’s back now and performing like a true number-one receiver. Parker’s been excellent at creating separation in all levels of the route (release and stem), and could have another major impact in this game.</p>
<p>If the Eagles are intent on covering <strong>Mike Gesicki</strong> with cornerbacks, or committing a safety to his side, that will open things up for Parker. My bold prediction for this game is that Gesicki plucks a 50/50 ball that makes highlight shows all over the country.</p>
<p><span style="color: #008080; font-size: 18pt;"><strong>The Concerns:</strong></span></p>
<p>Every game from here on out will bring a level of concern to either side of the trenches. Miami gets no push in the running game, and long third downs will aid an Eagles pass rush that’s looking to get healthy. The Dolphins difficulties with speed rushers on the edge, and power on the interior is a matchup nightmare in this game, and one that will surely have <strong>General Ryan Fitzpatrick</strong> on the move once again.</p>
<p><span style="font-size: 18pt; color: #008080;"><strong>The Projected Outcome:</strong></span></p>
<p>Much like the Cleveland game last week, this is a get-right game for the Eagles. A chance for the clipped-wing offense to soar once more, and for the pass rush to tee off. The Browns screened Miami to death early in the game, and I’d expect the same with Miles Sanders on Sunday.</p>
<p>Miami gets behind the eight ball again, but puts together some second-half touchdown drives to make the score somewhat respectable.</p>
<p><span style="color: #008080;"><strong>Dolphins 21</strong></span><br />
<span style="color: #003300;"><strong>Eagles 37</strong></span></p>
<p><a href="https://twitter.com/WingfieldNFL"><strong>@WingfieldNFL</strong></a></p>
																											</div><!--mvp-content-main-->
													<div id="mvp-content-bot" class="left">
																												<div class="mvp-post-tags">
															<span class="mvp-post-tags-header">Related Topics:</span><span itemprop="keywords"><a href="https://www.lockedondolphins.com/tag/devante-parker/" rel="tag">DeVante Parker</a><a href="https://www.lockedondolphins.com/tag/dolphins-eagles/" rel="tag">Dolphins Eagles</a><a href="https://www.lockedondolphins.com/tag/featured/" rel="tag">Featured</a><a href="https://www.lockedondolphins.com/tag/mike-gesicki/" rel="tag">Mike Gesicki</a></span>
														</div><!--mvp-post-tags-->
														<div class="posts-nav-link">
																													</div><!--posts-nav-link-->
																													<div id="mvp-prev-next-wrap" class="left relative">
																																																	<div class="mvp-prev-post-wrap left relative">
																		<a href="https://www.lockedondolphins.com/dolphins/where-would-the-2019-dolphins-be-with-lamar-jackson/" rel="bookmark">
																		<div class="mvp-prev-next-cont left relative">
																			<div class="mvp-prev-cont-out right relative">
																				<span class="mvp-prev-arr fa fa-chevron-left left"></span>
																				<div class="mvp-prev-cont-in">
																					<div class="mvp-prev-next-text left relative">
																						<span class="mvp-prev-next-label left relative">Don&#039;t Miss</span>
																						<p>Where Would The 2019 Dolphins Be With Lamar Jackson?</p>
																					</div><!--mvp-prev-next-text-->
																				</div><!--mvp-prev-cont-in-->
																			</div><!--mvp-prev-cont-out-->
																		</div><!--mvp-prev-next-cont-->
																		</a>
																	</div><!--mvp-prev-post-wrap-->
																															</div><!--mvp-prev-next-wrap-->
																																											<div id="mvp-author-box-wrap" class="left relative">
																<div class="mvp-author-box-out right relative">
																	<div id="mvp-author-box-img" class="left relative">
																		<img src="https://www.lockedondolphins.com/wp-content/uploads/2019/06/Profile-80x80.jpg" width="60" height="60" alt="Travis Wingfield" class="avatar avatar-60 wp-user-avatar wp-user-avatar-60 alignnone photo" />																	</div><!--mvp-author-box-img-->
																	<div class="mvp-author-box-in">
																		<div id="mvp-author-box-head" class="left relative">
																			<span class="mvp-author-box-name left relative"><a href="https://www.lockedondolphins.com/author/twingfield/" title="Posts by Travis Wingfield" rel="author">Travis Wingfield</a></span>
																			<div id="mvp-author-box-soc-wrap" class="left relative">
																																																																																																																																																															</div><!--mvp-author-box-soc-wrap-->
																		</div><!--mvp-author-box-head-->
																	</div><!--mvp-author-box-in-->
																</div><!--mvp-author-box-out-->
																<div id="mvp-author-box-text" class="left relative">
																	<p></p>
																</div><!--mvp-author-box-text-->
															</div><!--mvp-author-box-wrap-->
																												<div class="mvp-org-wrap" itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
															<div class="mvp-org-logo" itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
																																	<img src="https://www.lockedondolphins.com/wp-content/uploads/2019/02/Locked-On-Dolphins-Podcast-Website-Logo.png"/>
																	<meta itemprop="url" content="https://www.lockedondolphins.com/wp-content/uploads/2019/02/Locked-On-Dolphins-Podcast-Website-Logo.png">
																															</div><!--mvp-org-logo-->
															<meta itemprop="name" content="Locked On Dolphins">
														</div><!--mvp-org-wrap-->
													</div><!--mvp-content-bot-->
												</div><!--mvp-content-body-top-->
												<div class="mvp-cont-read-wrap">
																																								<div id="mvp-post-bot-ad" class="left relative">
															<span class="mvp-ad-label">Advertisement</span>
															<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<ins class="adsbygoogle"
     style="display:block"
     data-ad-format="fluid"
     data-ad-layout-key="-6r+di+5g-2m-8y"
     data-ad-client="ca-pub-3311849153835630"
     data-ad-slot="8448677726"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script>
<div style="height:20px;"></div>
<!-- Begin MailChimp Signup Form -->
<link href="//cdn-images.mailchimp.com/embedcode/horizontal-slim-10_7.css" rel="stylesheet" type="text/css">

<div id="mc_embed_signup">
<form action="https://fanragsports.us8.list-manage.com/subscribe/post?u=0929c3c0f4c900717acdf09e4&id=aa26475111" method="post" id="mc-embedded-subscribe-form" name="mc-embedded-subscribe-form" class="validate" target="_blank" novalidate>
    <div id="mc_embed_signup_scroll">
	<label for="mce-EMAIL">Subscribe to the Locked on Dolphins Newsletter Today - It's FREE</label>
	<input type="email" value="" name="EMAIL" class="email" id="mce-EMAIL" placeholder="email address" required>
    <!-- real people should not fill this in and expect good things - do not remove this or risk form bot signups-->
    <div style="position: absolute; left: -5000px;" aria-hidden="true"><input type="text" name="b_0929c3c0f4c900717acdf09e4_aa26475111" tabindex="-1" value=""></div>
    <div class="clear"><input type="submit" value="Subscribe" name="subscribe" id="mc-embedded-subscribe" class="button"></div>
    </div>
</form>
</div>

<!--End mc_embed_signup-->														</div><!--mvp-post-bot-ad-->
																																																																																			<div id="mvp-comments-button" class="left relative mvp-com-click">
																<span class="mvp-comment-but-text">Click to comment</span>
															</div><!--mvp-comments-button-->
															<div id="comments">
				
	
	<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title"><h4 class="mvp-widget-home-title"><span class="mvp-widget-home-title">Leave a Reply</span></h4> <small><a rel="nofollow" id="cancel-comment-reply-link" href="/dolphins/dolphins-eagles-week-13-preview/#respond" style="display:none;">Cancel reply</a></small></h3>			<form action="https://www.lockedondolphins.com/wp-comments-post.php" method="post" id="commentform" class="comment-form">
				<p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p><p class="comment-form-comment"><label for="comment">Comment</label> <textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" required="required"></textarea></p><p class="comment-form-author"><label for="author">Name <span class="required">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" required='required' /></p>
<p class="comment-form-email"><label for="email">Email <span class="required">*</span></label> <input id="email" name="email" type="text" value="" size="30" maxlength="100" aria-describedby="email-notes" required='required' /></p>
<p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="text" value="" size="30" maxlength="200" /></p>
<p class="comment-form-cookies-consent"><input id="wp-comment-cookies-consent" name="wp-comment-cookies-consent" type="checkbox" value="yes" /><label for="wp-comment-cookies-consent">Save my name, email, and website in this browser for the next time I comment.</label></p>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='8815' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="c0399ed6ff" /></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="65"/></p>			</form>
			</div><!-- #respond -->
	<p class="akismet_comment_form_privacy_notice">This site uses Akismet to reduce spam. <a href="https://akismet.com/privacy/" target="_blank" rel="nofollow noopener">Learn how your comment data is processed</a>.</p>
</div><!--comments-->																																							</div><!--mvp-cont-read-wrap-->
											</div><!--mvp-content-body-->
										</div><!--mvp-post-soc-in-->
									</div><!--mvp-post-soc-out-->
								</div><!--mvp-content-wrap-->
													<div id="mvp-post-add-box">
								<div id="mvp-post-add-wrap" class="left relative">
																			<div class="mvp-post-add-story left relative">
											<div class="mvp-post-add-head left relative">
												<h3 class="mvp-post-cat left relative"><a class="mvp-post-cat-link" href="https://www.lockedondolphins.com/category/dolphins/news/"><span class="mvp-post-cat left">News</span></a></h3>
												<h1 class="mvp-post-title left">Jakeem Grant placed on Injured Reserve</h1>
																																					<div class="mvp-author-info-wrap left relative">
														<div class="mvp-author-info-thumb left relative">
															<img src="https://www.lockedondolphins.com/wp-content/uploads/2019/02/image1-80x80.jpeg" width="46" height="46" alt="Shawn Digity" class="avatar avatar-46 wp-user-avatar wp-user-avatar-46 alignnone photo" />														</div><!--mvp-author-info-thumb-->
														<div class="mvp-author-info-text left relative">
															<div class="mvp-author-info-date left relative">
																<p>Published</p> <span class="mvp-post-date">1 day ago</span> <p>on</p> <span class="mvp-post-date">November 27, 2019</span>
															</div><!--mvp-author-info-date-->
															<div class="mvp-author-info-name left relative">
																<p>By</p> <span class="author-name"><a href="https://www.lockedondolphins.com/author/sdigity/" title="Posts by Shawn Digity" rel="author">Shawn Digity</a></span> <a href="@DIGITYnodoubt" class="mvp-twit-but" target="_blank"><span class="mvp-author-info-twit-but"><i class="fa fa-twitter fa-2"></i></span></a>
															</div><!--mvp-author-info-name-->
														</div><!--mvp-author-info-text-->
													</div><!--mvp-author-info-wrap-->
																							</div><!--mvp-post-add-head-->
											<div class="mvp-post-add-body left relative">
																																							<div class="mvp-post-add-img left relative">
															<img width="415" height="600" src="https://www.lockedondolphins.com/wp-content/uploads/2019/11/USATSI_13681138.jpg" class="attachment- size- wp-post-image" alt="Miami Dolphins Jakeem Grant" srcset="https://www.lockedondolphins.com/wp-content/uploads/2019/11/USATSI_13681138.jpg 415w, https://www.lockedondolphins.com/wp-content/uploads/2019/11/USATSI_13681138-207x300.jpg 207w, https://www.lockedondolphins.com/wp-content/uploads/2019/11/USATSI_13681138-768x1111.jpg 768w" sizes="(max-width: 415px) 100vw, 415px" />														</div><!--mvp-post-feat-img-->
																													<span class="mvp-feat-caption">Image courtesy of USA Today Sports</span>
																																																			<div class="mvp-post-add-cont left relative">
													<div class="mvp-post-add-main right relative">
														<h4><strong>MIAMI (Locked On Dolphins) &#8211; Wide Receiver Jakeem Grant headed to Injured Reserve</strong></h4>
<p><strong>Jakeem Grant</strong> has been added to Injured Reserve per <strong>Joe Schad</strong>.</p>
<blockquote class="twitter-tweet" data-width="550" data-dnt="true">
<p lang="en" dir="ltr">Miami Dolphins WR Jakeem Grant will be placed on season-ending IR, source confirms</p>
<p>&mdash; Joe Schad (@schadjoe) <a href="https://twitter.com/schadjoe/status/1199697318406230016?ref_src=twsrc%5Etfw">November 27, 2019</a></p></blockquote>
<p><script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></p>
<p>This will end Grant&#8217;s 2019 season.</p>
<p>It&#8217;s been almost a year to the day when <a href="https://www.lockedondolphins.com/dolphins/dolphins-promote-isaiah-ford-place-jakeem-grant-on-ir/"><strong>Jakeem Grant</strong> was placed on IR for the 2018 season</a>.</p>
<p>While Grant&#8217;s production wasn&#8217;t on par with the first half of the 2018 season, he was still able to unleash some splash plays, like a kick return against the Buffalo Bills in the Week 11 matchup.</p>
<p>The minuscule yet blazing-fast wide receiver had already been fending off injuries for the 2019 season and missed two games this season if you include the Browns game.</p>
<p>Grant sustained a high ankle injury from the Browns game, according to <strong>Barry Jackson</strong>, and that&#8217;s why he left the game early on Sunday.</p>
<p><strong>Jakeem Grant</strong> hasn&#8217;t been able to notch a lot of production in his four-year career but had shown growth over that span.</p>
<p>Grant did not have a receiving touchdown this year; his only score was the kick return against the Bills.</p>
<p>He tallied 19 receptions for 164 yards.</p>
<p>Grant had <a href="https://www.lockedondolphins.com/dolphins/miami-dolphins-expected-to-extend-jakeem-grant/">signed a contract extension earlier this year</a> that added four years and was valued at up to $24 million.</p>
<p>Wide receiver Isaiah Ford rejoins the team in the corresponding roster move, <a href="https://www.sun-sentinel.com/sports/miami-dolphins/fl-sp-dolphins-jakeem-grant-20191127-sfpetqsctnhpxbx3wzyxu2tf6e-story.html">per Safid Deen</a>.</p>
<p>&nbsp;</p>
													</div><!--mvp-post-add-main-->
													<div class="mvp-post-add-link">
														<a href="https://www.lockedondolphins.com/dolphins/news/jakeem-grant-placed-on-injured-reserve/" rel="bookmark"><span class="mvp-post-add-link-but">Continue Reading</span></a>
													</div><!--mvp-post-add-link-->
												</div><!--mvp-post-add-cont-->
											</div><!--mvp-post-add-body-->
										</div><!--mvp-post-add-story-->
																			<div class="mvp-post-add-story left relative">
											<div class="mvp-post-add-head left relative">
												<h3 class="mvp-post-cat left relative"><a class="mvp-post-cat-link" href="https://www.lockedondolphins.com/category/dolphins/"><span class="mvp-post-cat left">Miami Dolphins</span></a></h3>
												<h1 class="mvp-post-title left">Where Would The 2019 Dolphins Be With Lamar Jackson?</h1>
																																					<div class="mvp-author-info-wrap left relative">
														<div class="mvp-author-info-thumb left relative">
															<img src="https://www.lockedondolphins.com/wp-content/uploads/2019/05/image1-1-80x80.jpeg" width="46" height="46" alt="Chris Kowalewski" class="avatar avatar-46 wp-user-avatar wp-user-avatar-46 alignnone photo" />														</div><!--mvp-author-info-thumb-->
														<div class="mvp-author-info-text left relative">
															<div class="mvp-author-info-date left relative">
																<p>Published</p> <span class="mvp-post-date">1 day ago</span> <p>on</p> <span class="mvp-post-date">November 27, 2019</span>
															</div><!--mvp-author-info-date-->
															<div class="mvp-author-info-name left relative">
																<p>By</p> <span class="author-name"><a href="https://www.lockedondolphins.com/author/ckowalewski/" title="Posts by Chris Kowalewski" rel="author">Chris Kowalewski</a></span> <a href="" class="mvp-twit-but" target="_blank"><span class="mvp-author-info-twit-but"><i class="fa fa-twitter fa-2"></i></span></a>
															</div><!--mvp-author-info-name-->
														</div><!--mvp-author-info-text-->
													</div><!--mvp-author-info-wrap-->
																							</div><!--mvp-post-add-head-->
											<div class="mvp-post-add-body left relative">
																																							<div class="mvp-post-add-img left relative">
															<img width="847" height="600" src="https://www.lockedondolphins.com/wp-content/uploads/2019/11/35A92581-A312-4378-B6BD-701A0C7B7CC8.jpeg" class="attachment- size- wp-post-image" alt="" srcset="https://www.lockedondolphins.com/wp-content/uploads/2019/11/35A92581-A312-4378-B6BD-701A0C7B7CC8.jpeg 847w, https://www.lockedondolphins.com/wp-content/uploads/2019/11/35A92581-A312-4378-B6BD-701A0C7B7CC8-300x213.jpeg 300w, https://www.lockedondolphins.com/wp-content/uploads/2019/11/35A92581-A312-4378-B6BD-701A0C7B7CC8-768x544.jpeg 768w" sizes="(max-width: 847px) 100vw, 847px" />														</div><!--mvp-post-feat-img-->
																																																			<div class="mvp-post-add-cont left relative">
													<div class="mvp-post-add-main right relative">
														<p>Since the retirement of <b>Dan Marino</b>, the Miami Dolphins’ quarterback story has been one of frustration and division. With no replacement player able to even glimpse the franchise level set by Marino, fans continue to dwell on the past, clinging to the glory of his record setting career as well as the haunting despair of the franchise’s past poor choices (<b>Culpepper</b> over <b>Brees</b>) and sub-par draft picks.<span class="Apple-converted-space"> </span></p>
<p>This year is no different, as it sees the sensational <b>Lamar</b> <b>Jackson</b> skyrocket from the practice field to the heights of NFL super-stardom.</p>
<p>It was widely reported that Dolphins’ owner, <b>Stephen Ross</b> was never really happy with the outcome of the first round of the 2018 draft.<span class="Apple-converted-space"> </span></p>
<p>Miami held the 11th overall pick and whilst the team still lacked a true direction for the future, the choice of rookie was up for debate. Uncertainty loomed around the position concerning the return of <b>Ryan Tannehill</b> and the team had reached a metaphorical fork in the road when it came to deciding how they intended to proceed.</p>
<p>We all know how the events unfolded that night, as the Dolphins selected DB, <b>Minkah Fitzpatrick</b> from Alabama. Touted as <b>Nick Saban’s</b> ‘favourite son’, the selection was even widely applauded by Dolfans and the media in general with Minkah being considered a Top-10 talent.</p>
<p>But behind the scenes &#8211; before the Dolphins’ card had been turned in to the Commissioner &#8211; there was unease at the Dolphins’ top position regarding the decision. <b>Stephen Ross</b> voiced his preference was for the Dolphins to trade back from the 11th spot to acquire more draft picks and to select QB, <b>Lamar Jackson</b>.</p>
<p>Ultimately, Ross relented and deferred to the conviction of his employed ‘brain trust’ of <b>Mike Tannenbaum</b>, <b>Adam Gase</b> and <b>Chris Grier</b> &#8211; eventually swayed that Minkah Fitzpatrick was simply too good to pass up&#8230;</p>
<p>Whilst showing occasional flashes of brilliance in Miami, Minkah has since demonstrated his abilities and defensive prowess in the short time since joining the <b>Pittsburgh Steelers</b> on 16 September 2019 with 30 tackles, 12 assists, 2 forced fumbles and 5 INTS for 130 yards and 1 TD.</p>
<p>Some 240 miles SE of Pittsburgh, Lamar Jackson, the 32nd overall selection in the 2018 draft accelerates towards the position of league MVP following yet another stellar performance, a 45-6 victory on MNF against the <b>LA Rams</b>.</p>
<p>Through 11 games this season, Jackson has thrown for 2427 yards, 24 TDs, 5 INTs (66.9% completion) and a 111.4 QB rating. In addition, he leads his team in rushing yards with 876 yards on 124 carries for a further 6 TDs.<span class="Apple-converted-space"> </span></p>
<p>How things can change in less than a year, when the right plan is in place and when it actually works.</p>
<p>This time last year, Ravens’ coach <b>John Harbaugh</b> was reportedly on the hot seat in Baltimore as their 2018 campaign unfolded. Since bringing a Super Bowl title to Baltimore in 2012 led by an outstanding post-season performance from <b>Joe Flacco</b>, the Ravens had failed to maintain their dominance in a competitive AFC North. Joe Flacco had become a shell of his former self, and the 2012 Super Bowl MVP show was a distant and faded memory. He was benched late in the season for the young rookie as the Ravens stuttered and stumbled to a 10-6 finish with Lamar Jackson at the helm, ended by a Wildcard loss to the <b>LA Chargers</b>.</p>
<p>For most NFL teams which dwell in the habitats of perpetual mediocrity, a 10-6 finish and a playoff appearance would be considered a positive thing.<span class="Apple-converted-space"> </span></p>
<p>For those accustomed to the taste of victory and the shine of the Lombardi Trophy, it is a painful mark of failure. To them, falling so short marks a need for change rather than offering a solid foundation for the following season.</p>
<p>The way the Baltimore Ravens changed themselves and built new foundations for success has been nothing short of spectacular.</p>
<p>Ravens’ Offensive Co-ordinator, <b>Greg Roman</b>, was elevated to the position this season after spending 2018 as the team’s TE coach and Assistant Head Coach. NFL fans may recall that Roman had previously been the OC for the <b>San Francisco 49ers</b> under <b>Jim Harbaugh</b> en route to the brothers facing off in Super Bowl XLVII.</p>
<p>At the time, the 49ers had reached the Championship game with <b>Colin Kaepernick </b>&#8211; another dual threat quarterback &#8211; under center, after he had stepped in to replace the injured <b>Alex Smith</b>.</p>
<p>Over the 13 games he played in 2012, Kaepernick threw for 1,814 yards, 10 TDs and 3 INTs (62.4% completion), whilst rushing for 415 yards (avg 6.6 yards per carry) and 5 TDs.</p>
<p>With Lamar Jackson, OC Greg Roman has developed a scheme from scratch built entirely around the electric second-year QB. The verbiage of the plays has been constructed in tandem with Jackson to ensure the quarterback has full understanding and full control of the offensive system.</p>
<p>Everything about the offense has been designed with Jackson in mind, utilising the abilities of a dominant and athletic offensive line headlined by <b>Ronnie Stanley</b>, <b>Marshal Yanda</b> and <b>Orlando Brown</b>. It promotes a bulldozing running game and a vertical passing game incorporating blazing speed and playmaking tight ends. John Harbaugh has built a complementary defense and running game to support Jackson’s skills ensuring he can make the most of his ability on each and every play. It is a team built on speed and aggression, synonymous with the Ravens’ historically established mentality.</p>
<p><b>So, how does this all fit in with the Miami Dolphins?</b></p>
<p>Less than 18 months ago, the Dolphins had the chance to draft Lamar Jackson. He was there for the taking at 11 and the Dolphins could just have easily have traded back to land him later in the first round.</p>
<p>And now Stephen Ross has little option but to sit back along with the rest of the world and marvel as Lamar Jackson tears up the league with unprecedented success, filling up the stands at <b>M&amp;T Bank Stadium</b>, with Super Bowl hopes bounding through the streets of Baltimore.</p>
<p>Whilst John Harbaugh was once on the hot seat, he’s now perched on a block of solid ice as the Ravens seem to have quickly set themselves up for long term success.</p>
<p>As much as Lamar Jackson is firmly established within a system to highlight his incredible skillset, the Ravens’ model is not one which the Dolphins can &#8211; or could have &#8211; replicated to the same degree. There is a reason the Dolphins have historically struggled so mightily when facing the Ravens and it isn’t just because of the quarterback position.</p>
<p>The Ravens have been purpose-built over the past decade, like a well maintained car tweaked and repaired with authentic, matching parts. The Dolphins, on the other hand, have tried to fix their team with misfit spares and failing cast-offs taken from whatever other high-end motor they could find, hoping it would fit.</p>
<p>That process finally came to a close when Stephen Ross accepted the irreparable state of his own franchise.<span class="Apple-converted-space"> </span></p>
<p>2018’s coach, <b>Adam Gase</b>, had wanted to stay and build a winner ‘now’, but even the ever-hopeful Ross did not foresee this as a viable option. The hefty contracts handed out by Mike Tannenbaum were not producing a level of on-field success relative to their costs. The team lacked any semblance of an identity and Ryan Tannehill had now become the punching bag for a divided fanbase.</p>
<p>Ross knew that the rot ran deep and elected for a total rebuild.</p>
<p>But what if Ross had gained his way, and the Dolphins had drafted Lamar Jackson in the first round?<span class="Apple-converted-space"> </span></p>
<p>Let’s try and look into the mystical crystal ball to see what might have happened to the Dolphins offense.</p>
<p>First of all we would have to make some assumptions regarding a number of the team’s moves which have since happened:</p>
<ul>
<li>The Dolphins draft Lamar Jackson in 2018 either at 11 or through a trade back.</li>
<li>The rest of the 2018 draft would have remained the same, in which they did nothing to help the OL.</li>
<li>Adam Gase remains the head coach after 2018, trusted with developing his QB.</li>
<li>Mike Tannenbaum remains the GM.</li>
<li>It’s debatable whether the <b>Laremy Tunsil</b> trade still happens or not, but for the sake of this scenario, we’ll imagine he stays.</li>
<li><b>Kenny Stills</b> therefore stays too.</li>
<li><b>Ja’Wuan James</b> still leaves in Free Agency.</li>
<li>The rest of the offensive line? Likely stays the same quality as it is now.</li>
<li><b>DeVante Parker</b> would have been released.</li>
<li><b>Kenyan Drake</b>, purposely limited under Adam Gase, likely would still be gone by this point. We’ll imagine he was traded in any event, likely with another veteran brought in.</li>
</ul>
<p>Whether Jackson could have succeeded in Miami probably comes down to the offensive scheme under Adam Gase and likely-would-be-returning OC, <b>Dowell Loggains</b>.<span class="Apple-converted-space"> </span></p>
<p>For 7 years, we watched Miami Dolphins quarterbacks struggle to stay alive behind a depleted offensive line. The sacks and injuries piled up raising nothing but questions as to how the Dolphins would approach the team’s most important position.</p>
<p>Heading into the 2019 season, the Dolphins were projected to have in the region of $14m in cap space. So they were never destined to be big spenders and it is extremely unlikely that they would have been able to fortify the offensive line with any real quality and they still would have needed to sign Laremy Tunsil to an extension.</p>
<p>In view of the roster turnover, the Dolphins are still carrying a grand total of $62,436,902 of dead money through the 2019 season.</p>
<p>The question remains as to whether Gase have even wanted to play Jackson?</p>
<p>Stubborn in nature, with a strong affinity for <b>Ryan Tannehill</b>, Gase was quick to blame everyone and everything but his own scheme for the team’s failures. He was desperate to keep Tannehill as a pocket passer, bringing in <b>Brock Osweiler</b> to be his backup.</p>
<p>In a scheme built for Tannehill, with few designed QB runs, no power running game, no playmaking TE, a handful of diminutive receivers and zero protection,<span class="Apple-converted-space">  </span>Jackson would have no option but to scramble for his life on every play.</p>
<p>Ultimately there can be no real confidence that the Dolphins under Adam Gase would have been willing to build an entire scheme around Jackson as the Ravens have done. Even if they had wanted to, the Dolphins did not possess remotely the same caliber of players to do so, or even the capital to acquire them.</p>
<p>As the Dolphins embark on their rebuild, we even now see Tannehill having success with a system built to suit his needs and a strong running game.</p>
<p>Not for one second am I suggesting that Tannehill is currently playing on the level of Lamar Jackson, but he is yet another example of how the Dolphins in their previous state had no real direction of how to handle development of a quarterback or any other talented players.<span class="Apple-converted-space"> </span></p>
<p>Whilst there always remains the chance that Lamar Jackson could have suppressed my scepticism and brought new life to Miami, I just can’t look back at the ‘what-could-have-been’ by copying and pasting the Ravens’ current success onto the 2019 Miami Dolphins.</p>
<p>Although <b>Stephen Ross</b> hasn’t got the quarterback whom he desired in 2018, he has now torn down the front office and (indirectly) the roster to enable the Dolphins to build an offense using the Ravens’ blueprint for success &#8211; identify a quarterback, and build the whole team and scheme around him to support his skill set optimise every chance of success.</p>
<p><b>Chad O’Shea</b>, with a depleted roster has already shown a higher propensity for scheming and utilising players than we saw under <b>Adam Gase/Clyde Christensen/Dowell Loggains</b> and even though the running game remains a league worst behind the persistently awful offensive line, the team has been on a general upward trajectory with promising play calling and design.</p>
<p>With Lamar Jackson, the Dolphins certainly wouldn’t be in the position they are now with a multitude of draft picks and projected cap space. The more likely scenario is that they would have remained in stagnant position, gambling on Jackson being able to bail them out, rather than being able to do all they can to support him.</p>
<p>They would be stuck between a rock and a hard place when it comes to deciding how to proceed with Lamar Jackson. They could have continued to overpay mediocre talent, with an under-utilised run game and lacklustre play design under Adam Gase simply hoping for the best.</p>
<p>Or alternatively they could have offloaded talent and contracts as they have done in order to build for the future leaving him with little chance of success, similar to the Arizona Cardinals who have brought in a QB to a talent-depleted team. Even through Kyler Murray was reportedly a more accomplished passer than Lamar Jackson, the team as a whole is not built to match the Ravens’ success despite a scheme purposely built for Murray’s talent.<span class="Apple-converted-space"> </span></p>
<p>Looking back in despair and wishing that Miami drafted Lamar Jackson is natural for Dolphins fans. However, it simply can’t be trusted that the Dolphins front office in their previous incarnation would have had the mindset to incorporate the changes needed to see Lamar Jackson reach his current dizzying heights. With neither the versatility, draft capital nor cap space to support such a radical deviation from Miami’s usual approach it is impossible to state with any confidence that the Dolphins would now be settled with their franchise quarterback.<span class="Apple-converted-space"> </span></p>
<p>Lamar Jackson’s unprecedented success is a perfect storm in Baltimore, but one which would likely have ultimately developed into nothing more than a relative breeze down in South Florida.</p>
<p>‘Hoping for the best’ is what has landed the Dolphins in the sticky, stagnant puddles of mediocrity. They have now taken the opportunity to make a radical change.</p>
<p>It is time to stop looking back to the past and begin looking towards the future.</p>
<p>FINS UP.</p>
													</div><!--mvp-post-add-main-->
													<div class="mvp-post-add-link">
														<a href="https://www.lockedondolphins.com/dolphins/where-would-the-2019-dolphins-be-with-lamar-jackson/" rel="bookmark"><span class="mvp-post-add-link-but">Continue Reading</span></a>
													</div><!--mvp-post-add-link-->
												</div><!--mvp-post-add-cont-->
											</div><!--mvp-post-add-body-->
										</div><!--mvp-post-add-story-->
																			<div class="mvp-post-add-story left relative">
											<div class="mvp-post-add-head left relative">
												<h3 class="mvp-post-cat left relative"><a class="mvp-post-cat-link" href="https://www.lockedondolphins.com/category/dolphins/"><span class="mvp-post-cat left">Miami Dolphins</span></a></h3>
												<h1 class="mvp-post-title left">The Aftermath: Dolphins 24 Browns 41</h1>
																																					<div class="mvp-author-info-wrap left relative">
														<div class="mvp-author-info-thumb left relative">
															<img src="https://www.lockedondolphins.com/wp-content/uploads/2019/06/Profile-80x80.jpg" width="46" height="46" alt="Travis Wingfield" class="avatar avatar-46 wp-user-avatar wp-user-avatar-46 alignnone photo" />														</div><!--mvp-author-info-thumb-->
														<div class="mvp-author-info-text left relative">
															<div class="mvp-author-info-date left relative">
																<p>Published</p> <span class="mvp-post-date">2 days ago</span> <p>on</p> <span class="mvp-post-date">November 26, 2019</span>
															</div><!--mvp-author-info-date-->
															<div class="mvp-author-info-name left relative">
																<p>By</p> <span class="author-name"><a href="https://www.lockedondolphins.com/author/twingfield/" title="Posts by Travis Wingfield" rel="author">Travis Wingfield</a></span> <a href="" class="mvp-twit-but" target="_blank"><span class="mvp-author-info-twit-but"><i class="fa fa-twitter fa-2"></i></span></a>
															</div><!--mvp-author-info-name-->
														</div><!--mvp-author-info-text-->
													</div><!--mvp-author-info-wrap-->
																							</div><!--mvp-post-add-head-->
											<div class="mvp-post-add-body left relative">
																																							<div class="mvp-post-add-img left relative">
															<img width="928" height="600" src="https://www.lockedondolphins.com/wp-content/uploads/2019/11/USATSI_13707625.jpg" class="attachment- size- wp-post-image" alt="" srcset="https://www.lockedondolphins.com/wp-content/uploads/2019/11/USATSI_13707625.jpg 928w, https://www.lockedondolphins.com/wp-content/uploads/2019/11/USATSI_13707625-300x194.jpg 300w, https://www.lockedondolphins.com/wp-content/uploads/2019/11/USATSI_13707625-768x497.jpg 768w" sizes="(max-width: 928px) 100vw, 928px" />														</div><!--mvp-post-feat-img-->
																																																			<div class="mvp-post-add-cont left relative">
													<div class="mvp-post-add-main right relative">
														<h2>Snap Counts, Grades, Metrics, and Other Phins Notes</h2>
<p><span style="color: #008080;"><strong>Foreword:</strong></span></p>
<p>As we develop a weekly content schedule for the season, I wanted something to bridge the gap between the Sunday night game breakdown column and the Tuesday film review. So, here we are with a smorgasbord of information, statistics, snap counts, and whatever is prudent to the Dolphins game from the Sunday prior.</p>
<p>We’ll dive into the game data from <strong><a href="https://www.profootballfocus.com/">Pro Football Focus</a>,</strong> Pro Football Reference, grab some quotes from the player’s and coach’s pressers, and continue to provide the most comprehensive coverage on the Miami Dolphins you can find.</p>
<p><span style="font-size: 18pt; color: #008080;"><strong><span style="color: #008080;">Dolphins-<span style="color: #ff6600;">Browns</span></span></strong></span></p>
<p><span style="font-size: 18pt; color: #008080;"><strong>Team Stats</strong></span></p>
<p>There are five games left in 2019 for Miami. After a miserable first quarter of the season, an encouraging five-game run gave fans something to hang their hats on regarding Miami’s disciplined, progressing nature. Now, two games removed from the pair of victories, the Dolphins might be out of answers for this December stretch-run.</p>
<p>The secondary is beyond decimated, and might’ve lost another player Sunday to injury (<strong>Ken Crawley</strong>). The same is true of the Dolphins backfield. A stable of unproven backs that’re trying to create yardage behind an offensive line who’s only accolade this season has been its health.</p>
<p>Per <em>ESPN’s</em> <strong>Cameron Wolfe</strong>, Miami’s 63.2 rushing yards per game would be the lowest total in the NFL since the 1946 Detroit Lions. Sunday’s results brought Miami to the bottom in yards-per-carry as well &#8212; the 3.1 YPC is .1-point lower than <strong>Adam Gase’s</strong> New York Jets ground game.</p>
<p><strong>Ryan Fitzpatrick</strong> celebrated his 37<sup>th </sup>birthday and 200<sup>th </sup>touchdown pass on Sunday. The Dolphins passing game ranks 26<sup>th </sup>with 201.7 yards-per-game. Miami still ranks bottom in team passer rating with a 71.0 mark in one of the game’s most important stats (a measure of the passing game in totality).</p>
<p>It gets worse.</p>
<p>Miami have allowed a league-worst 46 sacks, and the 3.9 adjusted net yards per pass attempt also brings up the rear.</p>
<p>There are some positives. Miami are now 30<sup>th </sup>in scoring (up from 32<sup>nd</sup>) with 14.8 points per game. The Phins are 8<sup>th </sup>in red zone touchdown conversion rate with an impressive 63% mark scoring touchdowns inside the 20-yard-line.</p>
<p>The Dolphins rank 24<sup>th </sup>on third downs with a 34% conversion rate.</p>
<p>The Browns game did not improve and of Miami’s defensive metrics. The Dolphins pass defense ranks 22<sup>nd</sup>, but that’s largely a function of the run defense getting ran over. Miami ranks 31<sup>st</sup>in rushing yards per game, and 25<sup>th </sup>in yards per rush.</p>
<p>The Phins’ 45 QB hits are last in the league, the same is true of Miami’s 14 quarterback sacks. Suddenly, Miami are missing more tackles. The 70 missed tackles ranks 16<sup>th</sup>, though two fewer missed tackles would rank Miami 10<sup>th </sup>in that department, with a logjam of teams in the 68-69 missed tackle range.</p>
<p>The Dolphins are tied for last in quarterback pressure rate (Seattle) at 17.3%, and are alone at the bottom in hurry rate (6.2%). Miami’s 7.7% quarterback knockdown rate ranks 10<sup>th </sup>in football.</p>
<p><span style="color: #008080; font-size: 18pt;"><strong>Offense:</strong></span></p>
<p><span style="color: #ff6600;"><strong>Snap Counts:</strong></span></p>
<table>
<tbody>
<tr>
<td width="234"><strong>Player</strong></td>
<td width="234"><strong>Snaps (% of Offensive Snaps)</strong></td>
</tr>
<tr>
<td width="234">QB Ryan Fitzpatrick</td>
<td width="234">63 (100%)</td>
</tr>
<tr>
<td width="234">RB Kalen Ballage</td>
<td width="234">24 (38%)</td>
</tr>
<tr>
<td width="234">RB Patrick Laird</td>
<td width="234">23 (37%)</td>
</tr>
<tr>
<td width="234">RB Myles Gaskin</td>
<td width="234">16 (25%)</td>
</tr>
<tr>
<td width="234">FB Chandler Cox</td>
<td width="234">3 (5%)</td>
</tr>
<tr>
<td width="234">WR Devante Parker</td>
<td width="234">63 (100%)</td>
</tr>
<tr>
<td width="234">WR Allen Hurns</td>
<td width="234">57 (90%)</td>
</tr>
<tr>
<td width="234">WR Albert Wilson</td>
<td width="234">30 (48%)</td>
</tr>
<tr>
<td width="234">WR Jakeem Grant</td>
<td width="234">3 (5%)</td>
</tr>
<tr>
<td width="234">TE Mike Gesicki</td>
<td width="234">57 (90%)</td>
</tr>
<tr>
<td width="234">TE Durham Smythe</td>
<td width="234">39 (62%)</td>
</tr>
<tr>
<td width="234">OL Julie’n Davenport</td>
<td width="234">63 (100%)</td>
</tr>
<tr>
<td width="234">OL Michael Deiter</td>
<td width="234">63 (100%)</td>
</tr>
<tr>
<td width="234">OL Daniel Kilgore</td>
<td width="234">63 (100%)</td>
</tr>
<tr>
<td width="234">OL Shaq Calhoun</td>
<td width="234">63 (100%)</td>
</tr>
<tr>
<td width="234">OL Jesse Davis</td>
<td width="234">63 (100%)</td>
</tr>
</tbody>
</table>
<p>&nbsp;</p>
<p>Miami’s offensive creativity was challenged after a pair of in-game injuries prevented the team from any 11-personnel packages. That helped elevate <strong>Durham Smythe</strong> into a more prominent role in 12-personnel, one game after he played just eight snaps.</p>
<p><strong>Smythe</strong> graded O.K. in the run-game and pitched a shutout in pass protection. He was targeted once as a receiver, but the pass was broken up.</p>
<p><strong>Mike Gesicki</strong> got on the board with his first career touchdown. He only caught three of his seven targets and was charged with a drop.</p>
<p>It was <strong>Michael Deiter’s</strong> best day in pass protection. He allowed just one pressure (a hurry) keeping his quarterback clean throughout the day.</p>
<p><strong>Julie’n Davenport</strong> received good news when it was learned that <strong>Myles Garrett</strong> would not play in the game, but that didn’t stop Davenport from struggling immensely. He allowed seven more QB pressures bringing his total up to 23 on the season in just three appearances.</p>
<p>The other tackle position has been a weak spot as well. <strong>Jesse Davis</strong> allowed four pressures (one of them a sack).</p>
<p>Miami’s best run-blocking grade went to <strong>Daniel Kilgore</strong> with a less-than-impressive 62.4 mark from <em>PFF</em>. <strong>Shaq Calhoun</strong> was last on the non-Davenport list for run-blocking, and allowed two pressures (both hurries).</p>
<p><strong>Devante Parker</strong> continues to display consistency and big-play ability. <strong>Greedy Williams</strong> was the only one to get stops on Parker (2 catches on 5 targets). Parker’s 91 yards were spread nearly equal yards across four different players in coverage (25, 23, 22, and 21 respectively on the four players). Parker averaged 5.8 yards after the catch (35 total RAC yards).</p>
<blockquote class="twitter-tweet" data-width="550" data-dnt="true">
<p lang="en" dir="ltr">Here&#39;s a look at the AFC receiving leaders since Miami returned from the bye week&#8230;<a href="https://twitter.com/DeVanteParker11?ref_src=twsrc%5Etfw">@DeVanteParker11</a> <a href="https://t.co/VUaxpsv3cz">pic.twitter.com/VUaxpsv3cz</a></p>
<p>&mdash; Brett Brecheisen (@bbrech) <a href="https://twitter.com/bbrech/status/1198972172364066816?ref_src=twsrc%5Etfw">November 25, 2019</a></p></blockquote>
<p><script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></p>
<p><strong>Parker</strong> is averaging a career-high in yards per target (8.37), and is on-track to beat both his reception and yardage high-water marks, both set in the 2016 playoff season.</p>
<p><strong>Allen Hurns</strong> dropped another pass, but continues to provide <strong>Ryan Fitzpatrick</strong> with a dependable underneath target. Hurns caught four of seven targets for 42 yards and a touchdown.</p>
<p><strong>Fitzpatrick</strong> dealt with drops and pressures all day (four drops and four sacks). He had a passer rating of 3.3 under pressure (3-of-10 with 38 yards and an interception).</p>
<p>The running game is getting no help from the backs. <strong>Kalen Ballage</strong> is on-track to be the first back in league history with over 100 carries and less than a 2.0 average. He picked up just 12 yards after contact and did not move the chains a single time Sunday.</p>
<p><strong>Patrick Laird</strong> picked up 20 yards on three carries, 10 of those coming after contact for a 3.33 YAC average. He dropped the one pass thrown in his direction.</p>
<p><span style="color: #008080; font-size: 18pt;"><strong>Defense:</strong></span></p>
<p><span style="color: #ff6600;"><strong>Snap Counts:</strong></span></p>
<table>
<tbody>
<tr>
<td width="234"><strong>Player</strong></td>
<td width="234"><strong>Snaps (% of Defensive Snaps)</strong></td>
</tr>
<tr>
<td width="234">DL Christian Wilkins</td>
<td width="234">64 (84%)</td>
</tr>
<tr>
<td width="234">DL Davon Godchaux</td>
<td width="234">60 (79%)</td>
</tr>
<tr>
<td width="234">DL John Jenkins</td>
<td width="234">55 (72%)</td>
</tr>
<tr>
<td width="234">DL Avery Moss</td>
<td width="234">23 (30%)</td>
</tr>
<tr>
<td width="234">DL Taco Charlton</td>
<td width="234">15 (20%)</td>
</tr>
<tr>
<td width="234">DL Gerald Willis</td>
<td width="234">8 (11%)</td>
</tr>
<tr>
<td width="234">LB Jerome Baker</td>
<td width="234">76 (100%)</td>
</tr>
<tr>
<td width="234">LB Vince Biegel</td>
<td width="234">69 (91%)</td>
</tr>
<tr>
<td width="234">LB Raekwon McMillan</td>
<td width="234">67 (88%)</td>
</tr>
<tr>
<td width="234">LB Charles Harris</td>
<td width="234">38 (50%)</td>
</tr>
<tr>
<td width="234">LB Sam Eguavoen</td>
<td width="234">9 (12%)</td>
</tr>
<tr>
<td width="234">LB Andrew Van Ginkel</td>
<td width="234">7 (9%)</td>
</tr>
<tr>
<td width="234">DB Steven Parker</td>
<td width="234">69 (91%)</td>
</tr>
<tr>
<td width="234">DB Nik Needham</td>
<td width="234">68 (89%)</td>
</tr>
<tr>
<td width="234">DB Eric Rowe</td>
<td width="234">59 (78%)</td>
</tr>
<tr>
<td width="234">DB Jomal Wiltz</td>
<td width="234">48 (63%)</td>
</tr>
<tr>
<td width="234">DB Ryan Lewis</td>
<td width="234">48 (63%)</td>
</tr>
<tr>
<td width="234">DB Ken Crawley</td>
<td width="234">36 (47%)</td>
</tr>
<tr>
<td width="234">DB Adrian Colbert</td>
<td width="234">12 (16%)</td>
</tr>
<tr>
<td width="234">DB Chris Lammons</td>
<td width="234">5 (7%)</td>
</tr>
</tbody>
</table>
<p>&nbsp;</p>
<p><strong>Christian Wilkins’</strong> progress from day-one of camp till now is encouraging. An 86% workload for an interior defensive lineman is no picnic, serving as a testament to his conditioning. And he’s not just taking up space, he’s making plays. He had four run-stops and three QB pressures Sunday, with the second best defensive grade on the team.</p>
<p>Top honors in that regard went to <strong>Taco Charlton</strong>, though he had one hurry and no run stops on 14 total reps.</p>
<p><strong>Davon Godchaux</strong> made six more tackles, two good for run stops, and had four quarterback pressures (1 sack, 2 hits, 1 hurry).</p>
<p><strong>Eric Rowe’s</strong> transition to safety continues to look like a great decision. He was targeted once in coverage (incompletion) and he made a tackle on his lone opportunity &#8212; a great play splitting a block and getting the back down in space.</p>
<p><strong>Nik Needham</strong> came back down to earth. He allowed a pair of touchdowns and 87 receiving yards on 6-of-7 passing.</p>
<p>The linebacker play was dreadful. <strong>Raekwon McMillan</strong>,<strong> Jerome Baker</strong> and<strong> Vince Biegel</strong> combined to miss four tackles and all three of them graded 57.4 or worse, a well-below average grade on PFF. They combined for three QB pressures on 37 pass rush attempts and made just six run stops on 97 running downs.</p>
<p><span style="font-size: 18pt; color: #008080;"><strong>Offensive Overhaul and the Quick Construction to Do So</strong></span></p>
<p>The 2001 New England Patriots endured a massive rebuild ahead of their eventual two-decade-long run atop the AFC East, and the football world in general. Signing 23 free agents and drafting 10 rookies (three of the first four picks coming on the offensive and defensive lines) the Patriots began building <strong>Bill Belichick’s</strong> vision of a championship team.</p>
<p>During the course of the last 20 years, New England have had to remake itself on the fly several times. One of the many offensive archetypes the Patriots constructed was based around a pair of tight ends that perfectly complemented each other’s playing style. One of those tight ends is no longer with us &#8212; the other is now on television &#8212; but they might provide Miami with a blueprint for its own offense.</p>
<p>This team needs reinforcements in the worst way at quarterback, running back, and across the entire offensive line. That leaves Miami with <strong>Devante Parker</strong>,<strong> Preston Williams</strong> and <strong>Mike Gesicki</strong> to build around.</p>
<p><strong>Allen Hurns</strong> received a two-year extension last week, and he’d serve nicely as the first man off the bench in Miami’s skill personnel. Number-three receivers don’t normally come off the bench, given that the NFL’s average for 11-personnel is roughly 60% of the league’s play calls. Hurns is suited perfectly to play 60% of the downs. There, he can utilize his strengths to uncover inside and against blitzes.</p>
<p>Miami would need its <strong>Rob Gronkowski</strong> (the run-blocking version) to fully unlock the potential of<strong> Gesicki</strong>. Perhaps that’s <strong>Durham Smythe</strong>, perhaps that player comes in free agency or the draft.</p>
<p>Operating under a 12-personnel base, Miami would then be left to focus its resources on the quarterback, running back and offensive line positions. The draft is littered with tailbacks, and the Phins figure to get a crack at the best quarterback in the draft with the soon-to-be top-five pick.</p>
<p>Miami might top the 23 free agents New England signed that year, and if training camp 2019 was any indication, Miami wants to be a power running team.</p>
<p>That’s just one of many, countless options the Dolphins will project ahead of the most important offseason in team history.</p>
<p><a href="https://twitter.com/WingfieldNFL"><strong>@WingfieldNFL</strong></a></p>
													</div><!--mvp-post-add-main-->
													<div class="mvp-post-add-link">
														<a href="https://www.lockedondolphins.com/dolphins/the-aftermath-dolphins-24-browns-41/" rel="bookmark"><span class="mvp-post-add-link-but">Continue Reading</span></a>
													</div><!--mvp-post-add-link-->
												</div><!--mvp-post-add-cont-->
											</div><!--mvp-post-add-body-->
										</div><!--mvp-post-add-story-->
																	</div><!--mvp-post-add-wrap-->
							</div><!--mvp-post-add-box-->
													</div><!--mvp-post-content-->
						</div><!--mvp-post-main-in-->
													<div id="mvp-side-wrap" class="left relative">
						<section id="mvp_ad_widget-2" class="mvp-side-widget mvp_ad_widget">			<div class="mvp-widget-ad left relative">
				<span class="mvp-ad-label">Advertisement</span>
				<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Locked On Dolphins 300x250 Sidebar -->
<ins class="adsbygoogle"
     style="display:inline-block;width:300px;height:250px"
     data-ad-client="ca-pub-3311849153835630"
     data-ad-slot="1814147880"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>			</div><!--mvp-widget-ad-->
		</section>		<section id="recent-posts-2" class="mvp-side-widget widget_recent_entries">		<div class="mvp-widget-home-head"><h4 class="mvp-widget-home-title"><span class="mvp-widget-home-title">LATEST</span></h4></div>		<ul>
											<li>
					<a href="https://www.lockedondolphins.com/dolphins/dolphins-eagles-week-13-preview/">Dolphins Eagles Week 13 Preview</a>
											<span class="post-date">November 28, 2019</span>
									</li>
											<li>
					<a href="https://www.lockedondolphins.com/dolphins/news/jakeem-grant-placed-on-injured-reserve/">Jakeem Grant placed on Injured Reserve</a>
											<span class="post-date">November 27, 2019</span>
									</li>
											<li>
					<a href="https://www.lockedondolphins.com/dolphins/where-would-the-2019-dolphins-be-with-lamar-jackson/">Where Would The 2019 Dolphins Be With Lamar Jackson?</a>
											<span class="post-date">November 27, 2019</span>
									</li>
											<li>
					<a href="https://www.lockedondolphins.com/dolphins/the-aftermath-dolphins-24-browns-41/">The Aftermath: Dolphins 24 Browns 41</a>
											<span class="post-date">November 26, 2019</span>
									</li>
											<li>
					<a href="https://www.lockedondolphins.com/dolphins/blocking-the-miami-dolphins-from-winning-a-super-bowl/">Blocking the Miami Dolphins From Winning a Super Bowl</a>
											<span class="post-date">November 25, 2019</span>
									</li>
					</ul>
		</section><section id="mvp_ad_widget-4" class="mvp-side-widget mvp_ad_widget">			<div class="mvp-widget-ad left relative">
				<span class="mvp-ad-label">Advertisement</span>
				<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Locked On Dolphins Skyscraper Sidebar -->
<ins class="adsbygoogle"
     style="display:inline-block;width:300px;height:600px"
     data-ad-client="ca-pub-3311849153835630"
     data-ad-slot="4572173168"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>			</div><!--mvp-widget-ad-->
		</section><section id="custom_html-4" class="widget_text mvp-side-widget widget_custom_html"><div class="textwidget custom-html-widget"><iframe frameborder="no" height="455" scrolling="no" src="https://player.megaphone.fm/podcast/PPY7775606149?tile=true" width="275"></iframe></div></section><section id="mvp_ad_widget-5" class="mvp-side-widget mvp_ad_widget">			<div class="mvp-widget-ad left relative">
				<span class="mvp-ad-label">Advertisement</span>
				<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Locked On Dolphins 300x250 Sidebar -->
<ins class="adsbygoogle"
     style="display:inline-block;width:300px;height:250px"
     data-ad-client="ca-pub-3311849153835630"
     data-ad-slot="1814147880"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>			</div><!--mvp-widget-ad-->
		</section>			</div><!--mvp-side-wrap-->											</div><!--mvp-post-main-out-->
				</div><!--mvp-post-main-->
							<div id="mvp-post-more-wrap" class="left relative">
					<h4 class="mvp-widget-home-title">
						<span class="mvp-widget-home-title">Trending</span>
					</h4>
					<ul class="mvp-post-more-list left relative">
													<a href="https://www.lockedondolphins.com/dolphins/blocking-the-miami-dolphins-from-winning-a-super-bowl/" rel="bookmark">
							<li>
																	<div class="mvp-post-more-img left relative">
										<img width="400" height="240" src="https://www.lockedondolphins.com/wp-content/uploads/2019/11/USATSI_13639139-400x240.jpg" class="mvp-reg-img wp-post-image" alt="" srcset="https://www.lockedondolphins.com/wp-content/uploads/2019/11/USATSI_13639139-400x240.jpg 400w, https://www.lockedondolphins.com/wp-content/uploads/2019/11/USATSI_13639139-1000x600.jpg 1000w, https://www.lockedondolphins.com/wp-content/uploads/2019/11/USATSI_13639139-590x354.jpg 590w" sizes="(max-width: 400px) 100vw, 400px" />										<img width="80" height="80" src="https://www.lockedondolphins.com/wp-content/uploads/2019/11/USATSI_13639139-80x80.jpg" class="mvp-mob-img wp-post-image" alt="" srcset="https://www.lockedondolphins.com/wp-content/uploads/2019/11/USATSI_13639139-80x80.jpg 80w, https://www.lockedondolphins.com/wp-content/uploads/2019/11/USATSI_13639139-150x150.jpg 150w" sizes="(max-width: 80px) 100vw, 80px" />																			</div><!--mvp-post-more-img-->
																<div class="mvp-post-more-text left relative">
									<div class="mvp-cat-date-wrap left relative">
										<span class="mvp-cd-cat left relative">Miami Dolphins</span><span class="mvp-cd-date left relative">3 days ago</span>
									</div><!--mvp-cat-date-wrap-->
									<p>Blocking the Miami Dolphins From Winning a Super Bowl</p>
								</div><!--mvp-post-more-text-->
							</li>
							</a>
													<a href="https://www.lockedondolphins.com/dolphins/should-the-miami-dolphins-be-interested-in-signing-colin-kaepernick/" rel="bookmark">
							<li>
																	<div class="mvp-post-more-img left relative">
										<img width="400" height="240" src="https://www.lockedondolphins.com/wp-content/uploads/2019/11/USATSI_9783243-400x240.jpg" class="mvp-reg-img wp-post-image" alt="Miami Dolphins Colin Kaepernick" srcset="https://www.lockedondolphins.com/wp-content/uploads/2019/11/USATSI_9783243-400x240.jpg 400w, https://www.lockedondolphins.com/wp-content/uploads/2019/11/USATSI_9783243-1000x600.jpg 1000w, https://www.lockedondolphins.com/wp-content/uploads/2019/11/USATSI_9783243-590x354.jpg 590w" sizes="(max-width: 400px) 100vw, 400px" />										<img width="80" height="80" src="https://www.lockedondolphins.com/wp-content/uploads/2019/11/USATSI_9783243-80x80.jpg" class="mvp-mob-img wp-post-image" alt="Miami Dolphins Colin Kaepernick" srcset="https://www.lockedondolphins.com/wp-content/uploads/2019/11/USATSI_9783243-80x80.jpg 80w, https://www.lockedondolphins.com/wp-content/uploads/2019/11/USATSI_9783243-150x150.jpg 150w" sizes="(max-width: 80px) 100vw, 80px" />																			</div><!--mvp-post-more-img-->
																<div class="mvp-post-more-text left relative">
									<div class="mvp-cat-date-wrap left relative">
										<span class="mvp-cd-cat left relative">Miami Dolphins</span><span class="mvp-cd-date left relative">2 weeks ago</span>
									</div><!--mvp-cat-date-wrap-->
									<p>Should the Miami Dolphins be interested in signing Colin Kaepernick?</p>
								</div><!--mvp-post-more-text-->
							</li>
							</a>
													<a href="https://www.lockedondolphins.com/dolphins/draft/scouting-college-footballs-top-2020-quarterback-prospects-week-13/" rel="bookmark">
							<li>
																	<div class="mvp-post-more-img left relative">
										<img width="400" height="240" src="https://www.lockedondolphins.com/wp-content/uploads/2019/11/USATSI_13610736-400x240.jpg" class="mvp-reg-img wp-post-image" alt="" srcset="https://www.lockedondolphins.com/wp-content/uploads/2019/11/USATSI_13610736-400x240.jpg 400w, https://www.lockedondolphins.com/wp-content/uploads/2019/11/USATSI_13610736-1000x600.jpg 1000w, https://www.lockedondolphins.com/wp-content/uploads/2019/11/USATSI_13610736-590x354.jpg 590w" sizes="(max-width: 400px) 100vw, 400px" />										<img width="80" height="80" src="https://www.lockedondolphins.com/wp-content/uploads/2019/11/USATSI_13610736-80x80.jpg" class="mvp-mob-img wp-post-image" alt="" srcset="https://www.lockedondolphins.com/wp-content/uploads/2019/11/USATSI_13610736-80x80.jpg 80w, https://www.lockedondolphins.com/wp-content/uploads/2019/11/USATSI_13610736-150x150.jpg 150w" sizes="(max-width: 80px) 100vw, 80px" />																			</div><!--mvp-post-more-img-->
																<div class="mvp-post-more-text left relative">
									<div class="mvp-cat-date-wrap left relative">
										<span class="mvp-cd-cat left relative">NFL Draft</span><span class="mvp-cd-date left relative">5 days ago</span>
									</div><!--mvp-cat-date-wrap-->
									<p>Scouting College Football&#8217;s Top 2020 Quarterback Prospects &#8211; Week 13</p>
								</div><!--mvp-post-more-text-->
							</li>
							</a>
													<a href="https://www.lockedondolphins.com/dolphins/draft/scouting-college-footballs-top-2020-quarterback-prospects-week-12/" rel="bookmark">
							<li>
																	<div class="mvp-post-more-img left relative">
										<img width="400" height="240" src="https://www.lockedondolphins.com/wp-content/uploads/2019/11/USATSI_13283940-400x240.jpg" class="mvp-reg-img wp-post-image" alt="" srcset="https://www.lockedondolphins.com/wp-content/uploads/2019/11/USATSI_13283940-400x240.jpg 400w, https://www.lockedondolphins.com/wp-content/uploads/2019/11/USATSI_13283940-1000x600.jpg 1000w, https://www.lockedondolphins.com/wp-content/uploads/2019/11/USATSI_13283940-590x354.jpg 590w" sizes="(max-width: 400px) 100vw, 400px" />										<img width="80" height="80" src="https://www.lockedondolphins.com/wp-content/uploads/2019/11/USATSI_13283940-80x80.jpg" class="mvp-mob-img wp-post-image" alt="" srcset="https://www.lockedondolphins.com/wp-content/uploads/2019/11/USATSI_13283940-80x80.jpg 80w, https://www.lockedondolphins.com/wp-content/uploads/2019/11/USATSI_13283940-150x150.jpg 150w" sizes="(max-width: 80px) 100vw, 80px" />																			</div><!--mvp-post-more-img-->
																<div class="mvp-post-more-text left relative">
									<div class="mvp-cat-date-wrap left relative">
										<span class="mvp-cd-cat left relative">NFL Draft</span><span class="mvp-cd-date left relative">2 weeks ago</span>
									</div><!--mvp-cat-date-wrap-->
									<p>Scouting College Football&#8217;s Top 2020 Quarterback Prospects &#8211; Week 12</p>
								</div><!--mvp-post-more-text-->
							</li>
							</a>
											</ul>
				</div><!--mvp-post-more-wrap-->
						</div><!--mvp-main-box-->
		</div><!--mvp-article-cont-->
		</article><!--mvp-article-wrap-->
			</div><!--mvp-main-body-wrap-->
			<footer id="mvp-foot-wrap" class="left relative">
				<div id="mvp-foot-top" class="left relative">
					<div class="mvp-main-box">
						<div id="mvp-foot-logo" class="left relative">
															<a href="https://www.lockedondolphins.com/"><img src="https://www.lockedondolphins.com/wp-content/uploads/2019/02/Locked-On-Dolphins-Podcast-Website-Logo-2.png" alt="Locked On Dolphins" data-rjs="2" /></a>
													</div><!--mvp-foot-logo-->
						<div id="mvp-foot-soc" class="left relative">
							<ul class="mvp-foot-soc-list left relative">
																									<li><a href="https://twitter.com/lockedonphins" target="_blank" class="fa fa-twitter fa-2"></a></li>
																																																															</ul>
						</div><!--mvp-foot-soc-->
						<div id="mvp-foot-menu-wrap" class="left relative">
							<div id="mvp-foot-menu" class="left relative">
								<div class="menu-dolphins-footer-menu-container"><ul id="menu-dolphins-footer-menu" class="menu"><li id="menu-item-5247" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5247"><a target="_blank" href="https://lockedonpodcasts.com/about/#contact">Contact</a></li>
<li id="menu-item-5248" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5248"><a target="_blank" href="https://lockedonpodcasts.com/advertising/">Advertise</a></li>
<li id="menu-item-5255" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5255"><a href="https://www.lockedondolphins.com/terms-and-conditions/">Terms and Conditions</a></li>
<li id="menu-item-5254" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5254"><a href="https://www.lockedondolphins.com/privacy-policy/">privacy policy</a></li>
<li id="menu-item-2572" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2572"><a href="https://www.lockedondolphins.com/cookie-policy-2/">Cookie Policy</a></li>
</ul></div>							</div><!--mvp-foot-menu-->
						</div><!--mvp-foot-menu-wrap-->
					</div><!--mvp-main-box-->
				</div><!--mvp-foot-top-->
				<div id="mvp-foot-bot" class="left relative">
					<div class="mvp-main-box">
						<div id="mvp-foot-copy" class="left relative">
							<p>Copyright © 2019 <a href="https://lockedonpodcasts.com/" target="_blank">Locked On Podcast Network</a>, All Rights Reserved.</p>
						</div><!--mvp-foot-copy-->
					</div><!--mvp-main-box-->
				</div><!--mvp-foot-bot-->
			</footer>
		</div><!--mvp-site-main-->
	</div><!--mvp-site-wall-->
</div><!--mvp-site-->
<div class="mvp-fly-top back-to-top">
	<i class="fa fa-angle-up fa-3"></i>
</div><!--mvp-fly-top-->
<div class="mvp-fly-fade mvp-fly-but-click">
</div><!--mvp-fly-fade-->
<script>
  var ai_insert_1 = function(){
    ai_insert ('after', 'div.mvp-main-blog-cont.left.relative', b64d ('PGRpdiBjbGFzcz0nY29kZS1ibG9jayBjb2RlLWJsb2NrLTEnIHN0eWxlPSdtYXJnaW46IDhweCBhdXRvOyB0ZXh0LWFsaWduOiBjZW50ZXI7IGRpc3BsYXk6IGJsb2NrOyBjbGVhcjogYm90aDsnPgo8c2NyaXB0IGFzeW5jIHNyYz0iLy9wYWdlYWQyLmdvb2dsZXN5bmRpY2F0aW9uLmNvbS9wYWdlYWQvanMvYWRzYnlnb29nbGUuanMiPjwvc2NyaXB0Pg0KPCEtLSBMb2NrZWQgT24gRG9scGhpbnMgNzI4eDkwIExlYWRlcmJvYXJkIC0tPg0KPGlucyBjbGFzcz0iYWRzYnlnb29nbGUiDQogICAgIHN0eWxlPSJkaXNwbGF5OmlubGluZS1ibG9jazt3aWR0aDo3MjhweDtoZWlnaHQ6OTBweCINCiAgICAgZGF0YS1hZC1jbGllbnQ9ImNhLXB1Yi0zMzExODQ5MTUzODM1NjMwIg0KICAgICBkYXRhLWFkLXNsb3Q9IjgzNzE4MTczNzkiPjwvaW5zPg0KPHNjcmlwdD4NCihhZHNieWdvb2dsZSA9IHdpbmRvdy5hZHNieWdvb2dsZSB8fCBbXSkucHVzaCh7fSk7DQo8L3NjcmlwdD48L2Rpdj4K'));
  };
  if (document.readyState === 'complete' || (document.readyState !== 'loading' && !document.documentElement.doScroll)) ai_insert_1 (); else document.addEventListener ('DOMContentLoaded', ai_insert_1);
</script>
<script>
setTimeout (function() {Array.prototype.forEach.call (document.querySelectorAll (".ai-viewports"), function (element, index) {ai_insert_code (element);});}, 10);

</script>
		<div data-theiaStickySidebar-sidebarSelector='".mvp-post-soc-wrap, #mvp-side-wrap"'
		     data-theiaStickySidebar-options='{"containerSelector":"","additionalMarginTop":140,"additionalMarginBottom":20,"updateSidebarHeight":false,"minWidth":1025,"sidebarBehavior":"stick-to-bottom","disableOnResponsiveLayouts":true}'></div>
		<script type='text/javascript'>
/* <![CDATA[ */
var ai_front = {"wp_ai":"5.1.3+2.4.22","insertion_before":"BEFORE","insertion_after":"AFTER","insertion_prepend":"PREPEND CONTENT","insertion_append":"APPEND CONTENT","insertion_replace_content":"REPLACE CONTENT","insertion_replace_element":"REPLACE ELEMENT","cancel":"Cancel","use":"Use","add":"Add","parent":"Parent","cancel_element_selection":"Cancel element selection","select_parent_element":"Select parent element","css_selector":"CSS selector","use_current_selector":"Use current selector","element":"ELEMENT","path":"PATH","selector":"SELECTOR","visible":"VISIBLE","hidden":"HIDDEN"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.lockedondolphins.com/wp-content/plugins/ad-inserter/includes/js/ai-jquery.js'></script>
<script type='text/javascript'>
function ai_insert(a,f,h){var e=-1!=f.indexOf(":eq")?jQuery(f):document.querySelectorAll(f);Array.prototype.forEach.call(e,function(b,e){selector_string=b.hasAttribute("id")?"#"+b.getAttribute("id"):b.hasAttribute("class")?"."+b.getAttribute("class").replace(RegExp(" ","g"),"."):"";var d=document.createElement("div");d.innerHTML=h;var c=d.getElementsByClassName("ai-selector-counter")[0];null!=c&&(c.innerText=e+1);c=d.getElementsByClassName("ai-debug-name ai-main")[0];if(null!=c){var g="";"before"==
a?g=ai_front.insertion_before:"after"==a?g=ai_front.insertion_after:"prepend"==a?g=ai_front.insertion_prepend:"append"==a?g=ai_front.insertion_append:"replace-content"==a?g=ai_front.insertion_replace_content:"replace-element"==a&&(g=ai_front.insertion_replace_element);c.innerText=g+" "+f+" ("+b.tagName.toLowerCase()+selector_string+")"}c=document.createRange().createContextualFragment(d.innerHTML);"before"==a?b.parentNode.insertBefore(c,b):"after"==a?b.parentNode.insertBefore(c,b.nextSibling):"prepend"==
a?b.insertBefore(c,b.firstChild):"append"==a?b.insertBefore(c,null):"replace-content"==a?b.innerHTML=d.innerHTML:"replace-element"==a&&(b.parentNode.insertBefore(c,b),b.parentNode.removeChild(b))})}
function ai_insert_code(a){function f(a,b){return null==a?!1:a.classList?a.classList.contains(b):-1<(" "+a.className+" ").indexOf(" "+b+" ")}function h(a,b){null!=a&&(a.classList?a.classList.add(b):a.className+=" "+b)}function e(a,b){null!=a&&(a.classList?a.classList.remove(b):a.className=a.className.replace(new RegExp("(^|\\b)"+b.split(" ").join("|")+"(\\b|$)","gi")," "))}var b=!!(a.offsetWidth||a.offsetHeight||a.getClientRects().length);a.getAttribute("data-block");if(b){b=a.getAttribute("data-code");
var k=a.getAttribute("data-insertion"),d=a.getAttribute("data-selector");null!=b&&(null!=k&&null!=d?document.querySelectorAll(d).length&&(ai_insert(k,d,b64d(b)),e(a,"ai-viewports")):(b=document.createRange().createContextualFragment(b64d(b)),a.parentNode.insertBefore(b,a.nextSibling),e(a,"ai-viewports")))}else b=a.previousElementSibling,f(b,"ai-debug-bar")&&f(b,"ai-debug-script")&&(e(b,"ai-debug-script"),h(b,"ai-debug-viewport-invisible")),e(a,"ai-viewports")}
function b64e(a){return btoa(encodeURIComponent(a).replace(/%([0-9A-F]{2})/g,function(a,h){return String.fromCharCode("0x"+h)}))}function b64d(a){return decodeURIComponent(atob(a).split("").map(function(a){return"%"+("00"+a.charCodeAt(0).toString(16)).slice(-2)}).join(""))};
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var wpcf7 = {"apiSettings":{"root":"https:\/\/www.lockedondolphins.com\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"}};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.lockedondolphins.com/wp-content/plugins/contact-form-7/includes/js/scripts.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var cnArgs = {"ajaxurl":"https:\/\/www.lockedondolphins.com\/wp-admin\/admin-ajax.php","hideEffect":"slide","onScroll":"yes","onScrollOffset":"200","cookieName":"cookie_notice_accepted","cookieValue":"true","cookieTime":"2147483647","cookiePath":"\/","cookieDomain":"","redirection":"","cache":"","refuse":"no","revoke_cookies":"0","revoke_cookies_opt":"automatic","secure":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.lockedondolphins.com/wp-content/plugins/cookie-notice/js/front.min.js'></script>
<script type='text/javascript' src='https://www.lockedondolphins.com/wp-content/plugins/theia-sticky-sidebar/js/ResizeSensor.js'></script>
<script type='text/javascript' src='https://www.lockedondolphins.com/wp-content/plugins/theia-sticky-sidebar/js/theia-sticky-sidebar.js'></script>
<script type='text/javascript' src='https://www.lockedondolphins.com/wp-content/plugins/theia-sticky-sidebar/js/main.js'></script>
<script type='text/javascript' src='https://www.lockedondolphins.com/wp-content/themes/zox-news/js/mvpcustom.js'></script>
<script type='text/javascript'>
	jQuery(document).ready(function($) {
	$(window).load(function(){
	var leaderHeight = $("#mvp-leader-wrap").outerHeight();
	var logoHeight = $("#mvp-main-nav-top").outerHeight();
	var botHeight = $("#mvp-main-nav-bot").outerHeight();
	var navHeight = $("#mvp-main-head-wrap").outerHeight();
	var headerHeight = navHeight + leaderHeight;
	var aboveNav = leaderHeight + logoHeight;
	var totalHeight = logoHeight + botHeight;
	var previousScroll = 0;
	$(window).scroll(function(event){
			var scroll = $(this).scrollTop();
			if ($(window).scrollTop() > aboveNav){
				$("#mvp-main-nav-top").addClass("mvp-nav-small");
				$("#mvp-main-nav-bot").css("margin-top", logoHeight );
			} else {
				$("#mvp-main-nav-top").removeClass("mvp-nav-small");
				$("#mvp-main-nav-bot").css("margin-top","0");
			}
			if ($(window).scrollTop() > headerHeight){
				$("#mvp-main-nav-top").addClass("mvp-fixed");
				$("#mvp-main-nav-bot").addClass("mvp-fixed1");
				$("#mvp-main-body-wrap").css("margin-top", totalHeight );
				$("#mvp-main-nav-top").addClass("mvp-fixed-shadow");
				$(".mvp-nav-top-mid").addClass("mvp-fixed-post");
				$(".mvp-drop-nav-title").show();
				$(".mvp-fly-top").addClass("mvp-to-top");
	    		if(scroll < previousScroll) {
					$("#mvp-main-nav-bot").addClass("mvp-fixed2");
					$("#mvp-main-nav-top").removeClass("mvp-fixed-shadow");
					$("#mvp-main-nav-top").removeClass("mvp-soc-mob-up");
					$("#mvp-soc-mob-wrap").removeClass("mvp-soc-mob-up");
				} else {
					$("#mvp-main-nav-bot").removeClass("mvp-fixed2");
					$("#mvp-main-nav-top").addClass("mvp-fixed-shadow");
					$("#mvp-main-nav-top").addClass("mvp-soc-mob-up");
					$("#mvp-soc-mob-wrap").addClass("mvp-soc-mob-up");
				}
			} else {
				$("#mvp-main-nav-top").removeClass("mvp-fixed");
				$("#mvp-main-nav-bot").removeClass("mvp-fixed1");
				$("#mvp-main-nav-bot").removeClass("mvp-fixed2");
				$("#mvp-main-body-wrap").css("margin-top","0");
				$("#mvp-main-nav-top").removeClass("mvp-fixed-shadow");
				$(".mvp-nav-top-mid").removeClass("mvp-fixed-post");
				$(".mvp-drop-nav-title").hide();
	    		$(".mvp-fly-top").removeClass("mvp-to-top");
			}
			previousScroll = scroll;
	});
	});
	});
	

	jQuery(document).ready(function($) {
	// Mobile Social Buttons More
	$(window).load(function(){
 		$(".mvp-soc-mob-right").on("click", function(){
			$("#mvp-soc-mob-wrap").toggleClass("mvp-soc-mob-more");
  		});
  	});
	});
  	

	jQuery(document).ready(function($) {
	$(".menu-item-has-children a").click(function(event){
	  event.stopPropagation();
	  location.href = this.href;
  	});

	$(".menu-item-has-children").click(function(){
    	  $(this).addClass("toggled");
    	  if($(".menu-item-has-children").hasClass("toggled"))
    	  {
    	  $(this).children("ul").toggle();
	  $(".mvp-fly-nav-menu").getNiceScroll().resize();
	  }
	  $(this).toggleClass("tog-minus");
    	  return false;
  	});

	// Main Menu Scroll
	$(window).load(function(){
	  $(".mvp-fly-nav-menu").niceScroll({cursorcolor:"#888",cursorwidth: 7,cursorborder: 0,zindex:999999});
	});
	});
	

	jQuery(document).ready(function($) {
	$(".infinite-content").infinitescroll({
	  navSelector: ".mvp-nav-links",
	  nextSelector: ".mvp-nav-links a:first",
	  itemSelector: ".infinite-post",
	  errorCallback: function(){ $(".mvp-inf-more-but").css("display", "none") }
	});
	$(window).unbind(".infscr");
	$(".mvp-inf-more-but").click(function(){
   		$(".infinite-content").infinitescroll("retrieve");
        	return false;
	});
	$(window).load(function(){
		if ($(".mvp-nav-links a").length) {
			$(".mvp-inf-more-but").css("display","inline-block");
		} else {
			$(".mvp-inf-more-but").css("display","none");
		}
	});
	});
	
</script>
<script type='text/javascript' src='https://www.lockedondolphins.com/wp-content/themes/zox-news/js/scripts.js'></script>
<script type='text/javascript' src='https://www.lockedondolphins.com/wp-content/themes/zox-news/js/retina.js'></script>
<script type='text/javascript' src='https://www.lockedondolphins.com/wp-content/themes/zox-news/js/flexslider.js'></script>
<script type='text/javascript' src='https://www.lockedondolphins.com/wp-content/themes/zox-news/js/jquery.infinitescroll.min.js'></script>
<script type='text/javascript' src='https://www.lockedondolphins.com/wp-includes/js/comment-reply.min.js'></script>
<script type='text/javascript' src='https://www.lockedondolphins.com/wp-includes/js/wp-embed.min.js'></script>
<script async="async" type='text/javascript' src='https://www.lockedondolphins.com/wp-content/plugins/akismet/_inc/form.js'></script>

			<div id="cookie-notice" role="banner" class="cn-bottom bootstrap" style="color: #fff; background-color: #000;"><div class="cookie-notice-container"><span id="cn-notice-text">We use cookies to provide you with the best experience on our website. If you stick around, we'll assume that you're happy with it.</span><a href="#" id="cn-accept-cookie" data-cookie-set="accept" class="cn-set-cookie cn-button bootstrap button">Ok</a>
				</div>
				
			</div></body>
</html>